.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Enhancement Workshop > (mEAn) Bot.Admin Mod / ServerLoader > (mEAn) ServerLoader > General Forum - ServerLoader
General Forum - ServerLoader Post your questions, comments, solutions and suggestions for the ServerLoader in here

Reply
 
Thread Tools
Re: MeanLoader Server Startup
Old
  (#61)
azn_ahn
Member
 
Status: Offline
Posts: 3
Join Date: Aug 2006
Default Re: MeanLoader Server Startup - 04-08-2006

I don't quite understand the second part...For 1.6 you would put -game cstrike, but what about for Counter-Strike: Source?

Thanks in Advance
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#62)
azn_ahn
Member
 
Status: Offline
Posts: 3
Join Date: Aug 2006
Default Re: MeanLoader Server Startup - 04-08-2006

I don't quite understand what the second part is..For 1.6 you would put -game cstrike but what would you put for CS: S?

Thanks
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#63)
botmeister
Ex-Council Member
 
botmeister's Avatar
 
Status: Offline
Posts: 1,090
Join Date: Nov 2003
Location: Canada
Default Re: MeanLoader Server Startup - 09-08-2006

Can you run CS:S from a command-line prompt? If so, then whatever you use for the command-line is what you'll use for the loader.


Maker of the (mEAn) Bot.Admin Manager

"In theory, there is no difference between theory and practice. But, in practice, there is." - Jan L.A. van de Snepscheut
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#64)
supermop
Member
 
Status: Offline
Posts: 1
Join Date: Sep 2006
Default Re: MeanLoader Server Startup - 12-09-2006

Hi there,

I'm having trouble with my NS servers (hlds.exe). Everytime I log out of the server account, it restarts the server. Also whenever i stop it, hlds.exe crashes. Seems to be a problem with meanloader initial setup, but i cant quite pinpoint what.

Quote:
[Settings]
ServiceName = #Classic
RestartInterval = 5000
NumberOfProcesses = 1
ServicePriority = normal
UserInterface = no

[Process_0]
StartDir = D:\gameservers\Classic
ProcessName = nsclassic
AppName = D:\gameservers\Classic\hlds.exe
CommandLine = -console -port 27015 -game ns +map ns_tanith +maxplayers 22 +exec server.cfg
StartPause = 1000
StopPause = 1000
UserInterface = No
AutoRestart = Yes
Priority = normal
Paused = No
Window = ShowNA
NumOfRespChecks = 1
PrcFileLogging = Yes
Theres my meanloader.ini if it helps.

Edit: I read the known issues.txt - i see this has issues with hlds That makes me a sad panda... the old server admin had got round this somehow, but I have no idea. Is there any other process/server loaders like this that are compatible with hlds?

Last edited by supermop; 12-09-2006 at 10:00..
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#65)
Topspeed
Member
 
Status: Offline
Posts: 2
Join Date: Feb 2007
Default Re: MeanLoader Server Startup - 11-02-2007

Hi

@Supermop: try this:
CommandLine = -console -game ns -port 27015 +map ns_tanith +maxplayers 22 +exec server.cfg

I've got a problem with CS:Source and meanloader. I can't show any windows of my srcds.exe.
Quote:
[Settings]
ServiceName = (mEAn) Server Loader
RestartInterval = 5000
NumberOfProcesses = 1
ServicePriority = Low
UserInterface = yes

[Process_0]
AffinityMask = 1
StartDir =d:\public01\srcds
ProcessName = public01
AppName = d:\public01\srcds\srcds.exe
CommandLine = -console -game cstrike +maxplayers 20 +map de_dust -tickrate 100 -autoupdate -fps_max 0 -mp_dynamicpricing 0
StartPause = 1000
StopPause = 1000
UserInterface = Yes
AutoRestart = Yes
Priority = normal
Paused = No
Window = Show
NumOfRespChecks = 1
PrcFileLogging = Yes
window is set to show, but never was displayed anything. gameserver is running well, but i can't show window of this task even with this command:
Quote:
@rem set the path to the server loader, eg c:\srvload
set loaderpath=d:\downloads\meanloader122\meanloader

%loaderpath%\meanloader -show public01
I even tried to run without "-console" in commandline, no success.
Any ideas?
thanks for helping!
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#66)
Topspeed
Member
 
Status: Offline
Posts: 2
Join Date: Feb 2007
Default Re: MeanLoader Server Startup - 12-02-2007

ok, problem solved! when connecting remotely with Windows RemoteDesktop-Tool, then srcds.exe-window isn't shown, but with VNC or similar tools the window is beeing shown!
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#67)
Bartman
Member
 
Status: Offline
Posts: 5
Join Date: Nov 2007
Default Re: MeanLoader Server Startup - 08-11-2007

I'm trying to get the server loader to work on our new box, but for some reason it won't actually start anything. Even after a clean reinstall (turned off error reporting, ran loader_(un)install) and using the beta version to set core affinity, it still reports 'successfully' loading things but nothing shows up for some reason.

Here are the ini contents and some log output with the default processes. The only thing changed here is C:\WINNT\ --> C:\WINDOWS\ in both paths.

Code:
[Settings]
ServiceName = (mEAn) Server Loader
RestartInterval = 5000
NumberOfProcesses = 1
ServicePriority = Low
UserInterface = yes

[Process_0]
StartDir = 
ProcessName = calc
AppName = C:\WINDOWS\system32\calc.exe
CommandLine = 
AffinityMask = 1
StartPause = 1000
StopPause = 1000
UserInterface = Yes
AutoRestart = Yes
Priority = normal
Paused = No
Window = Minimize
NumOfRespChecks = 1
PrcFileLogging = Yes

[Process_1]
StartDir = 
ProcessName = notepad
AppName = C:\WINDOWS\system32\notepad.exe
CommandLine = 
AffinityMask = 1
StartPause = 1000
StopPause = 1000
UserInterface = Yes
AutoRestart = Yes
Priority = normal
Paused = No
Window = Minimize
NumOfRespChecks = 1
PrcFileLogging = Yes
Code:
Thu Nov 08 20:56:39 2007 :: Attempting to install the service ...
Thu Nov 08 20:56:39 2007 :: Version is 1.22.01 build 20060403.00
Thu Nov 08 20:56:40 2007 :: *** The service will be Interactive ***
Thu Nov 08 20:56:40 2007 :: The service (mEAn) Server Loader was successfully installed.
Thu Nov 08 20:56:40 2007 :: Attempting to start the service ...
Thu Nov 08 20:56:40 2007 ::    ServiceName = (mEAn) Server Loader
Thu Nov 08 20:56:40 2007 ::    UserInterface = Yes
Thu Nov 08 20:56:40 2007 ::    RestartInterval = 5000
Thu Nov 08 20:56:40 2007 :: Loading process values from ini file ...
Thu Nov 08 20:56:40 2007 :: 
Thu Nov 08 20:56:40 2007 :: [Process_0]
Thu Nov 08 20:56:40 2007 ::    AppName = C:\WINDOWS\system32\calc.exe
Thu Nov 08 20:56:40 2007 ::    ProcessName = calc
Thu Nov 08 20:56:40 2007 ::    CommandLine = 
Thu Nov 08 20:56:40 2007 ::    StartDir = 
Thu Nov 08 20:56:40 2007 ::    Priority = normal
Thu Nov 08 20:56:40 2007 ::    AffinityMask = 1
Thu Nov 08 20:56:40 2007 ::    Window = Minimize
Thu Nov 08 20:56:40 2007 ::    AutoRestart = Yes
Thu Nov 08 20:56:40 2007 ::    Paused = No
Thu Nov 08 20:56:40 2007 ::    StartPause = 1000
Thu Nov 08 20:56:40 2007 ::    StopPause = 1000
Thu Nov 08 20:56:40 2007 ::    NumOfRespChecks = 1
Thu Nov 08 20:56:40 2007 ::    PrcFileLogging = Yes
Thu Nov 08 20:56:40 2007 :: 
Thu Nov 08 20:56:40 2007 :: [Process_1]
Thu Nov 08 20:56:40 2007 ::    AppName = C:\WINDOWS\system32\notepad.exe
Thu Nov 08 20:56:40 2007 ::    ProcessName = notepad
Thu Nov 08 20:56:40 2007 ::    CommandLine = 
Thu Nov 08 20:56:40 2007 ::    StartDir = 
Thu Nov 08 20:56:40 2007 ::    Priority = normal
Thu Nov 08 20:56:40 2007 ::    AffinityMask = 1
Thu Nov 08 20:56:40 2007 ::    Window = Minimize
Thu Nov 08 20:56:40 2007 ::    AutoRestart = Yes
Thu Nov 08 20:56:40 2007 ::    Paused = No
Thu Nov 08 20:56:40 2007 ::    StartPause = 1000
Thu Nov 08 20:56:40 2007 ::    StopPause = 1000
Thu Nov 08 20:56:40 2007 ::    NumOfRespChecks = 1
Thu Nov 08 20:56:40 2007 ::    PrcFileLogging = Yes
Thu Nov 08 20:56:40 2007 :: 
Thu Nov 08 20:56:40 2007 :: Load completed.
Thu Nov 08 20:56:40 2007 :: The service is now running the main thread.
Thu Nov 08 20:56:40 2007 :: Attempting to start processes ...
Thu Nov 08 20:56:41 2007 :: The service was successfully started.
Thu Nov 08 20:56:41 2007 :: Started program C:\WINDOWS\system32\calc.exe
Thu Nov 08 20:56:41 2007 :: Affinity Mask (AM): 1
Thu Nov 08 20:56:41 2007 :: Affinity Mask (AM): 1 Process AM: 3 System AM: 3
Thu Nov 08 20:56:41 2007 :: 
Thu Nov 08 20:56:42 2007 :: Started program C:\WINDOWS\system32\notepad.exe
Thu Nov 08 20:56:42 2007 :: Affinity Mask (AM): 1
Thu Nov 08 20:56:42 2007 :: Affinity Mask (AM): 1 Process AM: 3 System AM: 3
Thu Nov 08 20:56:42 2007 ::
The result of this is that I can find the server loader service in the services list (started, automatic) but calc and notepad aren't actually started, nor can they be found in the task manager list.
Previously I'd get all the server windows to nicely show up in the task bar, now nothing.

As for the machine itself: it's a Core 2 Duo 6600 with WinXP SP2, and it previously did work on a near identical machine with windows server 2003. I'm connecting to it with remote desktop, should that matter for process visibility.
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#68)
Drek
Member
 
Status: Offline
Posts: 63
Join Date: Feb 2004
Default Re: MeanLoader Server Startup - 09-11-2007

Have you actually tried loading a game server with it?


AMD Athlon XP 1700+
1GB PC-2100 DDR SDRAM
Debian Etch 4.0 GNU/Linux (custom kernel 2.6.18.5)
Day of Defeat, Day of Defeat: Source, Firearms
Natural Selection, Team Fortress Classic
Metamod-P
AMX Mod X
Source Mod
Admin Mod
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#69)
Bartman
Member
 
Status: Offline
Posts: 5
Join Date: Nov 2007
Default Re: MeanLoader Server Startup - 09-11-2007

Of course! First thing I did was copy the settings over from our old server, where they did work. So I'm guessing the problem isn't with the variables but with the serverloader itself. I'm wondering if there are any incompatibilities with recent hardware?
   
Reply With Quote
Re: MeanLoader Server Startup
Old
  (#70)
Drek
Member
 
Status: Offline
Posts: 63
Join Date: Feb 2004
Default Re: MeanLoader Server Startup - 09-11-2007

Is the new box running Windows Vista by any chance?


AMD Athlon XP 1700+
1GB PC-2100 DDR SDRAM
Debian Etch 4.0 GNU/Linux (custom kernel 2.6.18.5)
Day of Defeat, Day of Defeat: Source, Firearms
Natural Selection, Team Fortress Classic
Metamod-P
AMX Mod X
Source Mod
Admin Mod
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com