.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > Sandbot
Sandbot A bot for Gunman Chronicles and They Hunger - by tschumann

Reply
 
Thread Tools
Re: progress
Old
  (#81)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 16-12-2017

Odd - I guess that's just an annoying reality of different distros doing different things.
Anyway, with https://github.com/tschumann/sandbot...a7287ffafbc558 you should be able to compile without changing things manually (hopefully). I think I'll have to stick with this approach as compiling for multiple different distros isn't something I have the time to do.

What was the problem with team picks that you mentioned? I didn't quite understand what was happening.
  
Reply With Quote
Re: progress
Old
  (#82)
RoboCop
vBulletin Veteran
 
Status: Offline
Posts: 159
Join Date: Feb 2013
Location: Dundee, Scotland
Default Re: progress - 17-12-2017

Quote:
Originally Posted by tschumann View Post
Odd - I guess that's just an annoying reality of different distros doing different things.
Anyway, with https://github.com/tschumann/sandbot...a7287ffafbc558 you should be able to compile without changing things manually (hopefully). I think I'll have to stick with this approach as compiling for multiple different distros isn't something I have the time to do.

What was the problem with team picks that you mentioned? I didn't quite understand what was happening.
Well in the Metamod loaded version of Sandbot the bots are joined but won't select any team nor spawn. It's kinda like it was depending on HPB's bot_start.cpp for the bots to work for Op4CTF maps.





vBulletin Webmaster since 2001
  
Reply With Quote
Re: progress
Old
  (#83)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 19-12-2017

Hm, I'll check it out and see if I can replicate it.
  
Reply With Quote
Re: progress
Old
  (#84)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 23-12-2017

I was unable to replicate but I've added some logging - see https://github.com/tschumann/sandbot...eeec1355a34684 (and the previous patch) - could you build and then tell me what you see in the console when it runs?
What version of MetaMod are you using too?
  
Reply With Quote
Re: progress
Old
  (#85)
RoboCop
vBulletin Veteran
 
Status: Offline
Posts: 159
Join Date: Feb 2013
Location: Dundee, Scotland
Default Re: progress - 23-12-2017

Well this may surprise you, because it appears that this Sandbot hates AMXX v1.8.2 for some odd reason. However it does seem to work well on Spawn Chat Protection and my modified version of AdminMod:-


Code:
 [  1] Adminmod, v2.50.61-APG (MM), Jun 25 2017, by Alfred Reynolds & RoboCop <robocop@lycos.co.uk>, see www.adminmod.org
 [  2] HLGuard, v1.9.n10, 08/07/2006, by The Z Project, see http://www.thezproject.org/
 [  3] Spawn & Chat Protection Plugin, v2.02, 24/11/2015, by Jussi Kivilinna <jussi.kivilinna@mbnet.fi>, see http://koti.mbnet
There must be some AMXX plugin or maybe the AMXX Core Engine that is blocking those bots from selecting a team and spawning. However despite AMXX ruining Sandbot the teams are a bit uneven and it does block some bots from selecting a team.

http://steamcommunity.com/id/SCO_Rob...01045018411047





vBulletin Webmaster since 2001
  
Reply With Quote
Re: progress
Old
  (#86)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 24-12-2017

Ah right. I think someone else has had a similar issue before (some other plugin breaking something). Annoying.

Yeah I'm aware that the joining code isn't great - it's on my todo list to make teams even etc.

Anyway, looks like I should be good to tag a release soon. Thanks for the help.
  
Reply With Quote
Re: progress
Old
  (#87)
RoboCop
vBulletin Veteran
 
Status: Offline
Posts: 159
Join Date: Feb 2013
Location: Dundee, Scotland
Default Re: progress - 24-12-2017

It's a pleasure and happy xmas!





vBulletin Webmaster since 2001
  
Reply With Quote
Re: progress
Old
  (#88)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 26-12-2017

Merry Christmas to you too!
I've released v0.4.1.1 too: https://github.com/tschumann/sandbot...s/tag/v0.4.1.1

I now realise I've forgotten to add some more notes to the readme. I guess I'll fix that up after I merge it back to master.
  
Reply With Quote
Re: progress
Old
  (#89)
RoboCop
vBulletin Veteran
 
Status: Offline
Posts: 159
Join Date: Feb 2013
Location: Dundee, Scotland
Default Re: progress - 27-12-2017

Code:
LoadLibrary failed on /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so: ./libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so)
Looks like that newer version still gives me that error from above on my Xubuntu 14.04 server for OP4CTF. But when I recompiled the src code on my Linux Mint with g++-4.8 it appears to work better. I don't know if your compiler from your Linux Distro or GCC have some missing dependencies.





vBulletin Webmaster since 2001
  
Reply With Quote
Re: progress
Old
  (#90)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 27-12-2017

Yeah I'm aware that's still a problem - some mismatch in libstdc++ versions which I haven't figured out yet (need to go back through this thread and try and nail it all down).
I wanted to get the main fix of waypoints not working in Linux out - in the meantime yeah it should compile if all else fails.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com