.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > FritzBot > Developers Forum
Developers Forum A place just for coders, testers, and waypointers to get together and discuss the FritzBot project.

Reply
 
Thread Tools
running FritzBot ET under ET-L (ET-Legacy project)
Old
  (#1)
TomTom
ET Waypointing team member
 
TomTom's Avatar
 
Status: Offline
Posts: 738
Join Date: Jun 2006
Default running FritzBot ET under ET-L (ET-Legacy project) - 08-06-2014

This thread is for reporting on issues running FritzBot ET under ET-L (ET-Legacy project)

Please use it to report any issues with that combination.

Please provide as much relevant detail as possible.

For now the following are assumed for any post unless you state otherwise;

  1. Operating system: Windows XP or later
  2. Listen server using etl.exe
  3. \fritzbot placed as sub-folder to where etl.exe resides
  4. etl version: Development release: 2.71rc3
  5. FritzBot ET version: 0.70c (fully patched to support larger maps)
  6. All official waypoint packs installed (Fritz0.pk3, Fritz1_1.00.pk3, Fritz1_1.00.pk3, Fritz3_1.00.pk3) in \fritzbot

The goal of the thread is to add FritzBot ET as a supported mod to the ET-Legacy website.


P.S. @Crapshoot if you see this, please make this thread a sticky. thx
   
Reply With Quote
Re: running FritzBot ET under ET-L (ET-Legacy project)
Old
  (#2)
TomTom
ET Waypointing team member
 
TomTom's Avatar
 
Status: Offline
Posts: 738
Join Date: Jun 2006
Default Re: running FritzBot ET under ET-L (ET-Legacy project) - 08-06-2014

So far works fine (in fueldump) in Win-7

Not sure my pak files are where their faq says
http://dev.etlegacy.com/projects/etl...art-what-to-do
but they work. And I copied over fritzbot's mp_bin.pk3 even though they said mp_bin.pk3 is not needed anymore by ETL.

Only issue noted was I needed my old etconfig for the mouse to work setting up etl (before I added the fritzbot mod), something they don't recommend.

Was able to turn on waypoint editor to see waypoints (but I won't waypoint inside etl for now jic)

(BTW I used the binaries instead of the window-installer version)
   
Reply With Quote
Re: running FritzBot ET under ET-L (ET-Legacy project)
Old
  (#3)
TomTom
ET Waypointing team member
 
TomTom's Avatar
 
Status: Offline
Posts: 738
Join Date: Jun 2006
Post Re: running FritzBot ET under ET-L (ET-Legacy project) - 09-06-2014

After sleeping on it I realized this thread could do with a clarification.

Compiled in to the game code of FritzBot ET are various bugs from the original ET 2.60. Those bugs fixes, now in ET_Legacy, FritzBot will not benefit from unless Mal's old bot code is made available for recompile. As to ET.exe changes, FritzBot ET might benefit from if no changes in the interface between files is required.

So this thread is to address;
  1. Can a \fritzbot folder reside in the ET-Legacy path? (so far yes).
  2. Can FritzBot ET be invoked and run in that path? (offline so far yes ).
  3. What are the locations for the FritzBot folders and files that work (2 options, more later).
  4. Can the waypoint editor be used in such an installation? (seemingly yes, but more tests needed).
  5. Can a LAN game with a listen fritzbot server run from that location?
  6. Can a LAN game with a dedicated fritzbot server run from that location? (etlded.exe)
  7. Can an ET-legacy client connect to an old 2.60B ET server running FritzBot ET mod? (the server not the client).
  8. Can an ET-legacy client connect to an ET-Legacy server running FritzBot ET mod?
  9. Are there things in the ET_legacy client that would benefit using it instead of the fritzbot client in a LAN? (see old discussions on Whaleclient)
  10. Are there any resource limits that affect running fritzbot under ET-Legacy?
  11. Are there any resources in ET_Legacy mod compatible and desirable with the old fritzbot? (.WAVs, JPGs...)
  12. What quirks (big and small) occur in ET-Legacy but not ET when running fritzbot? (so far maybe 1 minor one waypointing).

P.S. ignore my mp_bin reference in the previous post, wrong file
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com