.:: Bots United ::.  
filebase forums discord server github wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps yapb

Go Back   .:: Bots United ::. > Cyborg Factory > FritzBot
FritzBot A bot for Return To Castle Wolfenstein - by Maleficus Return to Castle Wolfenstein

Reply
 
Thread Tools
Which version of ET should I use?
Old
  (#1)
RR99i
Member
 
RR99i's Avatar
 
Status: Offline
Posts: 123
Join Date: Jul 2005
Location: Indiana, USA
Default Which version of ET should I use? - 12-07-2007

Hey Maleficus, TomTom, and everyone,

As of right now I'm using Wolfenstein - Enemy Territory 2.60 with FritzBot 0.70b plus Final Patch. As I know now, some of the maps included in ET 2.60, don't have waypoints for the bots. When I try to make a server with one of these maps, the game freezes. Have to force the game with Task Manager to close the game. Just want to know what version of ET I should use. Also the best place to download that version.

Thanks,

RR
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#2)
Nova2001
Member
 
Nova2001's Avatar
 
Status: Offline
Posts: 75
Join Date: Dec 2005
Default Re: Which version of ET should I use? - 12-07-2007

Sounds to me like your set-up is fine. Some maps aren't waypointed, or can't be, and you just don't play with those. Such is the breaks.

Railgun should be the only unsupported default map.

Unless what you're saying here is that you're not trying to play with bots, and it's crashing anyways. If this is the case, you need to start your server without engaging Fritzbot. I made a second desktop link and removed "+set fs_game fritzbot" from the shortcut target. That does the trick.
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#3)
TomTom
ET Waypointing team member
 
TomTom's Avatar
 
Status: Offline
Posts: 742
Join Date: Jun 2006
Default Re: Which version of ET should I use? - 14-07-2007

Fritzbot ET works properly with both 2.60 and 2.60b versions of ET. 2.55 should not be used, nor should Fritzbot ET be combined with other mods.

Normally you can host a map that has no waypoints and errors will appear in the console but you can still wander about (any bots added will stand stupidly about complaining about no goals).
However ET may handles errors differently for campaigns. E.G. If the first map in a campaign has no .nav then ET disconnects. And if the map is not OK to start campaigns it may even hang. Typically Fritzbot crashes are just regular ET crashes (e.g. no more entities, lack of memory allocs...) but there are a small number of Fritzbot specific items that Waypointers must deal with.

So...
(1) Verify that your ET is stable (some past posters have found that a temp file or regular file was likely corrupt).
(2) verify that your server can host Fritzbot (server+client combined). If not why not? Single Objective OK? campaign OK? com_hunkmegs ok?
(3) Then try a dedicated server with oasis map. Then purposely load in a single objective map not supported, say railgun. Is that the first place it crashes? Check the server logs for more insight.

If you still have problems post more details. I don't run dedicated servers normally so you should communicate with those who do (Nedd3h, vlvttch, lordbeaver, Docfrog, Adder, AIM, ...)
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#4)
nedd3h
Member
 
Status: Offline
Posts: 161
Join Date: Jul 2006
Location: Qld - Australia
Default Re: Which version of ET should I use? - 14-07-2007

use ET v2.60b in my opinion
(not essential but highly recommended)
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#5)
RR99i
Member
 
RR99i's Avatar
 
Status: Offline
Posts: 123
Join Date: Jul 2005
Location: Indiana, USA
Default Re: Which version of ET should I use? - 16-07-2007

Hi Nova2001, TomTom and nedd3h,

Beach Invasion (a Single-Map Objective map) is one of the maps, that I try to load. When click "Start Server", the next screen "Connecting" just freezes there. So I have to force a close of ET. I may not have a waypoint for the map. A few other maps, like Gold Rush for Single-Map Objective, will load. Bots are working great! I believe it may have to do with a needed waypoint. Like nedd3h said, even if not needed, go with v2.60b. I'll still go to that version, just for having the latest, even if beta. I'm not hosting a dedicated server. I should look around, but is there a pack of waypoints for all the maps that come with v2.60 or v2.60b? So I can just simply copy the waypoints, over to the Fritz0.pk3 file?

I'm very with FritzBot, don't know what do with with new waypoints. Since my file compression program, PowerArchiver, is showing I can edit the Fritz0.pk3... just not sure. Last, I hope this is understandable.
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#6)
nedd3h
Member
 
Status: Offline
Posts: 161
Join Date: Jul 2006
Location: Qld - Australia
Default Re: Which version of ET should I use? - 16-07-2007

ET v2.60 and v2.60b are independent on how fritzbot work (b does not mean beta btw)
still go to v2.60b (other reasons for this)
latest fritzbot is v0.70b patched - link -
ensure mod correctly installed
ensure et_beach.pk3 is in your etmain folder

if the above is all good try again
if same problem open your console and see what it says
post console info here

if there is nothing in console i'll get you to condump it
(will explain that next step)
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#7)
TomTom
ET Waypointing team member
 
TomTom's Avatar
 
Status: Offline
Posts: 742
Join Date: Jun 2006
Default Re: Which version of ET should I use? - 16-07-2007

using condumps requires that ET not hang (dumps are ok if ET just disconnects).

This wiki topic on testing waypoints shows how to set ET to continuously log messages to 2 files;

http://wiki.bots-united.com/index.ph...28Log_Files.29

The etconsole.log file is wiped when ET is started so don't forget to grab it after killing ET. You can view it and the etserver.log file with notepad.
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#8)
TomTom
ET Waypointing team member
 
TomTom's Avatar
 
Status: Offline
Posts: 742
Join Date: Jun 2006
Default Re: Which version of ET should I use? - 17-07-2007

Did some tests and came across one possible curiosity. It seems that original ET lists in the Host Game display all the <mapname>.arena files that it finds in the scripts subdirectory (etmain\scripts), and when you run Fritzbot ET it also includes those it finds in fritzbot\scripts. ET does not check for the bsp file until you try to load it. So what happens is your sound plays and the window display shows that it is "connecting..." but if you open the console (`) you see the message "Can't find map maps\et_beach.bsp" or whatever mapname you selected. No command I can think of gets the display back to the main menu (although load a good map like /map oasis, then after it loads /disconnect will get you back to the main menu).

So why is that a problem? After all the bsp and arena files are together in the file et_beach.pk3 right? Well there is a modified et_beach.arena file in the fritbot map pack fritz0.pk3. So if you don't have the proper et_beach.pk3 in \etmain selecting "beach invasion" in the host submenu will get you seemingly frozen out.

It seems that when we waypointers include an edited arena file we create the possibility for this rare problem to occur.

The good news is I only see 4 maps in the 2 official map paks that have included arena files.

If this is what is happening in your case we apologize for any confusion...
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#9)
RR99i
Member
 
RR99i's Avatar
 
Status: Offline
Posts: 123
Join Date: Jul 2005
Location: Indiana, USA
Default Re: Which version of ET should I use? - 20-07-2007

I downloaded et_beach.pk3, from here, http://maps.arni.name/etmain/et_beach.pk3 . Put that file in the etmain folder. That didn't fix the problem. Why? Because when I load Beach Invasion, which loaded. After the warmup, before the start of the match. The game would crash, after warmup. But... thanks so much nedd3h! I download the latest 2.60b .exe file for ET. That helped with my problem! Everything seems to be running great!

TomTom, I'm new with ET, not sure where to find the etconsole.log or etserver.log. With not having problems right now, since downloaded 2.60b, it'll come in handy if any other problems occur.
  
Reply With Quote
Re: Which version of ET should I use?
Old
  (#10)
nedd3h
Member
 
Status: Offline
Posts: 161
Join Date: Jul 2006
Location: Qld - Australia
Default Re: Which version of ET should I use? - 20-07-2007

well i have no idea why going to v2.60b worked but good news!
(as far as i know that release was a security update only)

  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com