.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Releases, Installers, Docs & Coding
Releases, Installers, Docs & Coding Where the official development happens

Reply
 
Thread Tools
Re: My bots dont work with AMXX 1.60?
Old
  (#11)
Guenhwyvar
Member
 
Status: Offline
Posts: 15
Join Date: Aug 2005
Default Re: My bots dont work with AMXX 1.60? - 17-03-2006

System conf: Athlon 64 with Suse 9.3 x64. AMXMODX v1.60, MetaMod v1.18p26.

meta list:
[ 2] POD-Bot mm RUN - podbot_mm_amd64. vR2b46b ini Chlvl ANY

My podbot_mm_amd64.so filesize is 319.374 bytes (EDIT: downladed here: http://koti.mbnet.fi/axh/amd64.binaries.html )


If I try the binary of this thread (the first one and the steamfixed version, c at the end):

[ 1] <podbot_mm_amd6 badf load podbot_mm_amd64. v - ini - -


I tried everything without AMXX loaded and only with the metamod-p (1.18p26).

For some weeks now (until day before yesterday), this (vR2b46b) worked great, no crashes, bots joined and played in the game.

Any suggestions/ideas are welcome!

Last edited by Guenhwyvar; 17-03-2006 at 20:27..
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#12)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,415
Join Date: Apr 2004
Default Re: My bots dont work with AMXX 1.60? - 17-03-2006

Did You try this one?
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#13)
Guenhwyvar
Member
 
Status: Offline
Posts: 15
Join Date: Aug 2005
Default Re: My bots dont work with AMXX 1.60? - 18-03-2006

thanks, it wasn't the solution, but the reason for another try:

I downloaded the mentioned version and like most of the others it wasnt loaded (badf).

Then, I pointed out these messages after quitting the server with hlsw:

Quote:
00:26:23 [META] WARNING: ini: Plugin '<podbot_mm_amd64.so>' has newer file, but unexpected status (badfile)
00:26:23 [META] ini: Read plugin config for: <podbot_mm_amd64.so>
00:26:23 [META] ini: Finished reading plugins list: /shc/fun/cstrike/addons/metamod/plugins.ini; Found 1 plugins
00:26:23 [META] dll: Updating plugins...
00:26:23 [META] WARNING: dll: Failed query plugin '<podbot_mm_amd64.so>'; Couldn't open file '/shc/fun/cstrike/addons/podbot/podbot_mm_amd64.so': libstdc++.so.6: cannot open shared object file: No such file or directory
00:26:23 [META] WARNING: dll: Skipping plugin '<podbot_mm_amd64.so>'; couldn't query
00:26:23 [META] dll: Finished updating 1 plugins; kept 0, loaded 0, unloaded 0, reloaded 0, delayed 0
00:26:23 Server shutdown
Maybe I shouldve seen this earlier, but I never paid much attention to the shutdown messages .

I checked my suse install and did only found a libstdc++.so.5.

Via wget I downloaded a rpm package called "libstdc++34-3.4.3_16-0.1.x86_64.rpm" (link) and put it on (rpm -Uvh ./libstdc++34-3.4.3_16-0.1.x86_64.rpm).

Another restart brought up a running (and working!) vR2b46d .

I do not really understand, what happened (*g, perhaps someone could lose some smart words about that), but it's maybe helpful to some people.

greetz
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#14)
Guenhwyvar
Member
 
Status: Offline
Posts: 15
Join Date: Aug 2005
Default Re: My bots dont work with AMXX 1.60? - 19-01-2007

Hm, weird, I get a similar error now.

Just set up a fresh cs 1.6 install on a new root (opensuse 10, 32bit). AMXMODX v1.76c, MetaMod v1.19p2.

Quote:
L 01/18/2007 - 23:47:05: [META] ini: Read plugin config for: AMX Mod X
L 01/18/2007 - 23:47:05: [META] WARNING: ini: Plugin '<podbot_mm_i386.so>' has newer file, but unexpected status (badfile)
L 01/18/2007 - 23:47:05: [META] ini: Read plugin config for: <podbot_mm_i386.so>
L 01/18/2007 - 23:47:05: [META] ini: Finished reading plugins list: /cstrike/addons/metamod/plugins.ini; Found 2 plugins
L 01/18/2007 - 23:47:05: [META] dll: Updating plugins...
L 01/18/2007 - 23:47:05: [META] WARNING: dll: Failed query plugin '<podbot_mm_i386.so>'; Couldn't open file '/cstrike/addons/podbot/podbot_mm_i386.so': libstdc++.so.5: cannot open shared object file: No such file or directory
L 01/18/2007 - 23:47:05: [META] WARNING: dll: Skipping plugin '<podbot_mm_i386.so>'; couldn't query
L 01/18/2007 - 23:47:05: [META] dll: Finished updating 8 plugins; kept 1, loaded 0, unloaded 0, reloaded 0, delayed 0
This happens with and without AMXMODX running.

I don't want to install foreign rpm packages - is there any other way to get the bots running?
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#15)
jeefo
ouch
 
jeefo's Avatar
 
Status: Offline
Posts: 445
Join Date: Nov 2005
Location: Saint-Petersburg
Default Re: My bots dont work with AMXX 1.60? - 19-01-2007

Recompile bot source on your OS
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#16)
Guenhwyvar
Member
 
Status: Offline
Posts: 15
Join Date: Aug 2005
Default Re: My bots dont work with AMXX 1.60? - 19-01-2007

@jeefo
bad hint

I crawled around the forum and found this topic:
http://forums.bots-united.com/showthread.php?t=4494

The solution in there worked for me. It seems if the binary (v3.0B17) is still compiled with an old/outdated version of make.
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#17)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,415
Join Date: Apr 2004
Default Re: My bots dont work with AMXX 1.60? - 20-01-2007

Since I don't have linux I cannot test anything with it. I must just believe in that makefile I have. If You can write me any advices what should I do to compile under windows xp the linux binaries with cygwin to get it working with libstdc++.so.6 - feel free to post me the solution. Grab from th efolebase the sources of podbot mm and look into existing makefile and tell me what should I change with it.
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#18)
jeefo
ouch
 
jeefo's Avatar
 
Status: Offline
Posts: 445
Join Date: Nov 2005
Location: Saint-Petersburg
Default Re: My bots dont work with AMXX 1.60? - 20-01-2007

@KWo:
You can try to kill all usage of C++ in bot, use Vector<> class from AMXX, and new/delete wrappers, form there too. So final SO, will not require libstdc++ at all ... I'm now trying todo similar stuff with yapb.
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#19)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,564
Join Date: Jul 2004
Location: Bulgaria
Default Re: My bots dont work with AMXX 1.60? - 20-01-2007

There is nothing bad in STL. If there is so much problems with the libraries just compile them staticly.
   
Reply With Quote
Re: My bots dont work with AMXX 1.60?
Old
  (#20)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,415
Join Date: Apr 2004
Default Re: My bots dont work with AMXX 1.60? - 21-01-2007

Quote:
Originally Posted by THE_STORM View Post
There is nothing bad in STL. If there is so much problems with the libraries just compile them staticly.
How? I think it may extend dramatically the length of linux binaries...

About the topic starter problem - I didn't notice it before - he is using mm 1.18, but pb mm requires mm 1.19...
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com