.:: Bots United ::.  
filebase forums discord server github wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Releases, Installers, Docs & Coding
Releases, Installers, Docs & Coding Where the official development happens

Reply
 
Thread Tools
POD-Bot v3B24 released by [APG]
Old
  (#1)
RoboCop
vBulletin Veteran
 
RoboCop's Avatar
 
Status: Offline
Posts: 179
Join Date: Feb 2013
Location: Dundee, Scotland
Default POD-Bot v3B24 released by [APG] - 31-03-2020

https://github.com/APGRoboCop/podbot.../tag/V3B24-APG

V3B24 PODBot released but only for Windows server. G++ isn't working with the recent updates as those `strncpy_s` and `strcpy_s` is a "no" for Linux.

But that's not all I've managed to recompile Metamod-P39 with some performance fixes.

https://github.com/APGRoboCop/metamo...s/tag/v1.21p39





vBulletin Webmaster since 2001
  
Reply With Quote
Re: POD-Bot v3B24 released by [APG]
Old
  (#2)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,614
Join Date: Jul 2004
Location: Bulgaria
Default Re: POD-Bot v3B24 released by [APG] - 31-03-2020

Just use the non _s versions for Linux.
  
Reply With Quote
Re: POD-Bot v3B24 released by [APG]
Old
  (#3)
RoboCop
vBulletin Veteran
 
RoboCop's Avatar
 
Status: Offline
Posts: 179
Join Date: Feb 2013
Location: Dundee, Scotland
Default Re: POD-Bot v3B24 released by [APG] - 31-03-2020

OK I got it now thanks!





vBulletin Webmaster since 2001
  
Reply With Quote
Re: POD-Bot v3B24 released by [APG]
Old
  (#4)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,425
Join Date: Apr 2004
Default Re: POD-Bot v3B24 released by [APG] - 14-04-2020

From that what I remember, it was my M$ Visual C++ some of latest versions forced me to use those _s commands instead old ones.

http://forums.bots-united.com/showpo...&postcount=571
I don't remember how I recompiled "my" latest sources for linux. I had to add some IF defined or something like this. Doesn't matter - if the sources You have taken from latest beta, it's OK. Good luck with fixing bugs and improving podbot mm.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com