.:: Bots United ::.  
filebase forums discord server github wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Bug Reports
Bug Reports Post any bug you experience with the latest release of this bot here

Reply
 
Thread Tools
Turns Off amxmodx
Old
  (#1)
endoglastic
Member
 
Status: Offline
Posts: 7
Join Date: Jan 2009
Default Turns Off amxmodx - 30-11-2009

My amxmodx addon the whole thing, turns off after about 70 hours of uptime with these bots. Everytime it turns off randomly, it was after 13 hours of the server being up and now its 70 hours. All my plugins turn off in amxmodx including amxmodx itself, so you know admin is useless. The only thing that is running......... is podbotmm.
  
Reply With Quote
Re: Turns Off amxmodx
Old
  (#2)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: Turns Off amxmodx - 01-12-2009

I can promise - there is no code in podbot mm to turn off Your amxmodx.
You can make an easy test.
1. Stop the server
2. Rename Your current addons folder to addons_old (as a backup of Your files).
3. Get All-In-One package from the filebase.
4. Unzip all the crap into Your main cstrike/czero folder (depanding of the mod You are playing - CS1.6 or CZERO).
5. Edit only users.ini in addons\amxomdx\config folder (to add Your-self as an admin). Don't change/add/remove any plugin from that package.
6. Start the server and keep it running for couple of hours - to see if also there is a problem.
7. If after 48hours You cannot see the problem with switching off Your amxmodx - step by step - add Your custom plugins (from addons_old folder) to that working amxmodx All-In-One comes with.
8. Again - keep it running couple of hours then add 2-3 new plugins from Your old configuration. Finally You will narrow down the plugin or group of plugins making the troubles on Your server.
  
Reply With Quote
Re: Turns Off amxmodx
Old
  (#3)
endoglastic
Member
 
Status: Offline
Posts: 7
Join Date: Jan 2009
Default Re: Turns Off amxmodx - 01-12-2009

Ok, i will do that. So there is no amxmodx versoin 1.8.1? Because that was what i was using with meta v1.19 and pb v3b20b. So there should not be any conflict with the newest versoin of amx?
  
Reply With Quote
Re: Turns Off amxmodx
Old
  (#4)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: Turns Off amxmodx - 02-12-2009

Quote:
Originally Posted by endoglastic View Post
So there is no amxmodx versoin 1.8.1? Because that was what i was using with meta v1.19 and pb v3b20b.
All-In-One comes with AMX X 1.8.1, metamod 1.19 and pb mm V3B20b. If the whole amxmodx folder is replaced - there is no conflict in the version. If You are using older version of AMX X and You will tryto add to "my" AMX X (from All-In-One) Your old plugins (without compiling them against amx x 1.8.1) - You have to expect conflicts - but only in this case.
  
Reply With Quote
Re: Turns Off amxmodx
Old
  (#5)
endoglastic
Member
 
Status: Offline
Posts: 7
Join Date: Jan 2009
Default Re: Turns Off amxmodx - 02-12-2009

Kwo, i have a question, do you think i can send you my addons folder, because this problem is hard to explain, i even did a whole complete rebuild and it still did the same thing, even with only gungame running on my server(which is what the server is) is still turned off. My addons folder is like 65megs, and i can put it on rapidshare.com for you to download. I dont know if you know how to make a dedicated serv to use it on or what not, but what do you think about my idea? It is very hard to determine the problem because nothing shows up in the logs except just all the plugins including amxmodx not loading on a random map.
  
Reply With Quote
Re: Turns Off amxmodx
Old
  (#6)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: Turns Off amxmodx - 02-12-2009

GunGame mod may explain a lot. Try to take a look what is happening with guns when the bot dies. Normally the weapon should dispear (at list CSDM does it so), so when the player gets spawned he gets the new weapon. That means the number of entities on the server doesn't increase. But if for some reason removing weapons after dieing player/bot is not working correctly - the amount of entities increases - end - if the map is neverending (mp_timelimit 0, objectivies - like bombs, bombzones, hostages - are removed from the map) - after certain amount of hours the memory allocated for CS gets corupted - which may cause side effects like turning off some plugins.
You can easy test if I'm right - just put on Your server as many bots as possible (so You dont need to wait 70 hours for the problem, but it should occur faster). Watch them as a spectator to see what is happening with their weapons after dieing or after they want to pickup another gun from the ground (so they have to drop their own one).
Another possibility - if You are using linux dedicated server and if You are using optimized metamod (i.e. metamod-p 1.19p32) I have seen the server which this metamod was causing really bad things (the memory got completly wrong info - some cvars registered by another amxx plugin, moved cvars between plugins etc). I don't know what was really the problem, but switching to the standard metamod fixed couple of problems.
  
Reply With Quote
Re: Turns Off amxmodx
Old
  (#7)
endoglastic
Member
 
Status: Offline
Posts: 7
Join Date: Jan 2009
Default Re: Turns Off amxmodx - 02-12-2009

Yes, i have noticed with the bots/players that the guns do dissapear, eliminating extra entities. Maybe i will also trying creating a server with 32 slots but not have it online for the public and see if it happends faster, or maybe its just my computer having problems. But it is a windows dedicated server and only about 12-14 slots since my internet cannot hold any more than that.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com