.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > HPB_bot
HPB_bot The trusty good ole mechs by botman HLDMTFCOpposing ForceDMCFront Line Force

Reply
 
Thread Tools
Need Help with HPB_Bot 4.0 w/Recongamer Server
Old
  (#1)
Vegita
Guest
 
Status:
Posts: n/a
Default Need Help with HPB_Bot 4.0 w/Recongamer Server - 24-11-2004

I have had a server with recongamer now for quite awhile, I recently had it shut down but saved all my files and reopened an account just the other day. The bot I used before was HPB_Bot 3.0 and always worked great for me with no issues. I run a Severian Teamplay server and now that I have my server all backup I upgraded to the new HPB_Bot 4.0, I basically kept all my files from 3.0 and just added in the new dll and made it the metamod plugin. Before I had an autoexec for the bots to start but since the new one doesnt need that I took that out. I also had a game.cfg which had this in it

mp_teamplay 1301
mp_teamlist "recon;gman;hgrunt;scientist;helmet;zombie;"

So heres the dilema: Now with my server if I leave the game.cfg in there the bots appear to load up right and look good but if you join the server it locks up and sends you back to desktop. Now, if you delete the game.cfg it works fine and you can join but the bots are all model gina. Also, forgot to say that they dont talk no more either. I have configured in my HPB_bot.cfg this info which worked from the last time with 3.0

min_bots 1
max_bots 2
bot_chat_percent 8
bot_taunt_percent 20
bot_whine_percent 20
bot_chat_tag_percent 95
bot_chat_drop_percent 3
bot_chat_swap_percent 1
bot_chat_lower_percent 50
bot_logo_percent 5
bot_reaction_time 1
random_color 1

# add 1 bots using the default skill level (a random skin will be chosen)
bot_strafe_percent 75
addbot gman player 1
addbot hgrunt noob 1

So thats pretty much it, not working and need a solution to help fix this issue. I would greatly appreciate anyone's help asap. thnx

Vegita
  
Reply With Quote
Re: Need Help with HPB_Bot 4.0 w/Recongamer Server
Old
  (#2)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: Need Help with HPB_Bot 4.0 w/Recongamer Server - 25-11-2004

problem solved over MSN. There was too many teams in his mp_teamlist. I'm not sure it's a bot limitation ; I checked the array sizes and the char strings, and no overflow can happen unless the game hits 32 teams or a model name is larger than 16 characters. The recipient string for the mp_teamlist strcpy is dim'ed at 512 bytes. So I think it's rather a HL restriction.

No bot update required, phew



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com