.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > HPB_bot
HPB_bot The trusty good ole mechs by botman HLDMTFCOpposing ForceDMCFront Line Force

Reply
 
Thread Tools
4.0 template crash at cs 1.6
Old
  (#1)
koraX
Member
 
koraX's Avatar
 
Status: Offline
Posts: 145
Join Date: Jan 2004
Location: Slovak Republic
Default 4.0 template crash at cs 1.6 - 25-01-2005

Well I downloaded HPB_bot template 4.0, compiled and it worked in cs 1.5. This same dll crashes in cs 1.6

CS crash when I try to "addbot" new bot.

Further investigation revealed that :
newest racc works both in cs 1.5 and 1.6
HPB_bot 4.0 works both in cs 1.5 and 1.6
however these 2 bots are under metamod.

So anyb knows where is the bug in HPB_bot template 4.0 which causes cs 1.6 to crash when trying to add a bot ?


kXBot
koraX's utils
- see my homepage for other projects (OpenGL CSG Editor, FAT16 Sim, NNetwork Sim, ...)
  
Reply With Quote
Re: 4.0 template crash at cs 1.6
Old
  (#2)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: 4.0 template crash at cs 1.6 - 25-01-2005

I know I will sound like an ass, but I have little time here (and other priorities)... would you mind debugging this one yourself ?



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: 4.0 template crash at cs 1.6
Old
  (#3)
koraX
Member
 
koraX's Avatar
 
Status: Offline
Posts: 145
Join Date: Jan 2004
Location: Slovak Republic
Default Re: 4.0 template crash at cs 1.6 - 25-01-2005

Quote:
Originally Posted by Pierre-Marie Baty
I know I will sound like an ass, but I have little time here (and other priorities)... would you mind debugging this one yourself ?
It's OK I had this problem for month and I debugged it. However crash was not caused by bots code. It created bot and returned succesfully, and then HL crashed. So it was probably some wrong return value/setting that caused hl engine to crash. I'll debug it again, but my hopes are low

EDIT : So I set breakpoint in dll.cpp in ClientCommand function on "BotCreate( pEntity, arg1, arg2, arg3, arg4 );" calling. after I invoked addbot command in game, program paused and I debugged ClientCommand function without any error and after It exited ClientCommand function it went back to disassembly, 'cause execution was back in Half-life engine. and right after I resumed execution, oh-so-helpful Unhandled exception on address 0xC0...5. Acces violation reading memory ...
I hope there are some advanced debugging stuff I do not know and there is way to debug this error...

Question is, what was changed from cs 1.5 to cs 1.6 ? Maybe that way I can find what is missing in the bot...


kXBot
koraX's utils
- see my homepage for other projects (OpenGL CSG Editor, FAT16 Sim, NNetwork Sim, ...)

Last edited by koraX; 25-01-2005 at 20:31..
  
Reply With Quote
Re: 4.0 template crash at cs 1.6
Old
  (#4)
dub
Member
 
dub's Avatar
 
Status: Offline
Posts: 89
Join Date: Aug 2004
Location: UK
Default Re: 4.0 template crash at cs 1.6 - 25-01-2005

korax i just downloaded the hpb template 4 & tested it, and i dont seem to have the crash. Maybe you changed something & forgot about it.

edit.
.NET might be compiling something wrong ???


Dubb`s Coding Cave WiP - YeGods - Free Image hosting
4u-servers.co.uk : YeGods Gin Palace II - Refloated - 195.20.108.30:27025

Last edited by dub; 25-01-2005 at 20:50..
  
Reply With Quote
Re: 4.0 template crash at cs 1.6
Old
  (#5)
koraX
Member
 
koraX's Avatar
 
Status: Offline
Posts: 145
Join Date: Jan 2004
Location: Slovak Republic
Default Re: 4.0 template crash at cs 1.6 - 25-01-2005

Quote:
Originally Posted by dub
korax i just downloaded the hpb template 4 & tested it, and i dont seem to have the crash. Maybe you changed something & forgot about it.

edit.
.NET might be compiling something wrong ???
I haven't changed anything. I downloaded source code, unpacked, compiled and tested it

And I started all this because my own bot does the same. Maybe it is time to switch to metamod


kXBot
koraX's utils
- see my homepage for other projects (OpenGL CSG Editor, FAT16 Sim, NNetwork Sim, ...)
  
Reply With Quote
Re: 4.0 template crash at cs 1.6
Old
  (#6)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: 4.0 template crash at cs 1.6 - 25-01-2005

hmmm... thinking about something here

Try adding FREE_PRIVATE() in BotCreate() ?
check the RACC source code to know where and how...



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: 4.0 template crash at cs 1.6
Old
  (#7)
koraX
Member
 
koraX's Avatar
 
Status: Offline
Posts: 145
Join Date: Jan 2004
Location: Slovak Republic
Default Re: 4.0 template crash at cs 1.6 - 26-01-2005

well I fixed it. Problem was not in bot, but in cs. Thank you for your concern and have some LED fun


kXBot
koraX's utils
- see my homepage for other projects (OpenGL CSG Editor, FAT16 Sim, NNetwork Sim, ...)
  
Reply With Quote
Re: 4.0 template crash at cs 1.6
Old
  (#8)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: 4.0 template crash at cs 1.6 - 26-01-2005

What was it ?



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com