.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > HPB_bot
HPB_bot The trusty good ole mechs by botman HLDMTFCOpposing ForceDMCFront Line Force

Reply
 
Thread Tools
Please help w/metamod-hpb compileing
Old
  (#1)
BIGman10in
Guest
 
Status:
Posts: n/a
Default Please help w/metamod-hpb compileing - 19-08-2004

Ok so i have the metamod code, the hpb bot code, and the updated source code.

I have read that inorder to compile hpb you need all the others. But what folders are they supost to go in?? I couldent find that info any where. I opened the .dsp with a text editor and tried puting the code in the folders it wanted it to be in. But still errors where files couldent be found.

So then i got mad and changed all the (even for metamod)
<something.h>
to
"something.h"
and put all the code in one happy little folder, but still files not found...

I think maybe the metamod .dsp file got messed up during decompression, because it looks all messed up. I will show you.
Quote:
# Microsoft Developer Studio Project File - Name="metamod" - Package Owner=<4> # Microsoft Developer Studio Generated Build File, Format Version 6.00 # ** DO NOT EDIT ** # TARGTYPE "Win32 (x86) Dynamic-Link Library" 0x0102 CFG=metamod - Win32 Debug
!MESSAGE This is not a valid makefile. To build this project using NMAKE, !MESSAGE use the Export Makefile command and run !MESSAGE !MESSAGE NMAKE /f "metamod.mak". !MESSAGE
!MESSAGE You can specify a configuration when running NMAKE !MESSAGE by defining the macro CFG on the command line. For example:
!MESSAGE !MESSAGE NMAKE /f "metamod.mak" CFG="metamod - Win32 Debug"
!MESSAGE !MESSAGE Possible choices for configuration are:
!MESSAGE !MESSAGE "metamod - Win32 Release" (based on "Win32 (x86) Dynamic-Link Library") !MESSAGE "metamod - Win32 Debug" (based on "Win32 (x86) Dynamic-Link Library") !MESSAGE # Begin Project # PROP AllowPerConfigDependencies 0
and it goes on like that, So do you think that is the problem?

Or what are the proper directories for the code to go into.

I miss the days before steam when life was simple...

Last edited by BIGman10in; 19-08-2004 at 06:59..
  
Reply With Quote
Re: Please help w/metamod-hpb compileing
Old
  (#2)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: Please help w/metamod-hpb compileing - 20-08-2004

I think that's because the archives were packed in UNIX format (with the end of line characters being 0x0A) and you are uncompressing them into Windows in Windows format (with the end of lines being 0x0D0A). Check to see if your unpacker doesn't have an option to automatically convert text files from UNIX to DOS. I bet your problem is here.



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com