.:: Bots United ::.  
filebase forums discord server github wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps yapb

Go Back   .:: Bots United ::. > Cyborg Factory > Sandbot
Sandbot A bot for Gunman Chronicles and They Hunger - by tschumann

Reply
 
Thread Tools
Re: progress
Old
  (#171)
Persephone
Member
 
Status: Offline
Posts: 57
Join Date: Mar 2014
Location: Indonesia
Default Re: progress - 13-04-2019

Entity that exploded into little creatures when you touched it ?

Are you talking about the creatures from my video on 1:52 ? It was called decore_sittingtubemortar

About the monster, have you noticed if there are some monsters on my map like Mines, Eagle, Pteranodon, and even Helicopter? There are Mini Turrets on each hill too but I didn't show them. You can kill them if you want.

By the way, I want to ask two things to you :

1. There is an enemy called "Turret" which bigger than Mini Turret. However, unlike on Half Life, this Turret seems invulnerable. How to kill it? Even Chemical Gun with zero acid, zero neutral, and base maxed, it won't help too much.

2. In map editor, there is an entity called "weapon_aicore" which also present on my map. However, I still don't know what a function of that weapon until now. Can you explain it to me?


About your bot : Yeah, I forgot about observer mode set to 1, lol xD
  
Reply With Quote
Re: progress
Old
  (#172)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 235
Join Date: Apr 2011
Location: Australia
Default Re: progress - 14-04-2019

Ah thanks - yeah I saw a few monsters around the map but I didn't recognise that one.

Not sure about the turret (or most Gunman Chronicles entities) but if it's anything like GMan in Half-Life the TakeDamage method probably does not subtract from pev->health.

weapon_aicore is used in the campaign in some maps to trigger some entities but doesn't do any damage I believe.
  
Reply With Quote
Re: progress
Old
  (#173)
Persephone
Member
 
Status: Offline
Posts: 57
Join Date: Mar 2014
Location: Indonesia
Default Re: progress - 02-05-2019

Tschumann, I need your help

I want to create an Opposing Force map with CTF gameplay. I've placed a base, flag, etc. Also I'm not forget to set "defaultctf" to 1 so it wouldn't become a deathmatch map.

However, when I tried it, I noticed if something has gone wrong. I didn't see any flag on my map. Instead, look at the bottom left corner. It seems my map was set to "cp mode" instead of "ctf mode", for some reason.

Well, can you help me sir? How to set the gameplay into CTF mode???

  
Reply With Quote
Re: progress
Old
  (#174)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 235
Join Date: Apr 2011
Location: Australia
Default Re: progress - 04-05-2019

I'm not sure - I've never done any mapping for Opposing Force but do you have a info_ctfdetect entity?

Also, I've started repurposing botman's waypointing tool to work with Sandbot: https://github.com/tschumann/sandbot-wptgen
Completely untested but it compiles.
  
Reply With Quote
Re: progress
Old
  (#175)
Persephone
Member
 
Status: Offline
Posts: 57
Join Date: Mar 2014
Location: Indonesia
Default Re: progress - 04-05-2019

Yes, I have entity called "info_ctfdetect"

However, it was used to converting a map from deathmatch into ctf mode. I never faced this problem in the past. This is my first time I find if that entity will converting my map to cp mode instead of ctf. I don't know why @_@

I don't remember when the last time I made a ctf map for Opposing Force. But I'm swear if I never encountered this error before.
  
Reply With Quote
Re: progress
Old
  (#176)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 235
Join Date: Apr 2011
Location: Australia
Default Re: progress - 05-05-2019

Yeah that's strange - the map name starts with op4ctf_ as well I assume? Not sure how the game checks.

You could try asking at https://twhl.info/ as there are lots of GoldSource mappers still there.
  
Reply With Quote
Re: progress
Old
  (#177)
Persephone
Member
 
Status: Offline
Posts: 57
Join Date: Mar 2014
Location: Indonesia
Default Re: progress - 07-05-2019

Sorry sir, but I've found a solution for my problem.

It seems I was placed an entity in wrong place. I put it too near with the ground. So the flag will missing and that's why I couldn't play on CTF mode xD



By the way, back to your Sandbot. How about the progress? Does your Sandbot no longer has bot_count problem?
  
Reply With Quote
Re: progress
Old
  (#178)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 235
Join Date: Apr 2011
Location: Australia
Default Re: progress - 10-05-2019

I've been working on other stuff so work on Sandbot has been slow. I do want to get another version out soon but I still want to finish Opposing Force Capture Point support (the entities are a mess to make sense of).

In the next version bot_count should get written to config.cfg - is that what you meant?
  
Reply With Quote
Re: progress
Old
  (#179)
Persephone
Member
 
Status: Offline
Posts: 57
Join Date: Mar 2014
Location: Indonesia
Default Re: progress - 3 Weeks Ago

Yes, I hope bot_count problem can be fixed as soon as possible because I need it to avoid "chaotic gameplay", creating a waypoints, etc

About Capture Point mode, just forget it. Even there are no other maps beside op4cp_park which has that mode. It means this mode is underrated
  
Reply With Quote
Re: progress
Old
  (#180)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 235
Join Date: Apr 2011
Location: Australia
Default Re: progress - 2 Weeks Ago

I know but I want to finish Opposing Force support before moving onto other stuff.

I've been a bit busy with other stuff lately unfortunately but hopefully I'll have a bit more time to work on Sandbot again soon.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com