.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > HPB_bot
HPB_bot The trusty good ole mechs by botman HLDMTFCOpposing ForceDMCFront Line Force

Reply
 
Thread Tools
Installed 4.0 for TFC, crashing when loading up
Old
  (#1)
BeaverMon
HPB_bot 3.0 Fan/EX-HPB_Bot Waypointer
 
Status: Offline
Posts: 46
Join Date: Mar 2004
Location: South-Central Indiana, USA
Default Installed 4.0 for TFC, crashing when loading up - 14-03-2004

I got the HPB_Bot 4.0 Version for MetaMod. I have set the Liblist.gam to open dlls\metamod.dll instead of HPB_bot_mm.dll and have downloaded the latest version of MetaMod and it's in my tfc\dlls folder.

But when I load the bot up using a LAN Connection, it goes back to Desktop.

What did I do wrong? o_O I tried before of setting the dlls\ thing in Liblist.gam to HPB_bot_mm.dll


Update: The problem was fixed by editing the target of my TFC Shortcut, from;
E:\Sierra\Half-Life\hl.exe -game tfc -sv_cheats 1 -console +localinfo mm_gamedll dlls/HPB_bot.dll
To
E:\Sierra\Half-Life\hl.exe -game tfc -sv_cheats 1 -console +localinfo mm_gamedll dlls/HPB_bot_mm.dll


Now I'm getting an error in the console, which shows this that is new;

HPB_bot: plugin attaching
Host Error: SuckOutClassname: parse error

??? Now what went wrong?

Last edited by BeaverMon; 14-03-2004 at 04:39..
  
Reply With Quote
Re: Installed 4.0 for TFC, crashing when loading up
Old
  (#2)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: Installed 4.0 for TFC, crashing when loading up - 14-03-2004

Use
E:\Sierra\Half-Life\hl.exe -game tfc -sv_cheats 1 -console
in your shortcut.
Do ***NOT*** use +localinfo mm_gamedll dlls/HPB_bot_mm.dll
HPB_bot_mm.dll is NOT a game DLL, it's a metamod plugin.
To set up metamod plugins, you only need to add lines to the metamod's plugins.ini file.

Metamod is normally installed in tfc/addons/metamod

Why don't you just use the install batch scripts provided with the HPB_bot ?



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: Installed 4.0 for TFC, crashing when loading up
Old
  (#3)
BeaverMon
HPB_bot 3.0 Fan/EX-HPB_Bot Waypointer
 
Status: Offline
Posts: 46
Join Date: Mar 2004
Location: South-Central Indiana, USA
Default Re: Installed 4.0 for TFC, crashing when loading up - 10-06-2005

I also have the Monster Mod 3.0 with this for TFC 1.5. So how do I get the Metamod version of the HPB_bot, Monster Mod, and Metamod to work together?

And sorry for digging up this old post. I want to try this again. Including getting CS 1.6 to work with PODBot 2.6 AND the latest version of (mEAn)Bot.Admin Mod.

Last edited by BeaverMon; 10-06-2005 at 08:47..
  
Reply With Quote
Re: Installed 4.0 for TFC, crashing when loading up
Old
  (#4)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: Installed 4.0 for TFC, crashing when loading up - 10-06-2005

Install metamod, test it, install HPB_bot, test it, install Monster Mod, test it.

Monster mod and HPB_bot are metamod plugins. I don't see how this can be a problem to install them ?

Quote:
Including getting CS 1.6 to work with PODBot 2.6 AND the latest version of (mEAn)Bot.Admin Mod.
that shouldn't be too difficult, follow-up into the right forum.



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: Installed 4.0 for TFC, crashing when loading up
Old
  (#5)
BeaverMon
HPB_bot 3.0 Fan/EX-HPB_Bot Waypointer
 
Status: Offline
Posts: 46
Join Date: Mar 2004
Location: South-Central Indiana, USA
Default Re: Installed 4.0 for TFC, crashing when loading up - 10-06-2005

Ok, I know metamod works with HPB_bot 3.0 and Monster Mod in TFC.
Now the trouble is getting this new metamod version of HPB_bot to work with Monster.
So, how do you set up these two metamod things? HPB_bot 4.0 and Monster Mod, to work in Metamod. It looks like to me you can only have 1 Metamod plugin running, according to liblist.gam.

And will I need to run this threw Steam? I have Steam installed because of HL2, but I managed to set HL/CS/and TFC to use their regular non-steam folder; C:\SIERRA\Half-Life\.

Sorry for being a n00b, I'm just not used to installing a non-dll version of the HPB_bot and having it work with Monster and the latest version of Metamod.

Last edited by BeaverMon; 10-06-2005 at 22:26..
  
Reply With Quote
Re: Installed 4.0 for TFC, crashing when loading up
Old
  (#6)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: Installed 4.0 for TFC, crashing when loading up - 10-06-2005

Quote:
It looks like to me you can only have 1 Metamod plugin running, according to liblist.gam.
No! No! No! No! No! For the n'th time the liblist.gam has nothing to do with the plugins !
The liblist.gam file tells the engine which game DLL to load (here, metamod - which in turn will load the right game DLL. That's the spirit of metamod: it sits between the engine and the game DLL).
The plugins.ini file tells metamod which plugins to load. It's in that file you need to add one line for the HPB_bot, and one line for the monster plugin.



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: Installed 4.0 for TFC, crashing when loading up
Old
  (#7)
BeaverMon
HPB_bot 3.0 Fan/EX-HPB_Bot Waypointer
 
Status: Offline
Posts: 46
Join Date: Mar 2004
Location: South-Central Indiana, USA
Default Re: Installed 4.0 for TFC, crashing when loading up - 11-06-2005

Ok, so liblist.gam is NOT NEEDED for metamod! plugins.ini is! 8D
I will try that. Thanks for your continued help and putting up with my n00bness.

Ok, so I just uninstall HPB_bot 3.0 by running the Remove command. But remember to backup my custom files from it, then install the latest version of Metamod, then HPB_bot 4.0.

Last edited by BeaverMon; 11-06-2005 at 04:32..
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com