.:: Bots United ::.  
filebase forums discord server github wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Common Questions
Common Questions Are you seeking help ? Get it here !

Reply
 
Thread Tools
help meeeee
Old
  (#1)
TBA
Member
 
Status: Offline
Posts: 3
Join Date: Oct 2005
Default help meeeee - 20-10-2005

okay i'm using metamod 1.18 amx mod x 1.60 on linux (freebsd 5.4)
in plugins.ini i have this
linux addons/podbot/podbot_mm_i386.so
linux addons/amxmodx/dlls/amxmodx_mm_i386.so
the directory structure is as follows
addons/podbot
addons/podbot/wptdefault
addons/podbot/pbmmdocs
addons/podbot/botchats
addons/metamod
addons/metamod/dlls
addons/amxmodx
....
amxmodx is working great my meta list shows this

Currently loaded plugins:
description stat pend file vers src load unlod
[ 1] <podbot_mm_i386 badf unld podbot_mm_i386.s v - ini - -
[ 2] AMX Mod X RUN - amxmodx_mm_i386. v1.60 ini ANY ANY
[ 3] Fun RUN - fun_amxx_i386.so v1.60 pl2 ANY ANY
[ 4] CStrike RUN - cstrike_amxx_i38 v1.60 pl2 ANY ANY
[ 5] CSX RUN - csx_amxx_i386.so v1.60 pl2 ANY ANY
5 plugins, 4 running

retrying the plugin comes up this
meta retry podbot
Retry failed for plugin '<podbot_mm_i386.so>'
(obviously)

what am i doing wrong

i know many ppl have been posting relativly the same thing but it seems its all for windows not nix and i'm wondering if the metamod version im using is the problem because i know when i first tried installing amxmodx with metamod 1.17 i was getting that error till i updated to 1.18 so i'm wondering if its the same problem only reversed?

[edit]
i'm using steam for cs 1.6 btw
[edit]

Last edited by TBA; 20-10-2005 at 00:05..
  
Reply With Quote
Re: help meeeee
Old
  (#2)
Lazarus Long
Member
 
Lazarus Long's Avatar
 
Status: Offline
Posts: 27
Join Date: Feb 2005
Default Re: help meeeee - 20-10-2005

Hello, TBA:

I'm not sure if this applies, since my knowledge of FreeBSD is very small, but I believe it runs Linux binaries in an pseudo-emulation mode and one has to have all the libraries needed installed, so please take a look at Unable to load R2b46d on Linux to see if it applies to you, and also for pointers on how to help us help you.

Regards,
  
Reply With Quote
Re: help meeeee
Old
  (#3)
TBA
Member
 
Status: Offline
Posts: 3
Join Date: Oct 2005
Default Re: help meeeee - 20-10-2005

you are correct it does require the proper linux binaries to run it, but i wouldn't be able to run steam, metamod and amx mod x if i didn't already have them installed so we can easily eliminate that. i tried running a few other bots that arn't meant for metamod and they load up fine, they just all drop from the sky like morons into the same spot which helped me get my rank up in headshots

i posted a screen shot of my directory structure as well as the error i get from meta list if theres any other screen shots or anything i can give i will but again, the server runs fine otherwise

[edit]
just to make sure that i am right and that its not the linux libraries causing the problem i'm doing a port update and will try it again with both .so files
[edit]
heh tried updating the linux_base-8 and it wouldn't update so i just finished formating and will be installing the latest linux_base as well as gcc-3.4 which is what your compile was made to be used with so we will see if that fix's it as well *cross's fingerS*
Attached Thumbnails
Click image for larger version

Name:	hlds1.JPG
Views:	156
Size:	79.0 KB
ID:	748   Click image for larger version

Name:	hlds2.JPG
Views:	149
Size:	26.4 KB
ID:	749   Click image for larger version

Name:	hlds3.JPG
Views:	138
Size:	68.1 KB
ID:	750  

Last edited by TBA; 21-10-2005 at 01:24..
  
Reply With Quote
Re: help meeeee
Old
  (#4)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: help meeeee - 21-10-2005

As always, first thing to test :

Comment out AMX mod and ALL your other metamod plugins, leave only podbot.

Try to fire up a game. If it doesn't load, then it's a linker issue (assuming your paths are right). Either it comes from a faulty (or too partial) Linux emulation on your FreeBSD box, or it's that the bot binary was compiled with a Linux compiler and linked with a Linux linker that's too recent for your box.

If you have a true Linux machine, test it on it and see if it works. Personally, I would still incriminate the Linux emulation of your BSD. The fact that you manage to load and run the whole game server is not discriminative enough to ensure the problem doesn't come from here. glibc versions, linker issues, etc...



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: help meeeee
Old
  (#5)
TBA
Member
 
Status: Offline
Posts: 3
Join Date: Oct 2005
Default Re: help meeeee - 21-10-2005

okay i just finished re-installing 5.4 with the latest linux libraries i tried both of the podbot_mm_i386.so files i have gcc 3.4 installed as thats what it said it works best with i also tried using metamod 1.17.4 without amx the map loads the bots still don't it still gives me the same error i've checked the directory structure easy 100 times and still nothing...is it because i'm running it on a dedicated server instead of doing the listenserver that comes with say windows cs and linux cs? as i can't think of anything else to try its not giving me any error messages except


Currently loaded plugins:
description stat pend file vers src load unlod
[ 1] <podbot_mm_i386 badf load podbot_mm_i386.s v - ini - -
is it possable that theres an error in some ini file thats its refering to as the source ?

meta info podbot
name: (nil)
desc: <podbot_mm_i386.so>
status: badfile
action: load
filename: addons/podbot/podbot_mm_i386.so
file: podbot_mm_i386.so
pathname: /usr/home/hlds/steam/cstrike/addons/podbot/podbot_mm_i386.so
index: 1
source: ini file
loadable: -
unloadable: -
version: (nil)
date: (nil)
author: (nil)
url: (nil)
logtag: (nil)
last loaded: Thu Jan 1 00:00:00 1970
No DLLAPI functions.
No DLLAPI-Post functions.
No NEWAPI functions.
No NEWAPI-Post functions.
No Engine functions.
No Engine-Post functions.
Registered commands:
0 commands
Registered cvars: float value string value
0 cvars
  
Reply With Quote
Re: help meeeee
Old
  (#6)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: help meeeee - 23-10-2005

Like I said, this is most probably a linker issue coupled with a problem in the Linux emulation system.

Either you switch your machine to Linux, or you try to cross-recompile the podbot sources with an older compiler (ideally, the compiler the version of metamod you're using has been compiled with, sine the metamod library you're using works).



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: help meeeee
Old
  (#7)
Lazarus Long
Member
 
Lazarus Long's Avatar
 
Status: Offline
Posts: 27
Join Date: Feb 2005
Default Re: help meeeee - 24-10-2005

And please post the server startup log (just until a player gets able to connect) since it may have pointers to help out diagnosing.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com