.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > JKBotti
JKBotti The new generation of Half-Life bots by ghost of evilspy HLDMOpposing Force

Reply
 
Thread Tools
Re: installation/doesn't work
Old
  (#11)
ghost of evilspy
Moderator
 
ghost of evilspy's Avatar
 
Status: Offline
Posts: 140
Join Date: Mar 2005
Location: Finland
Default Re: installation/doesn't work - 10-05-2007

Please paste your liblist.gam here.
  
Reply With Quote
Re: installation/doesn't work
Old
  (#12)
person135
Member
 
Status: Offline
Posts: 259
Join Date: Sep 2006
Default Re: installation/doesn't work - 11-05-2007

Code:
// Valve Game Info file
// gamedll "dlls\hl.dll"
//  These are key/value pairs.  Certain mods will use different settings.
//
game "Half-Life"
startmap "c0a0"
trainmap "t0a0"
mpentity "info_player_deathmatch"

gamedll "addons\metamod\dlls\metamod.dll"
gamedll_linux "dlls/hl_i386.so"
secure "1"
type "singleplayer_only"
metamod plugins.ini
Code:
;win32 addons/jk_botti/dlls/jk_botti_mm.dll
metamod config.ini
Code:
;gamedll ivpbot/ivpbot.dll

;gamedll dlls/mpbot.dll

;gamedll dlls/mp.dll

;gamedll "dlls\hl.dll"

;gamedll "addons/jk_botti/dlls/jk_botti_mm.dll"


  
Reply With Quote
Re: installation/doesn't work
Old
  (#13)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,604
Join Date: Jul 2004
Location: Bulgaria
Default Re: installation/doesn't work - 11-05-2007

Remove the ";" before win32 in plugins.ini and delete config.ini.
  
Reply With Quote
Re: installation/doesn't work
Old
  (#14)
ghost of evilspy
Moderator
 
ghost of evilspy's Avatar
 
Status: Offline
Posts: 140
Join Date: Mar 2005
Location: Finland
Default Re: installation/doesn't work - 11-05-2007

Ok, I have found reason for "DLL version is 140, engine version is 140" bug. Metamod isn't finding your gamedll. Make sure that 'valve\dlls\hl.dll' exists. If it doesn't, please start server with commandline options '+log on +localinfo mm_debug 10'. This way we see what goes wrong with metamod.
  
Reply With Quote
Re: installation/doesn't work
Old
  (#15)
person135
Member
 
Status: Offline
Posts: 259
Join Date: Sep 2006
Default Re: installation/doesn't work - 11-05-2007

first of all, have that in where? plugins.ini? liblist.gam? config.ini?

also, I can't start a server at all because of that.

can you just tell me what to do from the beginning. Do it as if i'm a noob XD

like tell me which file to open and what to edit and delete and all


btw@STORM: I had it removed and it didn't work, so I just added it so I could play regular HL


  
Reply With Quote
Re: installation/doesn't work
Old
  (#16)
ghost of evilspy
Moderator
 
ghost of evilspy's Avatar
 
Status: Offline
Posts: 140
Join Date: Mar 2005
Location: Finland
Default Re: installation/doesn't work - 11-05-2007

Ok. Are you trying to start dedicated server or installing metamod on listenserver?

If you are starting dedicated server through steam, follow as (mm installed):
1. Open Steam game list.
2. Select Dedicated Server and click right button and select Properties from list.
3. Open 'Set launch options...'
4. Write '+log on +localinfo mm_debug 10' to edit area (without ').
5. Close properties windows and start server.

If you are running server from within game (listenserver), follow as (mm installed):
1. Open Steam game list.
2. Select Half-Life and click right button and select Properties from list.
3. Open 'Set launch options...'
4. Write '+log on +localinfo mm_debug 10' to edit area (without ').
5. Close properties windows and start server.

Then post results here.

(If you are running dedicated server without steam add '+log on +localinfo mm_debug 10' on startup line or in shortcut with hlds.exe)

If you check your Half-Life/valve/dlls-directory and it's empty or doesn't exists, copy following file there: http://koti.mbnet.fi/axh/jk_botti/hl.dll
So you will have Half-Life/valve/dlls/hl.dll

If you get server running with copying this file in, go remove those launch options (will slowdown server).
  
Reply With Quote
Re: installation/doesn't work
Old
  (#17)
person135
Member
 
Status: Offline
Posts: 259
Join Date: Sep 2006
Default Re: installation/doesn't work - 12-05-2007

the thing is I can't start the server! the server wont start! I get that error I posted!


  
Reply With Quote
Re: installation/doesn't work
Old
  (#18)
ghost of evilspy
Moderator
 
ghost of evilspy's Avatar
 
Status: Offline
Posts: 140
Join Date: Mar 2005
Location: Finland
Default Re: installation/doesn't work - 13-05-2007

I know you are getting this error. "DLL version is 140, engine version is 140"


That's why I'm giving these instructions. This these instructions server will generate ALOT more meaningful text output for me to sort out this problem.

Did you try adding "+log on +localinfo mm_debug 10"? How did output change on server error?
  
Reply With Quote
Re: installation/doesn't work
Old
  (#19)
person135
Member
 
Status: Offline
Posts: 259
Join Date: Sep 2006
Default Re: installation/doesn't work - 13-05-2007

the same happened! there was the same output when I tried to start the server. I tried to start the server, I got that error even before the server started.


  
Reply With Quote
Re: installation/doesn't work
Old
  (#20)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,604
Join Date: Jul 2004
Location: Bulgaria
Default Re: installation/doesn't work - 13-05-2007

If you are using Steam delete the Dedicated Server folder and Start it again from tools, else delete liblist.gam and run hldsupdatetool.exe to redownload the stuff.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com