.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > Sandbot
Sandbot A bot for Gunman Chronicles and They Hunger - by tschumann

Reply
 
Thread Tools
Re: progress
Old
  (#51)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 25-11-2017

Thanks - thought the .wp* timestamp check could be a problem but that's not it.

So, with https://github.com/tschumann/sandbot...473cb1f5bd84d9 I got the following.

Half-Life works.
Half-Life with MetaMod works.
Opposing Force works.
Opposing Force with waypoints crashes.
Opposing Force with MetaMod crashes.

So I think the undefined symbol issue is fixed now (not sure why...).
Also, Opposing Force with waypoints works if .wp1, .wp2, .wp3 and .wp4 waypoint files are present (I noticed that running a non-waypointed map followed by a waypointed map generated these extra files), so it looks like some variable may be initialised with bad data to make Opposing Force CTF think there are four teams.
  
Reply With Quote
Re: progress
Old
  (#52)
Nubzior
Member
 
Status: Offline
Posts: 10
Join Date: Nov 2017
Location: Poland
Default Re: progress - 26-11-2017

Still the same on 0.4.1.1-hotfix.
  
Reply With Quote
Re: progress
Old
  (#53)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 27-11-2017

Quote:
Originally Posted by Nubzior View Post
Still the same on 0.4.1.1-hotfix.
The undefined symbol? Did you compile it yourself? The binaries in the repo are still from v0.4.1
If you did compile it yourself what version of gcc are you using?
  
Reply With Quote
Re: progress
Old
  (#54)
RoboCop
vBulletin Veteran
 
Status: Offline
Posts: 154
Join Date: Feb 2013
Location: Dundee, Scotland
Default Re: progress - 27-11-2017

Sorry for delay, been too busy on my essays. Do you need me to run Sandbot on Linux listenserver, is that what you are saying?





vBulletin Webmaster since 2001
  
Reply With Quote
Re: progress
Old
  (#55)
Nubzior
Member
 
Status: Offline
Posts: 10
Join Date: Nov 2017
Location: Poland
Default Re: progress - 28-11-2017

Quote:
Originally Posted by tschumann View Post
The undefined symbol? Did you compile it yourself? The binaries in the repo are still from v0.4.1
If you did compile it yourself what version of gcc are you using?
Yes, compiled by myself from branch 0.4.1.1-hotfix.
gcc (Debian 6.3.0-1 6.3.0 20170516
  
Reply With Quote
Re: progress
Old
  (#56)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 30-11-2017

Quote:
Originally Posted by RoboCop View Post
Sorry for delay, been too busy on my essays. Do you need me to run Sandbot on Linux listenserver, is that what you are saying?
No that's okay - it wasn't what I thought the issue might be.

Quote:
Originally Posted by Nubzior View Post
Yes, compiled by myself from branch 0.4.1.1-hotfix.
gcc (Debian 6.3.0-1 6.3.0 20170516
Okay, I'm using gcc 6.3.0 too - I'll try making some other changes - if you don't mind would you be able to try them out when I've tried some stuff?
Also, does Sandbot for Half-Life work even though Day of Defeat doesn't?
  
Reply With Quote
Re: progress
Old
  (#57)
Nubzior
Member
 
Status: Offline
Posts: 10
Join Date: Nov 2017
Location: Poland
Default Re: progress - 30-11-2017

No problem.
  
Reply With Quote
Re: progress
Old
  (#58)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 02-12-2017

Quote:
Originally Posted by Nubzior View Post
No problem.
Awesome thanks. I've tried adding some empty destructors and compiled some new binaries: https://github.com/tschumann/sandbot...9b0a047b8a9efd
Let me know how that goes - if that doesn't work I might try playing around with some compiler options.
  
Reply With Quote
Re: progress
Old
  (#59)
Nubzior
Member
 
Status: Offline
Posts: 10
Join Date: Nov 2017
Location: Poland
Default Re: progress - 02-12-2017

Still the same i think is something with Makefile binaries
  
Reply With Quote
Re: progress
Old
  (#60)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 209
Join Date: Apr 2011
Location: Australia
Default Re: progress - 03-12-2017

Quote:
Originally Posted by Nubzior View Post
Still the same i think is something with Makefile binaries
Did you try both my binaries and compiling yourself?
What version of libc and libstdc++ do you have installed?
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com