.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > Sandbot
Sandbot A bot for Gunman Chronicles and They Hunger - by tschumann

Reply
 
Thread Tools
Re: progress
Old
  (#41)
RoboCop
vBulletin Veteran
 
Status: Offline
Posts: 89
Join Date: Feb 2013
Location: Dundee, Scotland
Default Re: progress - 05-11-2017

Quote:
Originally Posted by The Storm View Post
@RoboCop The list is are watching is just a backtrace, not a "huge list of errors". There is no really a reason to split the builds for Metamod and Non-Metamod. The code is isolated in checks and calls Metamod functions when loaded as plugin and the normal game/engine functions when is working standalone.
Well actually they are huge cos those backtrace errors seem to had multipled by that existing error and flooded my terminal over 35 lines...





vBulletin Webmaster since 2001
   
Reply With Quote
Re: progress
Old
  (#42)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,566
Join Date: Jul 2004
Location: Bulgaria
Default Re: progress - 05-11-2017

As I said, backtrace is not an error list. It just shows the last call-stack up to the crash.
   
Reply With Quote
Re: progress
Old
  (#43)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 155
Join Date: Apr 2011
Location: Australia
Default Re: progress - 07-11-2017

Quote:
Originally Posted by RoboCop View Post
Well yes thanks to a bit of hint from Arkshine, he told me to test and engage GDB Debug mode is simply using this in the Terminal "$ LD_LIBRARY_PATH=".:$LD_LIBRARY_PATH" gdb ./hlds_linux"

Then type this in Terminal but don't use "./hlds_run", use "run -game gearbox -ip xx.xx.xx.xx +port 27015 +map op4_bootcamp +exec server.cfg -debug"

You can backtrace or get a full error crash log by typing "bt" as well rerunning the server using "run" (Nothing further as GDB stored the Startup Variables once after GDB is exited by typing "quit")

And "How about v0.4?" you say? Well I just did the tests and they don't seem to instantly crash as much as v0.4.1 did...
Okay, so v0.4 Half-Life is okay and v0.4 Opposing Force crashes in the waypoint code, and v0.4.1 Half-Life crashes only with MetaMod and v0.4.1 Opposing Force crashes due to undefined symbol. Lots going on.

I've got part of the way to debugging minidumps on Linux - I'll probably continue down this path (I do other Half-Life modding so I'll need to figure it out sooner or later). I might crank up the gcc warnings and see what I get.
   
Reply With Quote
Re: progress
Old
  (#44)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 155
Join Date: Apr 2011
Location: Australia
Default Re: progress - 4 Weeks Ago

Alright, playing some more, v0.4.1 works for me in Half-Life and Opposing Force, except for on op4ctf_hairball. Opposing Force doesn't work at all with MetaMod though.
I managed to get the minidump loaded into gdb but there are no symbols, though the backtrace for Opposing Force says WaypointDistanceFromTo and the backtrace for Opposing Force MetaMod says WaypointRouteInit.

Maybe the undefined symbol stuff I saw wasn't actually causing any crash but was more of a warning?
   
Reply With Quote
Re: progress
Old
  (#45)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 155
Join Date: Apr 2011
Location: Australia
Default Re: progress - 3 Weeks Ago

Robocop could you post the output of the following in bash:
ls -ali --time-style=full-iso ~/.local/share/steam/Steam/steamapps/common/Half-Life/gearbox/maps/*.wp*
   
Reply With Quote
Re: progress
Old
  (#46)
Nubzior
Member
 
Status: Offline
Posts: 10
Join Date: Nov 2017
Location: Poland
Default Re: progress - 3 Weeks Ago

After half day trying to run it firstly with Metamod, now i try without it and i got problem. Here is log from console. I tryed your precompiled binary and after all i compiled it on local machine. My OS: Debian 9.1 x64
Server is for Day of Defeat 1.3

Code:
Auto-restarting the server on crash
Could not locate steam binary:steamcmd/steamcmd.sh, ignoring.

Console initialized.
Protocol version 48
Exe version 1.1.2.6/Stdio (dod)
Exe build: 14:13:30 Jul  5 2017 (7559)
STEAM Auth Server
Server IP address 213.251.186.93:27015
LoadLibrary failed on /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so: /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so: undefined symbol: _ZdlPvj
Host_Error: Couldn't get DLL API from /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so!
FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so!

Last edited by Nubzior; 3 Weeks Ago at 21:03..
   
Reply With Quote
Re: progress
Old
  (#47)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 155
Join Date: Apr 2011
Location: Australia
Default Re: progress - 2 Weeks Ago

Quote:
Originally Posted by Nubzior View Post
After half day trying to run it firstly with Metamod, now i try without it and i got problem. Here is log from console. I tryed your precompiled binary and after all i compiled it on local machine. My OS: Debian 9.1 x64
Server is for Day of Defeat 1.3

Code:
Auto-restarting the server on crash
Could not locate steam binary:steamcmd/steamcmd.sh, ignoring.

Console initialized.
Protocol version 48
Exe version 1.1.2.6/Stdio (dod)
Exe build: 14:13:30 Jul  5 2017 (7559)
STEAM Auth Server
Server IP address 213.251.186.93:27015
LoadLibrary failed on /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so: /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so: undefined symbol: _ZdlPvj
Host_Error: Couldn't get DLL API from /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so!
FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so!
Could you post what you get when you run ls -ali --time-style=full-iso ~/.local/share/steam/Steam/steamapps/common/Half-Life/gearbox/maps/*.wp*
Also, what version of Sandbot are you using?
   
Reply With Quote
Re: progress
Old
  (#48)
Nubzior
Member
 
Status: Offline
Posts: 10
Join Date: Nov 2017
Location: Poland
Default Re: progress - 2 Weeks Ago

Newest one.
I don't have directory what u give me. I run server from user "nubzior" not root.
   
Reply With Quote
Re: progress
Old
  (#49)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 155
Join Date: Apr 2011
Location: Australia
Default Re: progress - 2 Weeks Ago

Could you run ls -ali --time-style=full-iso /home/nubzior/dod2017/dod/./dod/maps/*.wp*

So looks like this is where the crash is:
Code:
                           // check if this is NOT team specific OR matches this team
                           if (!(waypoints[index].flags & W_FL_TEAM_SPECIFIC) ||
                               ((waypoints[index].flags & W_FL_TEAM) == matrix))
                           {
I'll need to take a closer look at the waypoint code to see what it's actually doing, but I guess waypoints[index] is out of bounds.
   
Reply With Quote
Re: progress
Old
  (#50)
Nubzior
Member
 
Status: Offline
Posts: 10
Join Date: Nov 2017
Location: Poland
Default Re: progress - 2 Weeks Ago

Code:
95552360 -rwxrwxrwx 1 nubzior nubzior 13924 2017-04-22 13:49:46.000000000 +0200 /home/nubzior/dod2017/dod/./dod/maps/dod_avalanche.wp1
95552361 -rwxrwxrwx 1 nubzior nubzior  2212 2017-04-22 13:49:46.000000000 +0200 /home/nubzior/dod2017/dod/./dod/maps/dod_avalanche.wpt
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com