.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > FritzBot > Developers Forum
Developers Forum A place just for coders, testers, and waypointers to get together and discuss the FritzBot project.

Reply
 
Thread Tools
Nav File Saved but won't Load
Old
  (#1)
Silver Tiger
Member
 
Status: Offline
Posts: 2
Join Date: Dec 2012
Default Nav File Saved but won't Load - 29-05-2014

Hi there, long time everyone. I am working on some waypointing and when I save the Nav file and then load the saved nav file it reverts to the previous nav file before I saved it. Basically, if I work on a nav file and save it, I will see it says nav file saved. But when I continue to work on it later on, the nav file I had saved is not what shows up. Instead, the previous nav file shows up as if though I had never saved it. It seems Fritzbot is pointing to a different location than that which it is saving the nav file to. Does anyone know why this is happening and how I could remedy this problem? Many thanks in advance for your help

Tiger
  
Reply With Quote
Re: Nav File Saved but won't Load
Old
  (#2)
TomTom
ET Waypointing team member
 
TomTom's Avatar
 
Status: Offline
Posts: 742
Join Date: Jun 2006
Default Re: Nav File Saved but won't Load - 30-05-2014

If you have a nav file for the same map in a pk3 file in the fritzbot directory then that is likely the previous version being loaded. Anytime I am doing pure server tests I have to remind myself that the nav I am saving goes to the regular fritzbot\bots\maps, but the one that gets loaded when I restart is packed up in the pk3 zip file I was testing.

So first check if the map nav exists in any of the pk3 files in fritzbot/ including the official fritzbot map pack releases. If it does you can always rename that .nav to .old inside the .pk3 (winrar is a good tool).

2- always waypoint using /sv_pure 0 and /devmap mapname, it will save you from headaches.

3- If you make a big mistake in waypointing, but have not saved yet, vid_restart will reload the saved file (normal referee restart works with what is still in memory, which helps in cases where you forgot to save before the restart)

4- Make certain you use vid_restart after first turning on editing when you start up FritzBot ET, if you don't you could end up saving an empty waypoint (FritzBot has essentially 2 waypoints, those used in the game, modified by the aiscript, and a waypointing version that only the editor modifies. Seeing stuff on screen might make you think its safe to save when it is not. Later on only use vid_restart to fix display errors or to lose unsaved changes)

that's all for now, hope it helps

Last edited by TomTom; 30-05-2014 at 05:40.. Reason: cmd spelling correct
  
Reply With Quote
Re: Nav File Saved but won't Load
Old
  (#3)
Silver Tiger
Member
 
Status: Offline
Posts: 2
Join Date: Dec 2012
Default Re: Nav File Saved but won't Load - 30-05-2014

Hi Tom Tom, long long time no see. I hope everything is well and I am glad to see there is still activity on the waypointing forums. I had dealt with this issue years ago but since it was so long since I waypointed (2008 or so) I forgot how to deal with saving and then loading nav files.

I just tried what you said and it worked. I went into the pk3 file, deleted the old nav file and replaced it with the updated one and now it is working perfectly. Many thanks for your help and very speedy response!

Tiger
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com