.:: Bots United ::.  
filebase forums discord server github wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps yapb

Go Back   .:: Bots United ::. > Cyborg Factory > RealBot > General Forum
General Forum Follow progress, give suggestions, reply to bug report threads here.

Reply
 
Thread Tools
Re: My tutorial for RB
Old
  (#11)
Krillin
Member
 
Krillin's Avatar
 
Status: Offline
Posts: 38
Join Date: Aug 2007
Location: In a home
Default Re: My tutorial for RB - 19-09-2007

Quote:
Originally Posted by Ancient View Post
I thought most or all of these bots supported linux and windows.

Well realbot was put on hold right?
Maybe that would cause it to be out of date
If you have been following REALBOT at all, you would have noted there is a new release for this Meta MOD plugin on August 16, 2007. but only the .DLL for winblows server is supported. There isn't a newly compiled version of the 3063 build for linux yet and I can not figure how to compile the source files myself. The supplied ./Makefile errors out on our linux, Mandrivia 2007.0 Powerpack, distro and looking at the code in the ./Makefile CPP is not a function (that I can find of) doesn't exist, therefore the rest of the code errors out as * source file not being found (of something to that effect). So I am not even sure what I need to complie a linux version .so file for use on our servers.

Krillin


Serving Players Since 1997


www.KRILLINSWORLD.com

Last edited by Krillin; 19-09-2007 at 03:07.. Reason: Date and Version Numbers Supplied and corrected!
  
Reply With Quote
Re: My tutorial for RB
Old
  (#12)
stefanhendriks
RealBot Author
 
stefanhendriks's Avatar
 
Status: Offline
Posts: 3,088
Join Date: Nov 2003
Location: Netherlands
Default Re: My tutorial for RB - 19-09-2007

Looks like you're so good at linux, then you could probably just read the makefile, know that there are dependencies missing and grab the source file. Piece of cake with Linux right?

I don't like the additude towards Microsoft, just because coders use it. I code on Windows , Mac and Linux. And i don't care what OS it is, as long as it works.



RealBot was re-released with a purpose to give out an official, easy to install (for Windows yes) latest version. Instead of just downloading an old version, incremental updates, etc.

Source code is delivered with it, with a bit effort you can get it compiling for sure. Hint: Metamod, HLSDK.


Author of RealBot, "Arrakis" and "Dune 2 - The Maker" | co-Founder of Bots-United | Fundynamic | Blog | E-Mail me
  
Reply With Quote
Re: My tutorial for RB
Old
  (#13)
Whistler
Whistler
 
Whistler's Avatar
 
Status: Offline
Posts: 1,495
Join Date: Feb 2004
Location: P. R. China
Default Re: My tutorial for RB - 20-09-2007

you need to download the HLSDK and Metamod sources (as stefan said - they can be found at http://www.metamod.org ), and then adapt the Makefile (change the compiler command name and the paths to HLSDK and Metamod sources) then running "make" will produce the .so file if nothing is wrong.

to sum up, these are the lines which you need to change in Makefile:

CPP = gcc-2.95.3
METAMOD_SRCDIR = /usr/src/hl_bot_build/metamod-1.17/metamod
HLSDK_BASEDIR = /usr/src/hl_bot_build/hlsdk-2.3
  
Reply With Quote
Re: My tutorial for RB
Old
  (#14)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,614
Join Date: Jul 2004
Location: Bulgaria
Default Re: My tutorial for RB - 20-09-2007

Actually he don't need to use gcc-2.95.3 anymore.
GCC-3.4.4 do perfect job.
  
Reply With Quote
Re: My tutorial for RB
Old
  (#15)
Krillin
Member
 
Krillin's Avatar
 
Status: Offline
Posts: 38
Join Date: Aug 2007
Location: In a home
Default Re: My tutorial for RB - 21-09-2007

I have read the ./Makefile and the commands in this file are invalid as I told you in the e-mail I sent you with the console errors "Command not found:" if you like I will show you here if you need the reminder?

I am not going to get into a debate about coders making script or code for liunx in Microshaft Winblows. With all due respect it makes you coders lazy. You guys tend to forget with your code that Linux is CaSe SeNcItIvE. You have no idea how many problems were cause by lazy windoze programmers who are clueless about Linux constraints in this mannor.

This is not an opinion, this is plain old fact. And this only in the third+ on going years I have been working with Linux.

If you do not like the posts of scarcasium then remove them.

Krillin


Serving Players Since 1997


www.KRILLINSWORLD.com
  
Reply With Quote
Re: My tutorial for RB
Old
  (#16)
Krillin
Member
 
Krillin's Avatar
 
Status: Offline
Posts: 38
Join Date: Aug 2007
Location: In a home
Thumbs down Re: My tutorial for RB - 21-09-2007

Removed a Double Post


Serving Players Since 1997


www.KRILLINSWORLD.com

Last edited by Krillin; 21-09-2007 at 17:19.. Reason: Removed Double Posting...
  
Reply With Quote
Re: My tutorial for RB
Old
  (#17)
Krillin
Member
 
Krillin's Avatar
 
Status: Offline
Posts: 38
Join Date: Aug 2007
Location: In a home
Default Re: My tutorial for RB - 21-09-2007

The GCC verion on the build I am working with is 4.1.1-3

All components match this version. I hear the 2.95 comes as like a legacy package labled LSB and is the prefered GCC build product.

Ok, I have made some progress. Silly me was trying to run the Makefile, rahter then "make" to let it compile. Now the files included in the source code for realbot have hldsk and metamod. These files are missing and need to be placed in the hlsdk and metamod /user/src/ folders repectively, but I can not seem to figure out where they go. Compliling indicates these files are missing.

Where do the files located in hlsdk and metamod from /realbot/source/ need to go in what folder(s) for /usr/src/hlsdk-2.3 and /usr/src/metamod-1.19?

Krillin


Serving Players Since 1997


www.KRILLINSWORLD.com

Last edited by Krillin; 21-09-2007 at 19:16.. Reason: GCC no longer relivant.
  
Reply With Quote
Re: My tutorial for RB
Old
  (#18)
Whistler
Whistler
 
Whistler's Avatar
 
Status: Offline
Posts: 1,495
Join Date: Feb 2004
Location: P. R. China
Default Re: My tutorial for RB - 22-09-2007

read my post above.

you can extract them to anywhere you want, just edit the makefile to make the variables pointing to them.
  
Reply With Quote
Re: My tutorial for RB
Old
  (#19)
Krillin
Member
 
Krillin's Avatar
 
Status: Offline
Posts: 38
Join Date: Aug 2007
Location: In a home
Default Re: My tutorial for RB - 22-09-2007

Quote:
Originally Posted by Whistler View Post
read my post above.

you can extract them to anywhere you want, just edit the makefile to make the variables pointing to them.
This is not an answer. I will try it, but the files need to go in a specific location this I am sure of. I will place them in the root folders of hldsk and metamod.


Will post back in a few minutes and see if it worked or not.

Krillin

[edit1]
Just as I suspected, I was right. I was prompted to overright some files with metamod, but here is what came out of this trial.

gcc -Dstricmp=strcasecmp -Dstrcmpi=strcasecmp -march=i586 -O2 -w -I"/usr/src/metamod-1.19/metamod" -I"/usr/src/hlsdk-2.3/multiplayer/common" -I"/usr/src/hlsdk-2.3/multiplayer/dlls" -I"/usr/src/hlsdk-2.3/multiplayer/engine" -I"/usr/src/hlsdk-2.3/multiplayer/pm_shared" -c NodeMachine.cpp -o NodeMachine.o
In file included from /usr/src/metamod-1.19/metamod/meta_api.h:81,
from NodeMachine.cpp:40:
/usr/src/metamod-1.19/metamod/engine_api.h:79:23: error: archtypes.h: No such file or directory
/usr/src/metamod-1.19/metamod/engine_api.h:291: error: ‚€˜int32‚€™ has not been declared
/usr/src/metamod-1.19/metamod/engine_api.h:341: error: ‚€˜uint32‚€™ does not name a type
/usr/src/metamod-1.19/metamod/engine_api.h:343: error: ‚€˜uint32‚€™ was not declared in this scope
/usr/src/metamod-1.19/metamod/engine_api.h:383: error: ‚€˜int32‚€™ does not name a type
/usr/src/metamod-1.19/metamod/engine_api.h:535: error: expected initializer before ‚€˜*‚€™ token
/usr/src/metamod-1.19/metamod/engine_api.h:537: error: expected initializer before ‚€˜*‚€™ token
/usr/src/metamod-1.19/metamod/engine_api.h:707: error: ‚€˜int32‚€™ has not been declared
/usr/src/metamod-1.19/metamod/engine_api.h:747: error: ISO C++ forbids declaration of ‚€˜uint32‚€™ with no type
/usr/src/metamod-1.19/metamod/engine_api.h:747: error: typedef ‚€˜uint32‚€™ is initialized (use __typeof__ instead)
/usr/src/metamod-1.19/metamod/engine_api.h:747: error: ‚€˜FN_FUNCTIONFROMNAME‚€™ was not declared in this scope
/usr/src/metamod-1.19/metamod/engine_api.h:747: error: expected ‚€˜,‚€™ or ‚€˜;‚€™ before ‚€˜(‚€™ token
/usr/src/metamod-1.19/metamod/engine_api.h:779: error: ISO C++ forbids declaration of ‚€˜int32‚€™ with no type
/usr/src/metamod-1.19/metamod/engine_api.h:779: error: typedef ‚€˜int32‚€™ is initialized (use __typeof__ instead)
/usr/src/metamod-1.19/metamod/engine_api.h:779: error: ‚€˜FN_RANDOMLONG‚€™ was not declared in this scope
/usr/src/metamod-1.19/metamod/engine_api.h:779: error: expected ‚€˜,‚€™ or ‚€˜;‚€™ before ‚€˜(‚€™ token
/usr/src/metamod-1.19/metamod/engine_api.h:895: error: expected initializer before ‚€˜*‚€™ token
/usr/src/metamod-1.19/metamod/engine_api.h:897: error: expected initializer before ‚€˜*‚€™ token
/usr/src/metamod-1.19/metamod/meta_api.h:187: error: expected unqualified-id before ‚€˜do‚€™
/usr/src/metamod-1.19/metamod/meta_api.h:187: error: expected unqualified-id before ‚€˜while‚€™
/usr/src/metamod-1.19/metamod/meta_api.h:191: error: expected unqualified-id before ‚€˜while‚€™
/usr/src/metamod-1.19/metamod/meta_api.h:223: error: expected constructor, destructor, or type conversion before ‚€˜;‚€™ token
/usr/src/metamod-1.19/metamod/meta_api.h:287: error: ‚€˜META_FUNCTIONS‚€™ has not been declared
/usr/src/metamod-1.19/metamod/meta_api.h:295: error: ‚€˜META_FUNCTIONS‚€™ has not been declared
make: *** [NodeMachine.o] Error 1
[/edit1]

[edit2]
I was right again, the files for HLDSK needed to go into the multiplayer/common folder, metamod was fine, now here is what I am getting in compliling

gcc -Dstricmp=strcasecmp -Dstrcmpi=strcasecmp -march=i586 -O2 -w -I"/usr/src/hl_bot_build/metamod-1.19/metamod" -I"/usr/src/hl_bot_build/hlsdk-2.3/multiplayer/common" -I"/usr/src/hl_bot_build/hlsdk-2.3/multiplayer/dlls" -I"/usr/src/hl_bot_build/hlsdk-2.3/multiplayer/engine" -I"/usr/src/hl_bot_build/hlsdk-2.3/multiplayer/pm_shared" -c NodeMachine.cpp -o NodeMachine.o
/usr/src/hl_bot_build/metamod-1.19/metamod/engine_api.h:268: error: expected initializer before '*' token
/usr/src/hl_bot_build/metamod-1.19/metamod/engine_api.h:269: error: expected initializer before '*' token
/usr/src/hl_bot_build/metamod-1.19/metamod/engine_api.h:448: error: expected initializer before '*' token
/usr/src/hl_bot_build/metamod-1.19/metamod/engine_api.h:449: error: expected initializer before '*' token
make: *** [NodeMachine.o] Error 1

Now this is out of my hands as this is a syntax coding error. I am gonna try to put back the files the includes from the RB Source overwrote and see if this will do any better. Some files which were overwritten by RB Souce Files were much smaller than the ones they were replaced with.
[/edit2]


Serving Players Since 1997


www.KRILLINSWORLD.com

Last edited by Krillin; 22-09-2007 at 20:09.. Reason: Posted more error results
  
Reply With Quote
Re: My tutorial for RB
Old
  (#20)
Whistler
Whistler
 
Whistler's Avatar
 
Status: Offline
Posts: 1,495
Join Date: Feb 2004
Location: P. R. China
Default Re: My tutorial for RB - 23-09-2007

the HLSDK at http://metamod.org is updated. Make sure you are download the updated version and not the original version.

direct download link:
http://metamod.sourceforge.net/files...-2.3-p3.tar.gz

PS: I'd recommend you to read this article:
http://www.catb.org/~esr/faqs/smart-questions.html
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com