.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Bug Reports
Bug Reports Post any bug you experience with the latest release of this bot here

Reply
 
Thread Tools
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#11)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 15-04-2013

Trying the "All_in_One" package today, and assuming it works I will reverse-engineer putting back in just the AMX stuff I care about and taking everything else out.

Regarding the names it's a customized botnames.txt file (below).
Not other bots running on this game/in this installation folder, etc.

Code:
# This File contains all Botnames which are used if you don't
# specify a name using "pb add"
# There must be at least 9 names in here and you're allowed a maximum
# of 21 chars for the name ! Why ? The "[POD]" will be
# placed before the Name and the Skill will be appended...
#
# Line below contains 21 chars as a marker for you
#23456789012345678901
#
#
Data[bot]
Lore[bot]
R2D2[bot]
C3PO[bot]
Robo-Cop[bot]
Mecha-Godzilla[bot]
Robby_The_Robot[bot]
Terminator[bot]
Tom_Servo[bot]
Crow_T._Robot[bot]
Gort[bot]
K9[bot]
HAL-9000[bot]
Johnny_5[bot]
Evil_Bill[bot]
Evil_Ted[bot]
SID_6.7[bot]
FemBot[bot]
Bender[bot]
WALL-E[bot]
EVE[bot]
Battle-Droid[bot]
Hymie[bot]
Nomad[bot]
Voltron[bot]
Cylon_Centurion[bot]
Optimus_Prime[bot]
Megatron[bot]
Agent_Smith[bot]
Lain_of_the_Wired[bot]
Project_2501[bot]
Tachikoma[bot]
WOPR[bot]
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#12)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 15-04-2013

What exactly the distro and version number of Your linux OS is?
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#13)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 15-04-2013

Quote:
Originally Posted by KWo View Post
What exactly the distro and version number of Your linux OS is?
It's 64-Bit Debian 6.
Linux 2.6.32-042stab072.10 on x86_64

I tried removing/re-naming the existing "addons" folder, and using the full "all in one" package contents. Bots are running as expected with that.


So, don't really know what was up. Maybe it didn't like something about the existing metamod and/or amx-mod-x installation. I believe I had tried an updated metamod binary along with the updated PotBot binaries, etc. (i.e. all the normal stuff you would expect for any metamod plugin).

At this point, I am just going to use the AMX stuff from the "all in one" package as the base for my AMX install, and work on ripping stuff out not related to PotBot, and putting my normal (unrelated to PotBot) stuff back in.

I don't seem to be having any similar issues with JK_Botti on HL server, or FoxBot on TFC server. So, not really sure what I had or did wrong with this one. Still scratching my head (banging it on the desk actually).
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#14)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 15-04-2013

PS: In the future, would it be possible to get a PodBotMM release - that has just all the PodBotMM stuff in it (configs, manual, etc.) - without all the "extraneous" material? (i.e. AMX, ATAC, CSDM, etc.)?
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#15)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 15-04-2013

Quote:
Originally Posted by Weasel View Post
PS: In the future, would it be possible to get a PodBotMM release - that has just all the PodBotMM stuff in it (configs, manual, etc.) - without all the "extraneous" material? (i.e. AMX, ATAC, CSDM, etc.)?
Well - in that category of the filebase - it was existing the fullpack (just podbot mm with its config files, waypoints and docs) - as the full official release. Since some update of the filebase it seems to be not existing anymore. I have to talk to admin again.
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#16)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 28-05-2013

Seem to be back to my original problem (again) of bots not joining a team. I assume it was something with the last Valve update (from 2013-05-16)

I guess I will re-install full-pack, etc., etc. again. Or maybe I will just shut it down and call it quits. I haven't checked on the server for a few weeks, and when I did I found out it was broken.
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#17)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 30-05-2013

More than likely Your problem is related to this situation happening while steam updates - Your liblist.gam file is overwritten by steam update and it is calling just mp.dll/mp_i386.so file instead metamod. Just open that file by any text editor and change this line in it:
gamedll "dlls\mp.dll"
to this:
gamedll "addons\metamod\dlls\metamod.dll"
or for linux
gamedll_linux "addons/metamod/dlls/metamod_i386.so"

Note - bring attention at these slashes (for win "\", for linux "/").
After that save the file, make it as "read-only" (to prevent overwrite it again by steam update) and restart CS on Your server. That should help.
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#18)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 31-05-2013

Thanks, I will check that out.
However, AMX-Mod-X never stopped working, and that's dependent on MetaMod also.
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#19)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 31-05-2013

Working again. Here's what I did:
1) Deleted existing liblist.gam file file - assumed it was fracked-up in some way.
2) Re-ran SteamCMD to update/validate the Counter-Strike install. That resulted in a fresh liblist.gam file being downloaded.
3) Re-customized the liblist.gam file as specified.
4) Started it up and all looks good so far. This is with the defaul PBMM "full" install with-out any customized bot names or any of the other customized stuff I took out during previous troubleshooting.

PS: Also running it as version "V3B22c", because I had downloaded and tried that during prior troubleshooting.
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#20)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 31-05-2013

Just for reference ....

Current (working at the moment) liblist.gam file:
Code:
game "Counter-Strike"
url_info "www.counter-strike.net"
url_dl ""
version "1.6"
size "184000000"
svonly "0"
secure "1"
type "multiplayer_only"
cldll "1" 
hlversion "1111"
nomodels "1"
nohimodel "1"
mpentity "info_player_start"
gamedll "dlls\mp.dll"
gamedll_linux "addons/metamod/dlls/metamod_i386.so"
gamedll_osx "dlls/cs.dylib"
trainmap "tr_1"
edicts	"1800"
Previous (presumably something wrong) liblist.gam file:
Code:
game "Counter-Strike"
url_info "www.counter-strike.net"
url_dl ""
version "1.6"
size "184000000"
svonly "0"
secure "1"
type "multiplayer_only"
cldll "1" 
hlversion "1111"
nomodels "1"
nohimodel "1"
mpentity "info_player_start"
//
//      These lines changed to implement
//      Metamod on this server ...
//
//gamedll "dlls\hl.dll"
//gamedll_linux "dlls/hl_i386.so"
gamedll "addons/metamod/dlls/metamod.dll"
gamedll_linux "addons/metamod/dlls/metamod.so"
gamedll "dlls\mp.dll"
gamedll_linux "dlls/cs.so"
gamedll_osx "dlls/cs.dylib"
trainmap "tr_1"
Looks like at some point, I must have had the metamod library named without the "_i386" in it.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com