.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Bug Reports
Bug Reports Post any bug you experience with the latest release of this bot here

Reply
 
Thread Tools
PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#1)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default PotBotMM 3.22b on Linux = Bots do not join team? - 12-04-2013

They seem to have been broken since probably that "SteamPipe" conversion.

I tried the update to "v3B22b" on my Linux server.
I updated the binaries only (podbot_mm_i386.so, podbot_mm_amd64.so and of course metamod.so) since I don't want to over-write any of my other configuration stuff.

They join the game, and stay in "spectator".
Basically, they never actually join a team.
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#2)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 12-04-2013

CS/CZERO version (write in the server console "version" and hit the "Enter key)? Steam/no steam? dproto used? What does the command "meta list" say (written also in the server console)? What was the previous version of podbot mm You were using previously?
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#3)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 12-04-2013

Thanks for the follow-up!

Regarding which Counter-Strike: Plain/original "CS" - not "CZ".
Regarding Steam: Official Steam (SteamPipe via SteamCMD) - not some hacked/non-Steam server.

Output from "version" command:
Quote:
Protocol version 48
Exe version 1.1.2.7/Stdio (cstrike)
Exe build: 14:59:14 Feb 13 2013 (5956)
Output from "meta version" command:
Quote:
Metamod v1.20-am 2013-02-14 (5:13)
by Will Day <willday@metamod.org>
http://www.metamod.org/
compiled: Feb 13 2013, 23:23:17 -0800 (optimized)
Output from "meta list" command:
Quote:
Currently loaded plugins:
description stat pend file vers src load unlod
[ 1] AMX Mod X RUN - amxmodx_mm_i386. v1.8.2 ini Start ANY
[ 2] POD-Bot mm RUN - podbot_mm_i386.s vV3B22b ini Chlvl ANY
[ 3] Fun RUN - fun_amxx_i386.so v1.8.2 pl1 ANY ANY
[ 4] FakeMeta RUN - fakemeta_amxx_i3 v1.8.2 pl1 ANY ANY
[ 5] CStrike RUN - cstrike_amxx_i38 v1.8.2 pl1 ANY ANY
[ 6] CSX RUN - csx_amxx_i386.so v1.8.2 pl1 ANY ANY
6 plugins, 6 running
PS: Output of "status" command:
Code:
status
hostname:  Weasels CS (New-IP!): AMX, some bots
version :  48/1.1.2.7/Stdio 5956 secure  (10)
tcp/ip  :  192.30.161.61:6103
map     :  cs_militia at: 0 x, 0 y, 0 z
players :  8 active (32 max)

#      name userid uniqueid frag time ping loss adr
# 1 "K9[bot]" 1 BOT   0 24:32    0    0
# 2 "Evil_Bill[bot]" 2 BOT   0 24:32    0    0
# 3 "Data[bot]" 3 BOT   0 24:32    0    0
# 4 "Cylon_Centurion[bot]" 4 BOT   0 24:32    0    0
# 5 "Battle-Droid[bot]" 5 BOT   0 24:32    0    0
# 6 "WOPR[bot]" 6 BOT   0 24:32    0    0
# 7 "Project_2501[bot]" 7 BOT   0 24:32    0    0
# 8 "FemBot[bot]" 8 BOT   0 24:32    0    0

Last edited by Weasel; 12-04-2013 at 21:31..
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#4)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 12-04-2013

What are Your podbot.cfg settings (folder addons/podbot - without comment lines)? How does look like Your addons folder (make a screenshot of it - to let me see how names of folders are written there)?
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#5)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 12-04-2013

Quote:
Originally Posted by KWo View Post
What was the previous version of podbot mm You were using previously?
Since You said You updated podbot mm on Your server, then it means before - some previous version - was working correctly. What was that version number/date creation?
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#6)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 13-04-2013

Quote:
Originally Posted by KWo View Post
Since You said You updated podbot mm on Your server, then it means before - some previous version - was working correctly. What was that version number/date creation?
Previous version was not working. I think it all stopped working after the last Counter-Strike update(s). It was working at some point after converting/rebuilding as a SteamPipe/SteamCMD server (Valve's new content-delivery stuff - replacing HLDSUpdateTool), then later (after a some later CS update) it stopped working.

I tried updating to 3.22b to see if that would help, it didn't.
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#7)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 13-04-2013

PS: Here's the tree-structure involved ... relative to the base install location (hlds_linux):

Code:
.
|-- b6c158c6d9cdbbcd25efe30ebeabc5fcca7193b9
|-- cstrike
|   |-- CUSTOMIZATION
|   |-- addons
|   |   |-- amxmodx
|   |   |   |-- configs
|   |   |   |-- data
|   |   |   |   `-- lang
|   |   |   |-- dlls
|   |   |   |-- extensions
|   |   |   |-- logs
|   |   |   |-- modules
|   |   |   |-- plugins
|   |   |   |-- scripting
|   |   |   |   |-- amxmod_compat
|   |   |   |   |-- compiled
|   |   |   |   |-- include
|   |   |   |   |   `-- amxmod_compat
|   |   |   |   `-- testsuite
|   |   |   `-- translations
|   |   |-- metamod
|   |   |   `-- dlls
|   |   `-- podbot
|   |       |-- botchats
|   |       |-- pod_v3 docs
|   |       |   |-- files
|   |       |   |   |-- configs
|   |       |   |   `-- scripts
|   |       |   |       |-- other
|   |       |   |       |   |-- 252mapcm
|   |       |   |       |   `-- pbdefaultcm
|   |       |   |       `-- waypoint
|   |       |   |           `-- PodBot MM
|   |       |   |-- html
|   |       |   |-- images
|   |       |   |   `-- _notes
|   |       |   |-- index
|   |       |   `-- smileys
|   |       `-- wptdefault
|   |-- cl_dlls
|   |-- classes
|   |-- dlls
|   |-- events
|   |-- gfx
|   |-- iga_static
|   |-- logs
|   |-- manual
|   |-- maps
|   |-- models
|   |-- overviews
|   |-- resource
|   |-- sound
|   `-- sprites
|-- czero
`-- valve

Last edited by Weasel; 13-04-2013 at 03:29.. Reason: Formatting
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#8)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 13-04-2013

Quote:
Originally Posted by KWo View Post
What are Your podbot.cfg settings (folder addons/podbot - without comment lines)?
How about that? Do I need to ask You everything twice (or more) to get the answer? What was the version number of podbot mm You had working any time before any steam update? Did You get them working whole or You were never playing with podbot mm (because even before steam update they weren't working)? Did You try to use All-In-One package?
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#9)
Weasel
Member
 
Weasel's Avatar
 
Status: Offline
Posts: 44
Join Date: Mar 2008
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 13-04-2013

Quote:
Originally Posted by KWo View Post
How about that? Do I need to ask You everything twice (or more) to get the answer? What was the version number of podbot mm You had working any time before any steam update? Did You get them working whole or You were never playing with podbot mm (because even before steam update they weren't working)? Did You try to use All-In-One package?
Sorry, working on troubleshooting this if/when I can - around my day job and other resource constraints. Not troubleshooting this in one continuous steam of efforts, so it's hard to keep to memory/history straight. I only recently noticed they weren't working - since I've been working mostly on fixing issues on other servers lately.

I over-wrote the previous binaries. So, unsure what version they were.

I probably have backup copies in a 7-zip files somewhere. I'll try putting them back and see if what version they claim to be.

I have not tried the "all-in-one" package (yet), because I didn't want to have any AMX configuration stuff, plugins, or basically any stuff not related to PB altered. I'll back everything up, delete it all and try that.

Below are the settings from the configuration file (with the comment-line's stripped-out):
Code:
pb_wptfolder wptdefault
pb_welcomemsgs 1
pb_usespeech 0
pb_minbots 0
pb_maxbots 8
pb_bot_quota_match 0
pb_bot_join_team "ANY"
pb_skin 5
pb_timer_sound 0.5
pb_timer_pickup 0.3
pb_timer_grenade 0.5
pb_spray 0
pb_ffa 0
pb_shootthruwalls 1
pb_passwordkey "_pbadminpw"
pb_password {REDACTED}
pb_numfollowuser 5
pb_minbotskill 25
pb_maxbotskill 50
pb_maxweaponpickup 6
pb_mapstartbotdelay 10
pb_autokill 0
pb_autokilldelay 60
pb_maxcamptime 30
pb_jasonmode 0
pb_detailnames 0
pb_dangerfactor 2000
pb_chat 1
pb_latencybot 2
pb_radio 1
pb_aim_type 4
pb_aim_spring_stiffness_x 13.0
pb_aim_spring_stiffness_y	13.0
pb_aim_damper_coefficient_x 0.22
pb_aim_damper_coefficient_y 0.22
pb_aim_deviation_x 2.0
pb_aim_deviation_y 1.0
pb_aim_influence_x_on_y 0.25
pb_aim_influence_y_on_x 0.17
pb_aim_offset_delay 1.2
pb_aim_notarget_slowdown_ratio 0.5
pb_aim_target_anticipation_ratio 2.2
pb_restrequipammo "000000000"
pb fillserver 50

Last edited by Weasel; 13-04-2013 at 23:38.. Reason: Formatting.
  
Reply With Quote
Re: PotBotMM 3.22b on Linux = Bots do not join team?
Old
  (#10)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: PotBotMM 3.22b on Linux = Bots do not join team? - 14-04-2013

How about these names of bots:
Quote:
Originally Posted by Weasel View Post
# 1 "K9[bot]" 1 BOT 0 24:32 0 0
# 2 "Evil_Bill[bot]" 2 BOT 0 24:32 0 0
# 3 "Data[bot]" 3 BOT 0 24:32 0 0
# 4 "Cylon_Centurion[bot]" 4 BOT 0 24:32 0 0
# 5 "Battle-Droid[bot]" 5 BOT 0 24:32 0 0
# 6 "WOPR[bot]" 6 BOT 0 24:32 0 0
# 7 "Project_2501[bot]" 7 BOT 0 24:32 0 0
# 8 "FemBot[bot]" 8 BOT 0 24:32 0 0
Are they from Your botnames.txt file or they are other bots on Your server (ZBOTs or anything else)?
About All-In-One package mentioned before - my advice:
1. Download the package.
2. Stop the server.
3. Rename Your existing "addons" folder to something like addons_old.
4. Unzip all the crap from All-In-One package into the main cstrike folder (let overwrite all files - main files You need are now in addons_old folder).
5. Start the server (without changing any default settings) and see if there are any bots added.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com