.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Bug Reports
Bug Reports Post any bug you experience with the latest release of this bot here

Reply
 
Thread Tools
Podbot causing server to crash
Old
  (#1)
posse
Member
 
Status: Offline
Posts: 11
Join Date: Oct 2011
Default Podbot causing server to crash - 08-10-2011

Hello there, the bots are causing the server to crash but unfortunately no error message is being produced!

it is a HLDS 1.6 on linux Centos 5, i am using the latest podbot V 3.0 metamod Build 21

metamod 1.19

I turned off the bots and it stopped crashing. Is there anyway to produce an error message at server crash? I tried +log on +mp_logecho 1 on start up command but no errors produced still.

it just crashes with no error in console, if it did show an error I may be able to remedy it.

I am trying to run bots on a zombie swarm server on linux centos 5 with metamod 1.19 and amxmodx 1.8.1, are there different bots that i should use?
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#2)
Ancient
PodBot MM's Laziest Waypointer
 
Ancient's Avatar
 
Status: Offline
Posts: 1,010
Join Date: Jan 2005
Location: Nebraska, United States of America
Default Re: Podbot causing server to crash - 08-10-2011

Sometimes in certain maps there will be more than one weapon available in slot one or two (of inventory), the map will sometimes crash without errors when bots are running on it.

This also happens with YaPB v2.55.

But that isn't the issue here, I just simply think PBMM isn't compatible with Zombie Mod yet... at least not completely.


[Web Designer][Waypointer][Gamer]
CFE Games Administrator
[CFE]Games.com
[Never Trust the Untrusted]
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#3)
posse
Member
 
Status: Offline
Posts: 11
Join Date: Oct 2011
Default Re: Podbot causing server to crash - 08-10-2011

Can i disable the inventory for bots? How can I do that, I am only using the bots in the zombie side, so they do not need guns.
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#4)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: Podbot causing server to crash - 09-10-2011

What is the version number of Zombie Swarm mod You are using? I'll try to test it on my PC.
Please write also the command in the server console:
amxx plugins
and copy and paste the output here (so I know what else You are using there).
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#5)
posse
Member
 
Status: Offline
Posts: 11
Join Date: Oct 2011
Default Re: Podbot causing server to crash - 09-10-2011

I am using zombie swarm version 3.0.2 which is the latest one. I am also using the beta release of the podbots, I was using the official release but it was still crashing so I switched to beta but it still crashes. I took out the guns for bots, i think i did that properly, i put -1's in the file, it took longer to crash but it still did crash with no error produced.

The plugins I am running are:

[ 1] Admin Base 1.8.1.3746 AMXX Dev Team admin.amxx running
[ 2] Admin Commands 1.8.1.3746 AMXX Dev Team admincmd.amxx running
[ 3] Admin Help 1.8.1.3746 AMXX Dev Team adminhelp.amxx running
[ 4] Multi-Lingual System 1.8.1.3746 AMXX Dev Team multilingual.am running
[ 5] Menus Front-End 1.8.1.3746 AMXX Dev Team menufront.amxx running
[ 6] Commands Menu 1.8.1.3746 AMXX Dev Team cmdmenu.amxx running
[ 7] Players Menu 1.8.1.3746 AMXX Dev Team plmenu.amxx running
[ 8] Maps Menu 1.8.1.3746 AMXX Dev Team mapsmenu.amxx running
[ 9] Plugin Menu 1.8.1.3746 AMXX Dev Team pluginmenu.amxx running
[ 10] Admin Chat 1.8.1.3746 AMXX Dev Team adminchat.amxx running
[ 11] Anti Flood 1.8.1.3746 AMXX Dev Team antiflood.amxx running
[ 12] Scrolling Message 1.8.1.3746 AMXX Dev Team scrollmsg.amxx running
[ 13] Info. Messages 1.8.1.3746 AMXX Dev Team imessage.amxx running
[ 14] Admin Votes 1.8.1.3746 AMXX Dev Team adminvote.amxx running
14:51:33 [ 15] NextMap 1.8.1.3746 AMXX Dev Team nextmap.amxx running
[ 16] Nextmap Chooser 1.8.1.3746 AMXX Dev Team mapchooser.amxx running
[ 17] TimeLeft 1.8.1.3746 AMXX Dev Team timeleft.amxx running
[ 18] Pause Plugins 1.8.1.3746 AMXX Dev Team pausecfg.amxx running
[ 19] Stats Configuration 1.8.1.3746 AMXX Dev Team statscfg.amxx running
[ 20] Restrict Weapons 1.8.1.3746 AMXX Dev Team restmenu.amxx running
[ 21] StatsX 1.8.1.3746 AMXX Dev Team statsx.amxx running
[ 22] Credit Mod 1.0.4 atambo credit.amxx running
[ 23] Sentry guns 0.5.3 JGHG & GlobalMod gmsentryguns.am running
[ 24] round_money 0.7 SweatyBanana round_money.amx running
[ 25] Round Terminator 1.0.1 Arkshine round_terminato running
[ 26] Zombie Swarm 3.0.2 Mini_Midget zombie_swarm.am running
[ 27] unammo.amxx debug
[ 28] Swear Replacement 1.5 kaboomkazoom compile.amxx running
[ 29] NadeModes 10 Nomexous & OT nademodes.amxx running
[ 30] FrostNades 2.09 Avalanche frostnades.amxx running
[ 31] Napalm Nades 1.3a MeRcyLeZZ napalm_nades.am running
[ 32] AFK Manager v1.6 Leon McVeran afk_manager.amx running
[ 33] Game Namer 1.1 NeuroToxin gamenamechanger running
[ 34] Laser/Tripmine Entity 2.3 SandStriker lasermine_023.a running
[ 35] Parachute 1.3 KRoT@L/JTP10181 amx_parachute.a running
[ 36] xREDIRECT 1.0.3.3 x0R xredirect.amxx running
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#6)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: Podbot causing server to crash - 10-10-2011

Does it crash on every map or only on certain map?
Can You disable for test all custom plugins except Zombie Swarm (and - of course - except default AMXX plugin)? I want to see if the problem with the compatibility is with Zombie Swarm or with other Your plugin.
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#7)
posse
Member
 
Status: Offline
Posts: 11
Join Date: Oct 2011
Default Re: Podbot causing server to crash - 10-10-2011

i have an inkling that it could be crashing on a certain map, i just forget to look at which map it was on when it crashed. last time i looked it was hide_n_seek, i am waiting for it to crash again to see if it crashes on the same map. however, i have been on that map and played through the whole map untill map change it didn't crash.
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#8)
Ancient
PodBot MM's Laziest Waypointer
 
Ancient's Avatar
 
Status: Offline
Posts: 1,010
Join Date: Jan 2005
Location: Nebraska, United States of America
Default Re: Podbot causing server to crash - 10-10-2011

Test to see if it is other maps.

Also, how often did your server crash, was it occasional, rare or was it all the time?

I'm curious if you enabled Jason Mode (knives only) if it'd help prevent the maps from crashing.


[Web Designer][Waypointer][Gamer]
CFE Games Administrator
[CFE]Games.com
[Never Trust the Untrusted]
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#9)
posse
Member
 
Status: Offline
Posts: 11
Join Date: Oct 2011
Default Re: Podbot causing server to crash - 11-10-2011

It crashed again, this time on a different map, so I don't think its related to maps. i enable jason mode to test.

It crashes almost every 10 hours or so. its like routine.
  
Reply With Quote
Re: Podbot causing server to crash
Old
  (#10)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: Podbot causing server to crash - 11-10-2011

Did You test it only with Zombie Swarm (and default amxx plugins) or with everything You have there? From that what I know - Zombie Swarm needs round_terminator plugin to work - so please test with it and none custom plugin else.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com