.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Common Questions
Common Questions Are you seeking help ? Get it here !

Reply
 
Thread Tools
Unable to load pb mm on Linux
Old
  (#1)
tropicalxplorer
Member
 
Status: Offline
Posts: 12
Join Date: Sep 2005
Default Unable to load pb mm on Linux - 18-09-2005

I've upgraded the i386.so file from R2b46a to R2b46d on my Enterprise Linux 4 server and it doesn't appear to load. At the console when I type meta list it shows that all plugins load except for podbot (badf error). When I revert back to the R2b46a version all is ok.

I've downloaded the version d release several times thinking that the file was corrupted.

Any help is greatly appreciated.:'(
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#2)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: Unable to load R2b46d on Linux - 18-09-2005

since R2B46d all podbot directories should be written in lower case sensitivity (for example "podbot" instead "PODBot"). Make sure the line in Your metamod's plugins.ini file calling Your podbot *.so file looks so:

linux addons/podbot/podbot_mm_i386.so

If it still doesn't work for You just make the screenshots (but as jpg files) of Your addons directory and podbot directory (to show me the structure of Your folders). Copy and paste also the contents of Your plugins.ini file.
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#3)
tropicalxplorer
Member
 
Status: Offline
Posts: 12
Join Date: Sep 2005
Default Re: Unable to load R2b46d on Linux - 18-09-2005

ok..checked for the lower case on the directory structure as well as the call from plugins.ini and all looks well. I included 3 screenshots:

screen1 - displays directory structure
screen2 - dsplays contents of podbot
screen3 - displays contents of plugins.ini

on another note...I have another machine running an older version of redhat enterprise and I copied the entire hlds_l directory structure from from my problematic server (which is running redhat enterprise v4) to the server which is running the older version of linux and it is working perfectly. My son was able to play along with the bots and there were no problems. I mad no changes...just simply copied the entire hlds_l contents.

Only other difference from the OS is that my problem server is running on faster hardware and I'm hoping to get it working with the newer OS.

Thanks in advance!
Attached Thumbnails
Click image for larger version

Name:	screen1.jpg
Views:	838
Size:	89.6 KB
ID:	729   Click image for larger version

Name:	screen3.jpg
Views:	729
Size:	72.9 KB
ID:	730   Click image for larger version

Name:	screen2.jpg
Views:	759
Size:	73.9 KB
ID:	731  
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#4)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: Unable to load R2b46d on Linux - 18-09-2005

Do You remember where did You download from the version R2B46a linux? If this version is working for You (on this faster machine), I have to ask the man compiling it for linux to compile also R2B46d (there might be a deal with some optimization switches during compiling). Then we will try again.
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#5)
tropicalxplorer
Member
 
Status: Offline
Posts: 12
Join Date: Sep 2005
Default Re: Unable to load R2b46d on Linux - 19-09-2005

I located the R2B46a from somewhere on this forum. Anyway just checked my newer faster machine and OS and the version A does load without errors but the bots never join game just stay as spectators. I haven't tried version A on the older hardware and OS because its running fine with version D. I'll look forward to any updates.
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#6)
Lazarus Long
Member
 
Lazarus Long's Avatar
 
Status: Offline
Posts: 27
Join Date: Feb 2005
Default Re: Unable to load R2b46d on Linux - 19-09-2005

Hello, tropicalxplorer:

Quote:
Originally Posted by tropicalxplorer
Anyway just checked my newer faster machine and OS and the version A does load without errors but the bots never join game just stay as spectators.
This was what the D version came to fix.

Quote:
Originally Posted by tropicalxplorer
I haven't tried version A on the older hardware and OS because its running fine with version D. I'll look forward to any updates.
It'll do the same as the other.

Can you please post your startup log while trying to run the D version. I suspect that RedHat might have incompatible libraries (they do have a history of this), and seeing the error, might help in solving it.

Just install the gdb package and add the -debug parameter to your hlds_run command line.

Also post the result of running in a shell console:
Code:
cat /proc/cpuinfo
free
uname -a
Regards,
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#7)
tropicalxplorer
Member
 
Status: Offline
Posts: 12
Join Date: Sep 2005
Default Re: Unable to load R2b46d on Linux - 19-09-2005

work calls and I will post info later in the week...thanks for all the assistance so far.
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#8)
tropicalxplorer
Member
 
Status: Offline
Posts: 12
Join Date: Sep 2005
Default Re: Unable to load R2b46d on Linux - 23-09-2005

ok...back and got it to the point of loading the gdb package and running the ./hlds_run command followed by -debug. Unfortunately I'm not savy with this kind of stuff and I don't know where to find the startup log you are referring to...other than the logs directory under cstrike...but I don't think that's what you're looking for???
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#9)
tropicalxplorer
Member
 
Status: Offline
Posts: 12
Join Date: Sep 2005
Default Re: Unable to load R2b46d on Linux - 24-09-2005

ok...here's what I captured from one of the log files...hope this helps?

L 09/23/2005 - 14:11:19: [META] ini: Begin re-reading plugins list: /hlds_l/cstrike/addons/metamod/plugins.ini
L 09/23/2005 - 14:11:19: [META] ini: Read plugin config for: AMX Mod X
L 09/23/2005 - 14:11:19: [META] ERROR: ini: Plugin '<podbot_mm_i386.so>' has newer file, but unexpected status (badfile)
L 09/23/2005 - 14:11:19: [META] ini: Read plugin config for: <podbot_mm_i386.so>
L 09/23/2005 - 14:11:19: [META] ini: Finished reading plugins list: /hlds_l/cstrike/addons/metamod/plugins.ini; Found 2 plugins
L 09/23/2005 - 14:11:19: [META] dll: Updating plugins...
L 09/23/2005 - 14:11:19: [META] ERROR: dll: Failed query plugin '<podbot_mm_i386.so>'; Couldn't open file '/hlds_l/cstrike/addons/podbot/podbot_mm_i386.so': libstdc++.so.5: cannot open shared object file: No such file or directory
L 09/23/2005 - 14:11:19: [META] ERROR: dll: Skipping plugin '<podbot_mm_i386.so>'; couldn't query
L 09/23/2005 - 14:11:19: [META] dll: Finished updating 5 plugins; kept 1, loaded 0, unloaded 0, reloaded 0, delayed 0
L 09/23/2005 - 14:11:19: Log file closed

and here is the other info requested:
cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 2.60GHz
stepping : 9
cpu MHz : 2593.754
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips : 5128.19

free
total used free shared buffers cached
Mem: 1027736 1017300 10436 0 141192 607788
-/+ buffers/cache: 268320 759416
Swap: 2031608 0 2031608
uname -aLinux localhost.localdomain 2.6.9-5.EL #1 Wed Jan 5 19:22:18 EST 2005 i686 i686 i386 GNU/Linux
  
Reply With Quote
Re: Unable to load R2b46d on Linux
Old
  (#10)
Lazarus Long
Member
 
Lazarus Long's Avatar
 
Status: Offline
Posts: 27
Join Date: Feb 2005
Default Re: Unable to load R2b46d on Linux - 24-09-2005

tropicalxplorer:

Quote:
Originally Posted by tropicalxplorer
I don't know where to find the startup log you are referring to...other than the logs directory under cstrike...but I don't think that's what you're looking for???
Yep, that's it.

Quote:
Originally Posted by tropicalxplorer
L 09/23/2005 - 14:11:19: [META] ERROR: dll: Failed query plugin '<podbot_mm_i386.so>'; Couldn't open file '/hlds_l/cstrike/addons/podbot/podbot_mm_i386.so': libstdc++.so.5: cannot open shared object file: No such file or directory
Here it is, you are missing libstdc++.so.5. I'm not that familiar with Red Hat packaging but I think that the RPM package is called compat-libstdc++, so get the one for your distribution (see if you can find one with version 2.9x for best compatibility) and try it out.

If it still persists, post back. It's weird though, since PODBot mm should have the stdc++ library linked statically and this shouldn't be occurring, unless an old Makefile is still being used to create binaries.

Quote:
Originally Posted by tropicalxplorer
uname -aLinux localhost.localdomain 2.6.9-5.EL #1 Wed Jan 5 19:22:18 EST 2005 i686 i686 i386 GNU/Linux
No memory page faults? If so see if there is a newer kernel package, like 2.6.10 or 2.6.12 (not 2.6.11), unless the 2.6.9 version that Red Hat distributes was patched already.

Regards,
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com