.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Bug Reports
Bug Reports Post any bug you experience with the latest release of this bot here

Reply
 
Thread Tools
there is a bot aiming system bug
Old
  (#1)
iluvbot
Member
 
Status: Offline
Posts: 25
Join Date: Dec 2010
Default there is a bot aiming system bug - 18-12-2011

hi ,there is a bot aiming system bug :
when i keep shooting ( not release fire button) ,the bot seems wait for me to release ,so i can kill him by this way
( i try set pb_aim_type 4 ,3,2,1 ) (i usually set to 4) but this still happens
this happens to all podbot clones : yapb , epod
  
Reply With Quote
Re: there is a bot aiming system bug
Old
  (#2)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: there is a bot aiming system bug - 19-12-2011

Please make a test - take a M249 weapon and start fireing at the bot (until You kill him or Your clip is empty). If You are right, everytime You should kill the bot (without getting killed by him), because it should wait until Your clip is empty (as You wrote).
  
Reply With Quote
Re: there is a bot aiming system bug
Old
  (#3)
iluvbot
Member
 
Status: Offline
Posts: 25
Join Date: Dec 2010
Default Re: there is a bot aiming system bug - 20-12-2011

i 've just tested :
not everytime but
when i shot (and pains him before he can action , then keeping my fire,

in most case (about 80-90%) the bot get killed ,especially in not very long distance , i usually not lose hp (or lose only about 20 hp)

i die when he is too far or when the bot shoot (and pains me) before i fire, this case although i keep shooting ,if my shoot can't pain him => i die
almost time i can kill him by this way , maybe because i'm play with them for a long time

so i think it's better if the bot aiming system become more rich and always auto switch between aiming types

when i keep shooting he get pains ,if i release the fire , he shots and pains me immediately
( i set MIN_DELAY 0.06
MAX_DELAY 0.15
HEADSHOT_ALLOW 70
HEAR_SHOOTTHRU 40
SEEN_SHOOTTHRU 100 )
(this still happens when i set bot to godlike
another question, increase TURNSPEED will make bots look around more frequently and more chance to detect enemy ?

2. it says that turnspeed is the degree in frame bot look around ,isn't it ?
i set fps_max =60 (in my listenserver) now i leave :
MIN_TURNSPEED 8.0
MAX_TURNSPEED 15.0
could you please give me an advice to change this value to make bots better ?
is there a max value of them ( i mean if we set these > this max value, it won't give bot more chance to see enemy)
  
Reply With Quote
Re: there is a bot aiming system bug
Old
  (#4)
KWo
Developer of PODBot mm
 
KWo's Avatar
 
Status: Offline
Posts: 3,424
Join Date: Apr 2004
Default Re: there is a bot aiming system bug - 20-12-2011

Settings from the botskill.cfg file are used only for the pb_botaim_type 1
For the default setting (4) - there are settings in podbot.cfg file. They are started with "pb_aim_xx" (just below pb_aim_type). pb_aim_spring_stiffness_x and pb_aim_spring_stiffness_y are affecting the bot turning speed the most. You have to find out by Your-self the best settings for Your needs.
  
Reply With Quote
Re: there is a bot aiming system bug
Old
  (#5)
Immortal_BLG
Member
 
Status: Offline
Posts: 170
Join Date: Nov 2007
Location: Russian Federation
Default Re: there is a bot aiming system bug - 21-12-2011

All this probably because of punch angle compensation (BotDoFirePause()). When you attacking bot, his punch angles increases and he waits untill punch angles will move down, and only then bot will shoot at you.

Sorry for bad english, hope that luvbot understand me clearly.
  
Reply With Quote
Re: there is a bot aiming system bug
Old
  (#6)
iluvbot
Member
 
Status: Offline
Posts: 25
Join Date: Dec 2010
Default Re: there is a bot aiming system bug - 21-12-2011

yes, i think i understand, thank you ,Immortal_BLG
i hope this will be fix
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com