.:: Bots United ::.  
filebase forums discord server github wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps yapb

Go Back   .:: Bots United ::. > Cyborg Factory > FritzBot
FritzBot A bot for Return To Castle Wolfenstein - by Maleficus Return to Castle Wolfenstein

Reply
 
Thread Tools
Weird problem with map mp_xdam
Old
  (#1)
the bindlestiff
Member
 
the bindlestiff's Avatar
 
Status: Offline
Posts: 280
Join Date: Nov 2005
Location: Washington state
Default Weird problem with map mp_xdam - 10-12-2005

We have xdam in the map-rotation cycle of our server. Logging on this morning, we found the map running with all the bots invisible and stuck in place. Time had run out but the round had not ended. We could run around in the map except when we hit an invisible bot. This would prevent us from continuing; usually we could get around them unless they were stuck in a doorway.. They were impervious to gunfire and explosives, too. Grabbing the objective and returning it to the transmitter room as required did not end the game. The limbo screen indicated that this was a death match" when it should have been an objective game. The scores of all the bots were zero.

I did a map_restart, all the bots reappeared and the game looked like it was going to be normal. The limbo screen indicated that this was an objective round, as it should.

When one of our bots snatched the objective, I made my way to the transmitter room ahead of him to see what would happen. He entered the room, ran to the transmiter table, nothing happened; he ran to the door and back again many times. Finally I took the objective from him and did it myself with no change. Eventually the other bots blew the rest of the objectives and the game ended. When the "Allies win" screen appeared, it could not be removed, other than by another map_restart.

I could find nothing amiss with my map-rotation config -- no typos, no wrong gametype, etc. This is a copy of the relevent lines:
----------------
// X-DAM
set d36 "g_gametype 5; map mp_xdam; set nextmap vstr d36b"
set d36b "map_restart; set nextmap vstr 37"
-------------------

I ran through the game alone, no bots, and found that the game would not end if I got the objective to the radio room. There was no acknowledgement that this event had occurred. It would seem that the objective actually need not be taken anywhere, other than to be snatched away from the axis.

So it looks like there is something awry with the map itself. This would be a good map were it not for this weird behavior. Has anyone come across the same situation??
  
Reply With Quote
Re: Weird problem with map mp_xdam
Old
  (#2)
420Blunt
Member
 
Status: Offline
Posts: 61
Join Date: Nov 2005
Default Re: Weird problem with map mp_xdam - 10-12-2005

The x-lab needs to be blown up before the docs can be returned and for the game to end. I'll have a look at it and probably set it up so they destroy the x-lab before they grab the docs.
  
Reply With Quote
Re: Weird problem with map mp_xdam
Old
  (#3)
the bindlestiff
Member
 
the bindlestiff's Avatar
 
Status: Offline
Posts: 280
Join Date: Nov 2005
Location: Washington state
Default Re: Weird problem with map mp_xdam - 10-12-2005

Thanks, Blunt. That's important information for the human players to know!
  
Reply With Quote
Re: Weird problem with map mp_xdam
Old
  (#4)
Rebel
Member
 
Status: Offline
Posts: 26
Join Date: Aug 2004
Default Re: Weird problem with map mp_xdam - 12-12-2005

hallo from russia again. Can U gyes give me some links where aii can download x-dam and x -(forgot,sorry) maps plz ?? 'Cause there're no these maps on the main known sites as aiii see...
  
Reply With Quote
Re: Weird problem with map mp_xdam
Old
  (#5)
the bindlestiff
Member
 
the bindlestiff's Avatar
 
Status: Offline
Posts: 280
Join Date: Nov 2005
Location: Washington state
Default Re: Weird problem with map mp_xdam - 12-12-2005

Quote:
Originally Posted by Rebel
hallo from russia again. Can U gyes give me some links where aii can download x-dam and x -(forgot,sorry) maps plz ?? 'Cause there're no these maps on the main known sites as aiii see...
I found them both (mp_xddam.zip and mk_x_lab.zip) at

http://www.gamehost.at/webmanager/view.php?docid=3379&
page=entersub&mainera=49&subarea=51

I split the link so that it would all be shown on the page. Be sure to combine the two sections in your browser. Hope this helps!
  
Reply With Quote
Re: Weird problem with map mp_xdam
Old
  (#6)
Rebel
Member
 
Status: Offline
Posts: 26
Join Date: Aug 2004
Default Re: Weird problem with map mp_xdam - 13-12-2005

big thnx man.
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com