.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Developer's Farm > General Bot Coding
General Bot Coding See what a pain it is to get those little mechs shooting around

Reply
 
Thread Tools
Metamod Fails to Load Latest HPB_bot Template #4 for LINUX
Old
  (#1)
Etih
Member
 
Status: Offline
Posts: 4
Join Date: Apr 2005
Default Metamod Fails to Load Latest HPB_bot Template #4 for LINUX - 20-04-2005

I recently downloaded and compiled the latest version of the HPB_bot template in LINUX using the provided Makefile, 'makefile_linux'. I had to make some minor changes to the source (I added #include <ctype.h> and #include <unistd.h> in some of the modules) and fixed a spelling error in 'makefile_linux'. When running hlds, however, metamod failed to load the compiled .so file. The sever error log reads:

L 04/19/2005 - 23:03:59: [META] ERROR: dll: Failed query plugin '<HPB_bot_i486.so>'; Couldn't find Meta_Query(): /home/ttwang/hlds/tfc/dlls/HPB_bot_i486.so: undefined symbol: Meta_Query

I am pretty certain that my 'plugin.ini' is configured correctly as I was able to successfully load the latest precompiled version of HPB_bot. Thanks in advance for any offered insights.
  
Reply With Quote
Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX
Old
  (#2)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX - 20-04-2005

Linux binaries for HL MUST be compiled with GCC 2.95.3. If you use another compiler, or another version, it will not work.

This is related to how the linker builds the exports and how the hl engine exchanges its entity function tables.



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX
Old
  (#3)
Whistler
Whistler
 
Whistler's Avatar
 
Status: Offline
Posts: 1,482
Join Date: Feb 2004
Location: P. R. China
Default Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX - 21-04-2005

gcc 2.95.3 isn't the problem, the problem is if you use gcc3 you must use "g++" command to compile

I think he means using HPB bot Template in Metamod. The HPB bot 4.0 is the Metamod version, but the "Template" is NON-METAMOD version
  
Reply With Quote
Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX
Old
  (#4)
Pierre-Marie Baty
Roi de France
 
Pierre-Marie Baty's Avatar
 
Status: Offline
Posts: 5,049
Join Date: Nov 2003
Location: 4643'60N 043'0W 0.187A
Default Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX - 21-04-2005

Are you sure of that Whistler ? I've never seen a working GCC 3 compiled Linux binary yet, and I did try several times.



RACC home - Bots-United: beer, babies & bots (especially the latter)
"Learn to think by yourself, else others will do it for you."
  
Reply With Quote
Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX
Old
  (#5)
Cpl. Shrike
ShrikeBot Coder/Moderator
 
Cpl. Shrike's Avatar
 
Status: Offline
Posts: 550
Join Date: Mar 2004
Location: The Netherlands
Default Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX - 21-04-2005

Im compiling hpb bots with gcc 3.3.3
And ShrikeBot ofcoarse.

But im not using the BU-2.3-SDK that don't work for me.
Im using the default 2.3-SDK.
  
Reply With Quote
Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX
Old
  (#6)
Etih
Member
 
Status: Offline
Posts: 4
Join Date: Apr 2005
Default Re: Metamod Fails to Load Latest HPB_bot Template #4 for LINUX - 22-04-2005

Thanks for the feedback, everyone.

Whistler is right; I had falsely assumed that the bot template was also a metamod plugin.

One issue I did notice, however, is that hlds doesn't seem to like the name, "HPB_bot_i486.so". Even though I have "liblist.gam" configured to load "HPB_bot_i486.so", hlds looks for "HPB_i386.so". Renaming the shared object to "HPB_i386.so" fixed the problem. Hlds also loaded the binary with the name "dbot.so" successfully after I configured "liblist.gam" to load "dbot.so". I'm not sure what exactly is causing the problem here, but at least there seems to be a workaround.

Anyways, with some minor changes to the source and the makefile, HPB template 4 should run after compiling with GCC3.

Last edited by Etih; 22-04-2005 at 08:07..
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com