.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > YaPB
YaPB Yet another POD-Bot flavor by Whistler and Jeefo Counter-Strike

Reply
 
Thread Tools
YapB no longer support CS 1.5?
Old
  (#1)
Bend3R
Member
 
Status: Offline
Posts: 50
Join Date: Jun 2005
Default YapB no longer support CS 1.5? - 02-11-2015

Just tried YapB (2.7.1.4225-git150) under CS 1.5 (linux).
Code:
[META] WARNING: dll: Failed query plugin '<yapb.so>'
Couldn't open file '/home/hlds_l/cstrike/addons/yapb/bin/yapb.so': /home/hlds_l/cstrike/addons/yapb/bin/yapb.so: undefined symbol: __cxa_guard_acquire
Also, I can't find the documentation how to restrict weapons, just the old commands it seems like.
Code:
//
// Weapons that bot unable to buy in any situations. Priority of this cvar higher, than the data specified in general.cfg
//
// Default: 
//
yb_restricted_weapons "famas" //?
yb_restricted_weapons "galil" //?
yb_restricted_weapons "shield" //?
yb_restricted_weapons "25" //?
Does it work the same way as Podbot or what?
   
Reply With Quote
Re: YapB no longer support CS 1.5?
Old
  (#2)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,566
Join Date: Jul 2004
Location: Bulgaria
Default Re: YapB no longer support CS 1.5? - 03-11-2015

It seems like untested corrupted binary or very old libstdc++.

What is the Linux distribution it's version that you are using?
   
Reply With Quote
Re: YapB no longer supports CS 1.5?
Old
  (#3)
jeefo
ouch
 
jeefo's Avatar
 
Status: Offline
Posts: 445
Join Date: Nov 2005
Location: Saint-Petersburg
Default Re: YapB no longer supports CS 1.5? - 03-11-2015

Hi! As far as i know, it'll work for CS 1.5. But tested only under Windowz. Not sure about linux hlds of CS 1.5. If not, can you please PM me a link with hlds for cs 1.5, i will fix the probs.

Try: https://yapb.jeefo.net/drop/releases..._latest.tar.xz (build 4305) I have removed GLIBC_2.15 dependency, it's should run ok. If not, give me "ldd yapb.so" output.

@Storm: yapb is not linked with libstdc++ dynamically nor statically
   
Reply With Quote
Re: YapB no longer supports CS 1.5?
Old
  (#4)
Bend3R
Member
 
Status: Offline
Posts: 50
Join Date: Jun 2005
Default Re: YapB no longer supports CS 1.5? - 03-11-2015

Running the game server under Ubuntu Server 10.04 (x86)
Also good to mention Metamod-P 1.21p37

http://www.moddb.com/mods/won2-cd-re...d-server-v3111
http://www.moddb.com/mods/won2-cd-re...-server-v3111e

Still same msg.

Code:
ldd cstrike/addons/yapb/bin/yapb.so
linux-gate.so.1 =>  (0xb7787000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb765f000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb765b000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb74f8000)
/lib/ld-linux.so.2 (0xb7788000)
   
Reply With Quote
Re: YapB no longer supports CS 1.5?
Old
  (#5)
jeefo
ouch
 
jeefo's Avatar
 
Status: Offline
Posts: 445
Join Date: Nov 2005
Location: Saint-Petersburg
Default Re: YapB no longer supports CS 1.5? - 04-11-2015

Quote:
Originally Posted by Bend3R View Post
Running the game server under Ubuntu Server 10.04 (x86)
Also good to mention Metamod-P 1.21p37

http://www.moddb.com/mods/won2-cd-re...d-server-v3111
http://www.moddb.com/mods/won2-cd-re...-server-v3111e

Still same msg.

Code:
ldd cstrike/addons/yapb/bin/yapb.so
linux-gate.so.1 =>  (0xb7787000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb765f000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb765b000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb74f8000)
/lib/ld-linux.so.2 (0xb7788000)
Oh 10.04... I can compile for it, but a little later.
   
Reply With Quote
Re: YapB no longer supports CS 1.5?
Old
  (#6)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,566
Join Date: Jul 2004
Location: Bulgaria
Default Re: YapB no longer supports CS 1.5? - 04-11-2015

@Bend3R I would recommend to update your Ubuntu installation. This version is no longer supported by Cannonical.
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com