.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > YaPB
YaPB Yet another POD-Bot flavor by Whistler and Jeefo Counter-Strike

Reply
 
Thread Tools
Re: CSBot enable plugin
Old
  (#21)
FaTRuS
Member
 
Status: Offline
Posts: 5
Join Date: Nov 2009
Default Re: CSBot enable plugin - 09-11-2009

Send please yours csbot_enable_mm.so for check
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#22)
FaTRuS
Member
 
Status: Offline
Posts: 5
Join Date: Nov 2009
Default Re: CSBot enable plugin - 17-11-2009

please need help!!!
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#23)
FaTRuS
Member
 
Status: Offline
Posts: 5
Join Date: Nov 2009
Default Re: CSBot enable plugin - 01-12-2009

This problem arises with steam on 48 report, about 47 all works normally

Help to start bots on 48 report
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#24)
Whistler
Whistler
 
Whistler's Avatar
 
Status: Offline
Posts: 1,478
Join Date: Feb 2004
Location: Beijing, P. R. China
Default Re: CSBot enable plugin - 02-12-2009

that looks like valve just removed the bot from the cs_i386.so (in previous versions valve just disabled it rather than removed it).

if that's true, then I don't think there is anything we can do about that maybe copying an cs_i386.so file from older versions can fix that (not sure if this will have any negative effect though).
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#25)
Whistler
Whistler
 
Whistler's Avatar
 
Status: Offline
Posts: 1,478
Join Date: Feb 2004
Location: Beijing, P. R. China
Default Re: CSBot enable plugin - 06-12-2009

this can be confirmed, as the dlls in latest steam version of CS and CZero are already different.
gotta update the webpage to note that.
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#26)
slam357
Member
 
Status: Offline
Posts: 1
Join Date: Feb 2010
Default Re: CSBot enable plugin - 16-02-2010

please help...not compile =(
Code:
[slam@myhost csbot_enable_mm]$ make
g++ -Dstricmp=strcasecmp -Dstrcmpi=strcasecmp -w -O1 -s -DNDEBUG=1 -I/home/slam/hlsdk/multiplayer/common -I/home/slam/hlsdk/multiplayer/engine -I/home/slam/hlsdk/multiplayer/dlls -I/home/slam/hlsdk/multiplayer/pm_shared -I/home/slam/metamod-1.19/metamod -c dllapi.cpp -o dllapi.o
In file included from dllapi.cpp:40:
/home/slam/metamod-1.19/metamod/metamod.h:82: ошибка: conflicting declaration ‘HL_enginefuncs_t g_engfuncs’
/home/slam/hlsdk/multiplayer/dlls/enginecallback.h:26: error: ‘g_engfuncs’ has a previous declaration as ‘enginefuncs_t g_engfuncs’
make: *** [dllapi.o] Error 1
metamod 1.19
hlsdk 2.3-p3
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#27)
tomba2k
Member
 
Status: Offline
Posts: 3
Join Date: Jan 2011
Default Re: CSBot enable plugin - 10-01-2011

here is version with modified Makefile to compile on SUSE x64:
http://www.megaupload.com/?d=QXX6O6JM
http://www.mediafire.com/?g4shd37vlhudqce

hope it will help someone.
btw, does anyone have p47 linux hlds engine?

P.S.: makefile compiles 32bit binary on x64 system.
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#28)
Immortal_BLG
Member
 
Status: Offline
Posts: 170
Join Date: Nov 2007
Location: Russian Federation
Default Re: CSBot enable plugin - 26-09-2011

Hello!

I seem have found the reason of crash when using plugin CSBot enable.
The reason not in a plug-in, but in a metamod. Specifically, in build 4554 valve has added in structure enginefuncs_t pointer to a new function pfnCheckParameter(). This new function is just used in mp.DLL for testing parameter "-nobots" when you create a bot. But since metamod does not pass this function in mp.DLL occurs "access violation reading location".

My solution: I just did bypass of a call of this function.

Source code is present.

New function definition:
Code:
// This function returns the launch parameter index in 'com_argv' array, 0 if nothing found. (*argument == com_argv[pfnCheckParameter()]) (Only latest steam versions has this function....)
const unsigned int (*pfnCheckParameter) (const char *const parameter, const char **const argument/* = NULL*/);	// (Example: "-nobots") (Added: 15 Jun 2009, build 4554)
WARNING: ONLY FOR WINDOWS 32 BIT!!!!

LINK

P.S. Sorry for bad english
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#29)
tomba2k
Member
 
Status: Offline
Posts: 3
Join Date: Jan 2011
Default Re: CSBot enable plugin - 26-09-2011

so, there's no solution for linux?
btw, your english is not so bad, but that isn't of such importance as effort you showed
   
Reply With Quote
Re: CSBot enable plugin
Old
  (#30)
Whistler
Whistler
 
Whistler's Avatar
 
Status: Offline
Posts: 1,478
Join Date: Feb 2004
Location: Beijing, P. R. China
Default Re: CSBot enable plugin - 26-09-2011

Quote:
Originally Posted by Immortal_BLG View Post
Hello!

I seem have found the reason of crash when using plugin CSBot enable.
The reason not in a plug-in, but in a metamod. Specifically, in build 4554 valve has added in structure enginefuncs_t pointer to a new function pfnCheckParameter(). This new function is just used in mp.DLL for testing parameter "-nobots" when you create a bot. But since metamod does not pass this function in mp.DLL occurs "access violation reading location".

My solution: I just did bypass of a call of this function.

Source code is present.

New function definition:
Code:
// This function returns the launch parameter index in 'com_argv' array, 0 if nothing found. (*argument == com_argv[pfnCheckParameter()]) (Only latest steam versions has this function....)
const unsigned int (*pfnCheckParameter) (const char *const parameter, const char **const argument/* = NULL*/);	// (Example: "-nobots") (Added: 15 Jun 2009, build 4554)
WARNING: ONLY FOR WINDOWS 32 BIT!!!!

LINK

P.S. Sorry for bad english
good job

tomba2k: maybe try patching the HLSDK & metamod sources to add the new engine API as Immortal_BLG noted and recompile?

Last edited by Whistler; 26-09-2011 at 14:48..
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com