.:: Bots United ::.  
filebase forums discord server github wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps yapb

Go Back   .:: Bots United ::. > Enhancement Workshop > (mEAn) Bot.Admin Mod / ServerLoader > (mEAn) Bot.Admin Mod Help
(mEAn) Bot.Admin Mod Help Need Help? Ask questions in here

Reply
 
Thread Tools
A few questions - Access / PODBots / Maps
Old
  (#1)
txc
Member
 
Status: Offline
Posts: 5
Join Date: Mar 2006
Default A few questions - Access / PODBots / Maps - 29-03-2006

First of all, thank you for mEAn. It was a struggle getting it toinstall (I finally found the answer on here by using autoexec.cfg), butsince then it's been great. It's reliably added and removed bots andkilled them all when all humans have died (which makes for aninteresting effect when the only human is a spectator). Working verynice with the server, AMX X and MM.

I just have a few questions.

1) Every time I connect, I get granted public access, not serverop. Ieven tried to do it just by nick and it doesn't seem to work.

this is what I have in the users.cfg:

; Place your authentication information below:
;
; SteamIDUsername Password Access
; ======= ============================= ======== ======
"10551250" "" "" "o1c"
"" "txc" "o1c"

am I missing something? is this file supposed to go somewhere else? i have it in both mean and the cstrike folders.

2) Is there any way to prevent PODBots from using the radio? since youcontrol them otherwise. I see this is a popular request on the PODBotforum but the developers seem reluctant (they've also been promising abeta which will fix other problems I've been experiencing for monthsnow).

3) Sometimes (maybe most of the time, but not all the time), when auser says nextmap, both HL and mEAn answer and the answers don't agree.Why don't they? and which one is right?

Thanks in advance for your help.


  
Reply With Quote
Re: A few questions - Access / PODBots / Maps
Old
  (#2)
botmeister
Ex-Council Member
 
botmeister's Avatar
 
Status: Offline
Posts: 1,090
Join Date: Nov 2003
Location: Canada
Default Re: A few questions - Access / PODBots / Maps - 04-04-2006

Quote:
Originally Posted by txc
1) Every time I connect, I get granted public access, not serverop. Ieven tried to do it just by nick and it doesn't seem to work.

this is what I have in the users.cfg:

; Place your authentication information below:
;
; SteamIDUsername Password Access
; ======= ============================= ======== ======
"10551250" "" "" "o1c"
"" "txc" "o1c"

am I missing something? is this file supposed to go somewhere else? i have it in both mean and the cstrike folders.
In the first line, the steam id is wrong since it's in the old WON format Should be something like this: steam_id:0:0:123456

The second line is missing the password:
"" "txc" "your password" "o1c"

If the password is empty it should be "" like this:
"" "txc" "" "o1c"

The users.cfg file should be located under the mEAn folder and no where else.

Quote:
2) Is there any way to prevent PODBots from using the radio? since youcontrol them otherwise. I see this is a popular request on the PODBotforum but the developers seem reluctant (they've also been promising abeta which will fix other problems I've been experiencing for monthsnow).
I can't easily stop POD from using the radio. My understanding is that someone created a metamod plugin to stop the bots from using radio, but that's all I know.

Quote:
3) Sometimes (maybe most of the time, but not all the time), when auser says nextmap, both HL and mEAn answer and the answers don't agree.Why don't they? and which one is right?
There maps cycles can get out of sync for a number of reasons. The correct answer is whichever map loads up as stated. If mEAn is wrong, you can disable the map change notification commands.

m_setcommand < command > [ enabled | disabled | access_code ]

Enables/Disables < command > which can be any valid (mEAn) command.
Access to the command may be changed by specifing an access_code
of ServerOp, Admin1, Admin2, Clan, Guest or Public

Examples:
m_setcommand m_nextmap disabled
m_setcommand nextmap disabled

If you want to fix the problem, right after you first run the HLDS server, check the map list as mEAn sees it using:

m_maplist

If the list does not match what it should be, there's a problem with loading the missing maps. Unfortunately, I did not add the ability to turn off the nextmap message completely.


Maker of the (mEAn) Bot.Admin Manager

"In theory, there is no difference between theory and practice. But, in practice, there is." - Jan L.A. van de Snepscheut
  
Reply With Quote
Re: A few questions - Access / PODBots / Maps
Old
  (#3)
txc
Member
 
Status: Offline
Posts: 5
Join Date: Mar 2006
Default Re: A few questions - Access / PODBots / Maps - 04-04-2006

ok, thanks for the responses. I'll try the users.cfg change. the STEAM ID would be enough for me but I wasn't sure based on the examples in the CFG file. i'm relatively new to the HL thing.

I guess I'll look into the POD radio MM as well (although that'll be a coup for sure if I manage to google that one). I was toying with trying to just patch the source myself, but the less work i have to do the better.

as far as the map change goes, I was incorrect. it *ALWAYS* thinks the next map is the same map (de_predator in my case). I just said most of the time because when the next map IS de_predator, it's right. I'll add those commands and review any other commands I might have missed that will help things run better.

i'll try what you suggest, but i'm a little confused by the process. if m_maplist doesn't agree (and it probably won't because the server has been restarted many times and it's never been right), what do I do? it doesn't just read mapcycle?


  
Reply With Quote
Re: A few questions - Access / PODBots / Maps
Old
  (#4)
botmeister
Ex-Council Member
 
botmeister's Avatar
 
Status: Offline
Posts: 1,090
Join Date: Nov 2003
Location: Canada
Default Re: A few questions - Access / PODBots / Maps - 04-04-2006

mEAn loads up its own version of the mapcycle by reading the maplist.txt file and using one of the server commands to verify that the map is valid - if not, the map is not loaded into the map cycle. I've seen problems with the maplist.txt file, such as invalid comment lines, tabs or spaces in front of the map name, and so on that will cause a map to be seen as invalid even though it's fine and loads into the mapcycle. Sometimes a map is invalid because there are some missing files asscoiated with it, but it will still load into the mapcycle and work for the most part. I think there's a file for some maps that describes what files (or resources) are associated with a goven map, so that's a place to look at. I'm not a map expert, so you should ask in the waypoint/mapping forums for help if a map is being rejected by mEAn.

Whatever HLDS is doing, it does not seem to use the same server function I use to check for map validity because it seems to load incomplete maps anyway. For the most part I was able to get mEAn's mapcycle to work for me by being careful when entering in the map names into the maplist.txt file and by making sure all my maps were installed correctly.

What you can do, is start with two maps and see if they load, then add one map at a time until all the maps load up correctly, or you discover the one that is not loading. When you find a map that's being rejected, you can try getting a fresh copy for reinstallation.


Maker of the (mEAn) Bot.Admin Manager

"In theory, there is no difference between theory and practice. But, in practice, there is." - Jan L.A. van de Snepscheut
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com