.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > E[POD]bot
E[POD]bot Evil mutants tamed out of POD-bot by The Storm and Markus Heiden Counter-Strike

Reply
 
Thread Tools
Troubleshooting - Linux install
Old
  (#1)
Peedori
Member
 
Status: Offline
Posts: 4
Join Date: Nov 2012
Default Troubleshooting - Linux install - 18-11-2012

Hey guys,
I've had some difficultys with a linux install of EPODbot and I'd like to share my solution with you.

In the following instructions we only talk about metamod server. Because it is easier to administrate a server with metamod.How to install metamod. Get MetaMod.

Troubleshooting

1. Make sure epb is loaded, type in server console:
Code:
meta list
You should get this message:
Code:
meta list
Currently loaded plugins:
      description         stat pend  file                 vers      src  load  unlod
 [ 1] E[POD]bot        RUN   -    EPB_i386.so       v5.30     ini  Start Never
...
But if you get something different, then check this:

1. Manual loading...
  • Unload the plugin in console, while server is running:
    Code:
    meta clear EPB_i386.so
  • Load the plugin
    Code:
    meta load EPODbot/EPB_i386.so
  • If it works you will get
    Code:
    meta load EPODbot/EPB_i386.so
    Plugin 'E[POD]bot' couldn't attach; only allowed at server startup

Now you know, you just typed something wrong in the metamod config.
Open it up again and correct your mistake!
For my server it is "linux EPODbot/EPB_i386.so" in the first line, without quotes. You should be able to locate this file on your server under "cstrike/EPODbot/", if not, upload it again .

Restart the server and everything will be fine!

Now the hard part! If the loading fails, after manually loading the plugin via console it will say:
Code:
meta load EPODbot/EPB_i386.so
Couldn't load plugin '<EPB_i386.so>'; see log
To me it happened, because EPB requires a library that is outdated.
EPB requires libstdc++5. Check if it already exists:
Code:
ls -la /usr/lib32 | grep libstdc++.so.5
you should get this:
Code:
lrwxrwxrwx  1 root root       18 2012-11-18 12:51 libstdc++.so.5 -> libstdc++.so.5.0.7
-rw-r--r--  1 root root   737192 2012-11-18 11:31 libstdc++.so.5.0.7
The first line is a file link that actually links to the second file.
If you get this, you are fine.
If you get nothing, just follow my tutorial:

2. Installing libstdc++
  • This library is required on linux servers to run EPODbot.
  • You need to have root permissions (e.g. with root account or with sudo)
  • Download the attached file ("libstdc++5.zip")
  • Upload the archive to your server
  • Use those commands in the folder where you uploaded it
    Code:
    unzip libstdc++5.zip
    sudo cp libstdc++.so.5.0.7 /usr/lib32/
    cd /usr/lib32
    sudo ln -s libstdc++.so.5.0.7 libstdc++.so.5

Now restart the server and check again your loaded plugins with:
Code:
meta list
You should be able to have fun now !
Attached Files
File Type: zip libstdc++5.zip (225.7 KB, 171 views)
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com