.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > Sandbot
Sandbot A bot for Gunman Chronicles and They Hunger - by tschumann

Reply
 
Thread Tools
progress
Old
  (#1)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 142
Join Date: Apr 2011
Location: Australia
Default progress - 05-11-2016

I'll post about any breakthroughs or interesting progress I have here.

Today's breakthrough was getting Day of Defeat bots working: they'll go back and forth capturing points on dod_avalanche and win rounds. Currently only four player classes are supported but it does work.
   
Reply With Quote
Re: progress
Old
  (#2)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 142
Join Date: Apr 2011
Location: Australia
Default Re: progress - 21-05-2017

So I investigated the crashing in Opposing Force CTF yesterday - it didn't crash immediately but when it did it was because it was trying to look up a non-existent waypoint (not sure why it would do that - I haven't touched the waypointing code in such a way that would break it). Anyway, I've started adding support for Opposing Force CTF.
   
Reply With Quote
Re: progress
Old
  (#3)
Persephone
Member
 
Status: Offline
Posts: 25
Join Date: Mar 2014
Location: Indonesia
Default Re: progress - 22-05-2017

Maybe we have a different opinion

In my opinion, when Sandbot playing on CTF Maps without any waypoints, it seems fine (like a deathmatch). But if you adding waypoint to the current CTF maps and saving it for the later play, after BOT joins then my game will crash. So it makes non sense if the game crash because BOT looking up a non-existent waypoint.
   
Reply With Quote
Re: progress
Old
  (#4)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 142
Join Date: Apr 2011
Location: Australia
Default Re: progress - 23-05-2017

Yeah that's right - I added some waypoints and spawned some bots and the bot tried to use waypoint 6153 or something but there's a hard limit of 2048 waypoints, so it crashed.
   
Reply With Quote
Re: progress
Old
  (#5)
Persephone
Member
 
Status: Offline
Posts: 25
Join Date: Mar 2014
Location: Indonesia
Default Re: progress - 23-05-2017

Waypoint limit eh?

Is possible to fix it? I'm starting of lose any hope now -_-
   
Reply With Quote
Re: progress
Old
  (#6)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 142
Join Date: Apr 2011
Location: Australia
Default Re: progress - 27-05-2017

No it's not a limit issue, something is generating an invalid waypoint id.
Sandbot is one of many things that I work on (http://www.teamsandpit.com/#sandpit, http://www.teamsandpit.com/#zcmp, http://www.teamsandpit.com/#basis, http://www.teamsandpit.com/#gssmt as well as other private/unannounced stuff) so things like this take time.
   
Reply With Quote
Re: progress
Old
  (#7)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 142
Join Date: Apr 2011
Location: Australia
Default Re: progress - 10-06-2017

Getting further with Opposing Force CTF. I don't think the old flag/base finding stuff was correct or all there so I've fixed a lot of that up.
Now I need to find out why the bots aren't going to the flags...
   
Reply With Quote
Re: progress
Old
  (#8)
Persephone
Member
 
Status: Offline
Posts: 25
Join Date: Mar 2014
Location: Indonesia
Default Re: progress - 12-06-2017

Don't worry, we just need a waypoint to make BOT takes a flag and returning it to their base.
   
Reply With Quote
Re: progress
Old
  (#9)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 142
Join Date: Apr 2011
Location: Australia
Default Re: progress - 17-06-2017

Yeah I've got the waypoints, it's just the finding that isn't working.

Anyway, someone on ModDB reported that currently single player doesn't work with Sandbot. I've got a fix which I'll test some more tomorrow then release.
I also swapped MetaMod-P for MetaMod on Linux at least as MetaMod-P has frozen up every time I've used it bar one.
   
Reply With Quote
Re: progress
Old
  (#10)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 142
Join Date: Apr 2011
Location: Australia
Default Re: progress - 22-07-2017

Finally got bots to capture the flag in Opposing Force CTF: turns out my code was all fine but the map I was testing on (op4ctf_hairball) has the slippery ice in the middle and the slipperyness doesn't get reset once you get off the ice (see https://github.com/ValveSoftware/halflife/issues/1542). This meant that even though the bots could navigate to the flag they would almost always slip off the thin pathways.
You can see some screenshots at https://github.com/tschumann/sandbot...nshots/22-7-17

edit: still not ready to ship yet - once bots have captured a flag and get it back to their own base they don't realise they no longer have the flag.
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com