.:: Bots United ::.  
filebase forums irc server wiki web
cubebot epodbot fritzbot gravebot grogbot hpbbot ivpbot jkbotti joebot
meanmod podbotmm racc rcbot realbot sandbot shrikebot soulfathermaps waypoints yapb

Go Back   .:: Bots United ::. > Cyborg Factory > POD-Bot mm > Common Questions
Common Questions Are you seeking help ? Get it here !

Reply
 
Thread Tools
Re: Turn off Bots shooting back after Teamattack
Old
  (#61)
joeysmile
BRUT.me
 
Status: Offline
Posts: 25
Join Date: Aug 2013
Default Re: Turn off Bots shooting back after Teamattack - 3 Weeks Ago

Thank You very much, sadly it restarts the server just before creating the bots, could u doublecheck the code?
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#62)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,595
Join Date: Jul 2004
Location: Bulgaria
Default Re: Turn off Bots shooting back after Teamattack - 2 Weeks Ago

Hey. Sorry to head that. Anyway it has been a busy week for me, tomorrow I will try to look what is wrong.
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#63)
joeysmile
BRUT.me
 
Status: Offline
Posts: 25
Join Date: Aug 2013
Default Re: Turn off Bots shooting back after Teamattack - 2 Weeks Ago

no problem thank you, another friend tested them locally and he managed to run the bots, but the pb_ffrev cvar does not work for him, even if it is set to 0, the bots still revenge
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#64)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,595
Join Date: Jul 2004
Location: Bulgaria
Default Re: Turn off Bots shooting back after Teamattack - 2 Weeks Ago

Ok, here you are a new build that I've actually tested. It is working perfectly for me.

P.S. @KWo Your static variables are killing me...
Attached Files
File Type: zip podbot_mm-ffrev.zip (236.5 KB, 6 views)
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#65)
joeysmile
BRUT.me
 
Status: Offline
Posts: 25
Join Date: Aug 2013
Default Re: Turn off Bots shooting back after Teamattack - 2 Weeks Ago

yes it is working for my friend without problems, but it keeps restarting the server for me :/ what did u do different than the original version of podbot, did u use a newer compiler? I have xp on that machine and a little bit older version of hlds
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#66)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,595
Join Date: Jul 2004
Location: Bulgaria
Default Re: Turn off Bots shooting back after Teamattack - 1 Week Ago

Yep, the build I did is not compatible with Windows XP at all. Why would someone use an operating system that is not supported several years already? You should go at least to Windows 7 SP1, the older version of hlds will still run fine.

Anyway if it is very critical for you I can instruct the compiler to create an XP compatible build but I will be able to that tomorrow.
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#67)
RoboCop
vBulletin Veteran
 
Status: Offline
Posts: 154
Join Date: Feb 2013
Location: Dundee, Scotland
Default Re: Turn off Bots shooting back after Teamattack - 1 Week Ago

Well XP did die in April 2014 and is no longer safe to use. And Steam will no longer support XP by the start of 2019.

So you maybe best to move onto Windows 10 (this OS isn't good on privacy matters) or maybe try some other OSes by xmas.





vBulletin Webmaster since 2001
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#68)
joeysmile
BRUT.me
 
Status: Offline
Posts: 25
Join Date: Aug 2013
Default Re: Turn off Bots shooting back after Teamattack - 1 Week Ago

@The Storm If you would be so nice, I will be really gratefull, If u come to Slovakia, just write to our livechat @ chat.brut.me, gotta few beers for ya


it is an old notebook, that I use for these servers, I am not sure how good it would behave when reinstalling to a newer system, for now everything is working as it should, except this issue of course
on my personal notebook I have windows 10 and it is sometimes really pain in the ass, I would not recommend to use a notebook with this system as a server, anyway will see how long this old notebook will live, it has a lot of parts broken, but surprisingly it still runs
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#69)
The Storm
Council Member / E[POD]bot developer
 
The Storm's Avatar
 
Status: Offline
Posts: 1,595
Join Date: Jul 2004
Location: Bulgaria
Default Re: Turn off Bots shooting back after Teamattack - 1 Week Ago

Here you are a Windows XP build. As you can figure I don't have XP to test it so you will be the lucky one to try it out first.

I'm also uploading the sources as promised. I based my work on the latest stable version V3B22 and marked all the changes with my nickname "The Storm" if someone is interested in integrating them with the latest beta. With the sources I also upload a project files for Visual Studio 2017 Community ready for building with Windows XP compatibility.
Attached Files
File Type: zip podbot_mm-xp.zip (230.7 KB, 3 views)
File Type: zip podbot_mm-V3B22-src.zip (978.6 KB, 2 views)
  
Reply With Quote
Re: Turn off Bots shooting back after Teamattack
Old
  (#70)
joeysmile
BRUT.me
 
Status: Offline
Posts: 25
Join Date: Aug 2013
Default Re: Turn off Bots shooting back after Teamattack - 1 Week Ago

thank you and yes, you are the Boss it is working now like a charm remember me, when u visit slovakia
btw: I checked the beta changelog and there are a few nice changes, how to integrate the changes into the beta bots, just copy them and compile with visual basic 17?
  
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com