Thread: progress
View Single Post
Re: progress
Old
  (#144)
tschumann
Moderator
 
tschumann's Avatar
 
Status: Offline
Posts: 241
Join Date: Apr 2011
Location: Australia
Default Re: progress - 26-04-2018

Quote:
Originally Posted by RoboCop View Post
Nothing much its just they don't seem to combat at the best it can at bot_skill 1, unlike the other HL1 bots I've used...
Hm, coincidentally I just tidied up the bot_skill code and noticed that bot_skill 1 wasn't using the top level of accuracy available.

Quote:
Originally Posted by The Storm View Post
E[POD]Bot is working fine with Metamod and Singleplayer. You can check there.
Thanks I'll check it out, though I thought E[POD]Bot was for Counter-Strike and not for any single player game.

Quote:
Originally Posted by RoboCop View Post
I just had this crash from your latest SB 0.4.2 build:-

Code:
../common/singleprocesspipe_any.cpp (200) : Assertion Failed: m_Peeked.second == false || m_nEventCount > 0

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 0xf1a58b40 (LWP 14229)]
0xf2e87a0a in ?? () from ./steamclient.so
(gdb) bt
#0  0xf2e87a0a in ?? () from ./steamclient.so
#1  0xf256f900 in ?? () from ./steamclient.so
#2  0xf2569c78 in ?? () from ./steamclient.so
#3  0xf255ffac in ?? () from ./steamclient.so
#4  0xf25626aa in ?? () from ./steamclient.so
#5  0xf2563536 in ?? () from ./steamclient.so
#6  0xf2e8f420 in ?? () from ./steamclient.so
#7  0xf2e8e09b in ?? () from ./steamclient.so
#8  0xf2e8e25d in ?? () from ./steamclient.so
#9  0xf2e90b63 in ?? () from ./steamclient.so
#10 0xf7e9af72 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xf7dd143e in clone () from /lib/i386-linux-gnu/libc.so.6
(gdb)
Hm, not sure what's going on here but it looks like a crash is Steam? Do you have a debugger attached?
  
Reply With Quote