.:: Bots United ::.

.:: Bots United ::. (http://forums.bots-united.com/index.php)
-   Common Questions (http://forums.bots-united.com/forumdisplay.php?f=51)
-   -   pb menu doesn't work (http://forums.bots-united.com/showthread.php?t=5669)

KWo 18-04-2009 20:38

Re: pb menu doesn't work
Read carefully this topic from the first post, then You will know amx_pbmenu is not the command invoking build-in podbotmenu. amx_pbmenu is invoking the menu looking the same as podbotmenu, but it works thanks some amxx plugin, but this topic is not about it).

FR0NTLINE 23-06-2009 16:21

Re: pb menu doesn't work
I've read everything i could, but I am lost still. I'm trying to make waypoints on a server I made on my computer all my bots are running with amx I have the key binded bind "h" "pb wpmenu" And every time I hit that key I get this message.
You must be the host of a listen server to use this command
I'm also on a router and maybe I'm missing something. I don't know.
Appreciate the help of any sort, THANKS.:shit:

FR0NTLINE 04-07-2009 02:34

Re: pb menu doesn't work
GOT IT! It's easier to make a dedicated server /HLSERVER VALVE FOLDER then drag all the amxx shit to your cstrike folder. Then Make a file called listenserver.cfg and put that in the cstrike folder.

LeviN 13-03-2010 02:17

Re: pb menu doesn't work
I have tried it in my server and it seems to not work.

After doing what this tutorial says I get this as a message:

Unknown command: pb

KWo 13-03-2010 08:02

Re: pb menu doesn't work
If the manual wasn't sufficient - read the whole topic - yes about 11 pages - but don't be so lazy. Because I'm not going to reapeat the same answer over and over again...

TheTrueDiablo 27-08-2012 05:29

Re: pb menu doesn't work

Originally Posted by KWo (Post 61221)
If the manual wasn't sufficient - read the whole topic - yes about 11 pages - but don't be so lazy. Because I'm not going to reapeat the same answer over and over again...

The way you explain it all makes sense to most but some get confused, and on a dedicated server typing the "restart" command won't allow access to the pb menu to those who can't get it here's what i did to fix the issues i had like KWo said

Server side setup:

C:\HLServer\cstrike\addons\podbot\podbot.cfg thats the file you need to access on the server inside this file heres what needs to be changed.


# Sets the password to have access to the podbot menu on DS by 'pb menu'
# console command typed in client's admin PC or called from the binded key.
# Example of bind on Your client PC:
# bind "=" "pb menu"
pb_password "Password1"

change the bold text to whatever you want now for the next part

Client Side settings:

C:\Program Files (x86)\Steam\steamapps\"steamuserid"\counter-strike\cstrike

in that folder create a text file "autoexec.cfg" like KWo said previously make sure to have hide known file extensions checked off or the file will be "autoexec.cfg.txt" and will not work if you already have this file then just add the following to it


setinfo "_pbadminpw" "this is the same password you made in the podbot.cfg file"
bind "=" "pb menu"

After all this has been done type exit on the console of your server this will close the server all the way then restart the server and it should then work """""THIS INFO IS FOR DEDICATED SERVERS ONLY FOR NAMESERVER HELP ASK KWo""""""""

KWo sorry if i stepped on your toes or anything that could have upset you i just was frustrated and figured this could help others having issues like mine

KWo 28-08-2012 12:12

Re: pb menu doesn't work
Have You been reading this:

Originally Posted by KWo (Post 51450)
Yeah - it must be a text file. The mine just look so:


console "1"
exec graphic.cfg
exec blood.cfg

setinfo "_amx_pw" "my_amx_password"

setinfo "_pbadminpw"  "my_pb_mm_password"
bind "=" "pb menu"

setinfo "_yapb_pw"  "my_yapb_password"

exec buy.cfg

These bolded lines are related to podbot mm. As You can see from autoexec.cfg You can call other *.cfg files (if needed).
Make sure Your autoexec.cfg file isn't autoexec.cfg.txt (windows by default hides extensions for most known files types - You can unhide them in Windows Explorer's settings - Tools -> Folder Options -> View).

All times are GMT +2. The time now is 16:04.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.