.:: Bots United ::.

.:: Bots United ::. (http://forums.bots-united.com/index.php)
-   Sandbot (http://forums.bots-united.com/forumdisplay.php?f=85)
-   -   progress (http://forums.bots-united.com/showthread.php?t=10041)

tschumann 05-11-2016 11:49

I'll post about any breakthroughs or interesting progress I have here.

Today's breakthrough was getting Day of Defeat bots working: they'll go back and forth capturing points on dod_avalanche and win rounds. Currently only four player classes are supported but it does work.

tschumann 21-05-2017 06:56

Re: progress
So I investigated the crashing in Opposing Force CTF yesterday - it didn't crash immediately but when it did it was because it was trying to look up a non-existent waypoint (not sure why it would do that - I haven't touched the waypointing code in such a way that would break it). Anyway, I've started adding support for Opposing Force CTF.

Persephone 22-05-2017 22:00

Re: progress
Maybe we have a different opinion

In my opinion, when Sandbot playing on CTF Maps without any waypoints, it seems fine (like a deathmatch). But if you adding waypoint to the current CTF maps and saving it for the later play, after BOT joins then my game will crash. So it makes non sense if the game crash because BOT looking up a non-existent waypoint.

tschumann 23-05-2017 13:08

Re: progress
Yeah that's right - I added some waypoints and spawned some bots and the bot tried to use waypoint 6153 or something but there's a hard limit of 2048 waypoints, so it crashed.

Persephone 23-05-2017 14:19

Re: progress
Waypoint limit eh?

Is possible to fix it? I'm starting of lose any hope now -_-

tschumann 27-05-2017 04:03

Re: progress
No it's not a limit issue, something is generating an invalid waypoint id.
Sandbot is one of many things that I work on (http://www.teamsandpit.com/#sandpit, http://www.teamsandpit.com/#zcmp, http://www.teamsandpit.com/#basis, http://www.teamsandpit.com/#gssmt as well as other private/unannounced stuff) so things like this take time.

tschumann 10-06-2017 08:51

Re: progress
Getting further with Opposing Force CTF. I don't think the old flag/base finding stuff was correct or all there so I've fixed a lot of that up.
Now I need to find out why the bots aren't going to the flags...

Persephone 12-06-2017 20:30

Re: progress
Don't worry, we just need a waypoint to make BOT takes a flag and returning it to their base.

tschumann 17-06-2017 12:06

Re: progress
Yeah I've got the waypoints, it's just the finding that isn't working.

Anyway, someone on ModDB reported that currently single player doesn't work with Sandbot. I've got a fix which I'll test some more tomorrow then release.
I also swapped MetaMod-P for MetaMod on Linux at least as MetaMod-P has frozen up every time I've used it bar one.

tschumann 22-07-2017 07:31

Re: progress
Finally got bots to capture the flag in Opposing Force CTF: turns out my code was all fine but the map I was testing on (op4ctf_hairball) has the slippery ice in the middle and the slipperyness doesn't get reset once you get off the ice (see https://github.com/ValveSoftware/halflife/issues/1542). This meant that even though the bots could navigate to the flag they would almost always slip off the thin pathways.
You can see some screenshots at https://github.com/tschumann/sandbot...nshots/22-7-17

edit: still not ready to ship yet - once bots have captured a flag and get it back to their own base they don't realise they no longer have the flag.

All times are GMT +2. The time now is 18:22.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.