.:: Bots United ::.

.:: Bots United ::. (http://forums.bots-united.com/index.php)
-   Bug Reports (http://forums.bots-united.com/forumdisplay.php?f=49)
-   -   PodBot FPS drops in Windows 7! (http://forums.bots-united.com/showthread.php?t=8942)

Guest064 09-08-2011 20:28

PodBot FPS drops in Windows 7!
 
I have a problem when you start csdm with bots on Windows 7 drops sharply to 50 FPS and below when the server 12 bots. On Windows XP set up to 32 bots, fps held steady 99-100.


PC
Operating system Microsoft Windows 7 Ultimate
OS Service Pack Service Pack 1
Internet Explorer 9.0.8112.16421 (IE 9.0)
DirectX DirectX 11.0
mainboard
CPU Type DualCore Intel Core 2 Duo E7500, 2933 MHz (11 x 267)
Mainboard Gigabyte GA-EP45-UD3 (3 PCI, 3 PCI-E x1, 1 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN, IEEE-1394)
Motherboard Chipset Intel Eaglelake P45
System Memory 6144 MB (DDR2-800 DDR2 SDRAM)
DIMM2: Samsung M3 78T5663EH3-CF7 2GB DDR2-800 DDR2 SDRAM (6-6-6-18 @ 400 MHz) (5-5-5-15 @ 333 MHz) (4-4-4-12 @ 266 MHz)
DIMM3: Samsung M3 78T5663FB3-CF7 2GB DDR2-800 DDR2 SDRAM (6-6-6-18 @ 400 MHz) (5-5-5-15 @ 333 MHz) (4-4-4-12 @ 266 MHz)
DIMM4: Samsung M3 78T5663EH3-CF7 2GB DDR2-800 DDR2 SDRAM (6-6-6-18 @ 400 MHz) (5-5-5-15 @ 333 MHz) (4-4-4-12 @ 266 MHz)
Type BIOS Award Modular (09/18/08)
Video adapter NVIDIA GeForce GTX 550 Ti (1024 MB)


for Windows XP was all excellent.
Bots can not suited for Windows 7, please fix this bug.

Ancient 09-08-2011 23:24

Re: PodBot FPS drops in Windows 7!
 
I have a very similar Windows 7 setup, however, Windows 7 has different compatibilities with certain programs. Have you tried changing the compatability options for counter-strike?

There really isn't a difference for me when I open csdm whether I have 10 bots or 31. Plus I only have 4 GB RAM and I didn't have to use any comparability changes either.

The only difference between my setup and yours seems to be the RAM, Type of Processor and Graphics card.
I have 4 GB RAM, Windows 7 Home Preimum (64-bit) SP1, NVidia GeForce GTX 460 SE and AMD Sempron 150 Processor.

Have you tried changing your monitor refresh rate?

Were there anything you tried to change or edit before claiming this to be a bug?
What is the average rate of fps when in csdm?

Guest064 10-08-2011 09:04

Re: PodBot FPS drops in Windows 7!
 
Quote:

Originally Posted by Ancient (Post 63934)
I have a very similar Windows 7 setup, however, Windows 7 has different compatibilities with certain programs. Have you tried changing the compatability options for counter-strike?

There really isn't a difference for me when I open csdm whether I have 10 bots or 31. Plus I only have 4 GB RAM and I didn't have to use any comparability changes either.

The only difference between my setup and yours seems to be the RAM, Type of Processor and Graphics card.
I have 4 GB RAM, Windows 7 Home Preimum (64-bit) SP1, NVidia GeForce GTX 460 SE and AMD Sempron 150 Processor.

Have you tried changing your monitor refresh rate?

Were there anything you tried to change or edit before claiming this to be a bug?
What is the average rate of fps when in csdm?




Compatibility tried the same situation FPS sags.
The frequency of the monitor to change unnecessarily pointless thing is that server without bots csdm FPS 99-100 steadily, and with the bots have a feeling that the CPU is overloaded or something and sags FPS and this problem only under Windows 7, XP had no such problems. You can do this as a fix and then go back to XP is not a hunting ...

KWo 10-08-2011 20:36

Re: PodBot FPS drops in Windows 7!
 
Try with different bots (yapb, CZERO bots etc) and see if the problem happens with them under Windows 7, too.

Guest064 16-08-2011 00:58

Re: PodBot FPS drops in Windows 7!
 
Quote:

Originally Posted by KWo (Post 63937)
Try with different bots (yapb, CZERO bots etc) and see if the problem happens with them under Windows 7, too.

tried FPS sags, some bots lag ...

Ancient 16-08-2011 01:17

Re: PodBot FPS drops in Windows 7!
 
If YaPB lags then it might be a structure thing for both bots or perhaps one of your mods may be conflicting with them.

It would be good if you list all the things you have tried.

Guest064 17-08-2011 08:38

Re: PodBot FPS drops in Windows 7!
 
Quote:

Originally Posted by Ancient (Post 63952)
If YaPB lags then it might be a structure thing for both bots or perhaps one of your mods may be conflicting with them.

It would be good if you list all the things you have tried.

What fashions all can clash with the boats, too most that on XP, only on XP with фпс everything is all right...

Code:

; AMX Mod X plugins

; Admin Base - Always one has to be activated
admin.amxx                ; admin base (required for any admin-related)
;admin_sql.amxx                ; admin base - SQL version (comment admin.amxx)

; Basic
admincmd.amxx                ; basic admin console commands
adminhelp.amxx                ; help command for admin console commands
adminslots.amxx                ; slot reservation
;multilingual.amxx        ; Multi-Lingual management

; Menus
menufront.amxx                ; front-end for admin menus
cmdmenu.amxx                ; command menu (speech, settings)
plmenu.amxx                ; players menu (kick, ban, client cmds.)
;telemenu.amxx                ; teleport menu (Fun Module required!)
mapsmenu.amxx                ; maps menu (vote, changelevel)
;pluginmenu.amxx        ; Menus for commands/cvars organized by plugin

; Chat / Messages
adminchat.amxx                ; console chat commands
antiflood.amxx                ; prevent clients from chat-flooding the server
;scrollmsg.amxx                ; displays a scrolling message
;imessage.amxx                ; displays information messages
adminvote.amxx                ; vote commands

; Map related
nextmap.amxx                ; displays next map in mapcycle
mapchooser.amxx                ; allows to vote for next map
timeleft.amxx                ; displays time left on map

; Configuration
pausecfg.amxx                ; allows to pause and unpause some plugins
statscfg.amxx                ; allows to manage stats plugins via menu and commands

; Counter-Strike
restmenu.amxx                ; restrict weapons menu
;statsx.amxx                ; stats on death or round end (CSX Module required!)
statsx_gui.amxx        ; New Stats
miscstats.amxx                ; bunch of events announcement for Counter-Strike
;stats_logging.amxx        ; weapons stats logging (CSX Module required!)

; Enable to use AMX Mod plugins
;amxmod_compat.amxx        ; AMX Mod backwards compatibility layer

; Custom - Add 3rd party plugins here
amx_gag.amxx
high_ping_kicker.amxx
playerquit.amxx
server_restart.amxx

;snow.amxx


Ancient 17-08-2011 22:43

Re: PodBot FPS drops in Windows 7!
 
Quote:

Originally Posted by Ancient (Post 63952)
It would be good if you list all the things you have tried.

You claimed to also have used YaPB bots as well to see if the lag still existed.
Did you actually set up YAPB and see if they caused the server to lag?

If so, what else have you tried to claim it is the bots that are causing lag?
Do they lag only when you have CSDM enabled or do they also lag when CSDM isn't enabled?

Have you tried to add any other different kinds of bots like e[POD]Bot?

Try and disable certain mods and then try and see if PodBot MM still causes lag.


All times are GMT +2. The time now is 03:13.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.