.:: Bots United ::.

.:: Bots United ::. (http://forums.bots-united.com/index.php)
-   Grave Bot (http://forums.bots-united.com/forumdisplay.php?f=56)
-   -   Bugs in Gravebot 0.1 and 0.2 (http://forums.bots-united.com/showthread.php?t=3374)

hiyahin 09-01-2005 17:19

Bugs in Gravebot 0.1 and 0.2
 
Just to help clear everything that's been on the forum so far, these are the bugs found so far:
General:
  • Min/Max bots feature ( "SZ_GetSpace: Tried to write to an uninitialized sizebuf_t: ???" error. Quite a few bots also have this error)
S&I:
  • S&I loop and freeze (possibly due to bot spawning/weapons)
  • Teammate bot shooting friendly tripmines
Hopefully, this list will help Ghoul fix this bot. If there are any other bugs that I've missed, please post on this thread.

Kronikles 10-01-2005 00:40

Re: Bugs in Gravebot 0.1 and 0.2
 
The bots act kind of weird in si_urban in those corners...

They also always seem to be going offense and rarely on defense

CoCoNUT 10-01-2005 07:38

Re: Bugs in Gravebot 0.1 and 0.2
 
When you use my waypoints...in si_urban I tested camping-waypoints. They are not supported yet by Gravebot I think- added them only for testing and fun ;). Itīs the only map with camping-waypoints.

BuMHeD 10-01-2005 13:33

Re: Bugs in Gravebot 0.1 and 0.2
 
Thanks for helping Ghoul organize the errors Hiyahin. I would've done the same myself, but I didn't want to make his forums clogged with too many threads. I will post any future issues here. Goodluck Ghoul.

*~BuM~*

Kronikles 12-01-2005 01:38

Re: Bugs in Gravebot 0.1 and 0.2
 
also when the bots auto join some bots appear on the scoreboard

(i.e Grave 0 kills 0 deaths.)

but they are not in the actual game. I've seen this many times and when you attempt to kick them out the game freezes the moment the bot leaves the game. Is this whta happened Ghoul when you experimented kicking and adding bots??

hiyahin 12-01-2005 17:37

Re: Bugs in Gravebot 0.1 and 0.2
 
That hasn't happened to me before. Does the bots just stay in the spectator or do they totally not exist?

Kronikles 12-01-2005 21:31

Re: Bugs in Gravebot 0.1 and 0.2
 
they are on the scoreboard but not in the game. Not in spectator mode or anything. like half way through the game they are still on the scoreboard and have no score or deaths. When I joined that team, there was 1 person missing...

???:( ???:(

BuMHeD 12-01-2005 22:09

Re: Bugs in Gravebot 0.1 and 0.2
 
Actually, Kronikles... if you're playing HLDM... I think I know what you're referring to. This is actaully a bug in steam... and it happens in my server all the time. I call them "phantom" player slots. This usually occurs when someone joins/leaves at the same time or shortly after a map change or server restart. What is occuring is that your server loads the list of players in the server and then the client disconnects, therefore the server logs the player name on the list of players, but the ping will always be 0, and they will not really be there. When this happens on my dedicated server, all "phantoms" are cleared on the next map change or restart. Phantoms do not take up players slots, and sometimes disappear if a server is full (because the scoreboard cannot display more names than the sv_maxplayer variable specifies). Next time it happens, if it's just you and some bots, try changing the map or restarting the server and see if they go away. If not, then it's not the same thing.

*~BuM~*

EDIT: Another idea. In your gravebot.cfg file, if you use the "addbot" command to load bots when you start the server, you may want to add a short pause between them. It should look like this:
addbot Grave 3
pause 2
addbot Headcrab 2
pause 2
etc...
The pauses prevent bots from bottlenecking the server upon startup, and thus preventing crashes/freezes. If that doesn't do the trick, you may need more assistance from Ghoul.

Kronikles 12-01-2005 23:30

Re: Bugs in Gravebot 0.1 and 0.2
 
ill try that and see if it works.

E--------D--------I--------T: I seems to only happen on S&I and not on HLDM...

Ghoul 23-01-2005 17:04

Re: Bugs in Gravebot 0.1 and 0.2
 
I'm not sure what causes that, not in the slightest. It only happens every so often, and I can't figure out any obvious link to why it happens. :-/

Also, for a majority of the team to go on defense, the team has to have a pretty big lead. Usually in a bots vs bots game, this never happens because the bots are evenly skilled.


All times are GMT +2. The time now is 01:21.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.