.:: Bots United ::.

.:: Bots United ::. (http://forums.bots-united.com/index.php)
-   JKBotti (http://forums.bots-united.com/forumdisplay.php?f=83)
-   -   JKBotti Bugs (http://forums.bots-united.com/showthread.php?t=9449)

joeysmile 15-08-2013 14:57

JKBotti Bugs
 
hello,

i am running a few hl based servers, and half-life with opposing force have jkbotti installed.
I have a few questions and a few bugs to report, hope someone could give me advise.
i am running metamod 1.19 and amxmodx 1.8.1
automatic waypointing is turned on
autoballance on + autoballance in bot cfg on too
1. sometimes the bots are spinning and ignoring the players, not attacking, sometimes they are spinning at the wall and sometimes but when i tried it with adminmod on my old half-life installation, it seemed not to happen, have to test it more, strange
2.the bots are sometimes bugging the ip address of a player, it shows 127.0.0.1 like it was a bot but ping is showing real
3. on half-life teamplay there is other problem too, when a player disconnects and bot connects, or sometimes when swap bot from one team to another the bot is swapped, change its model, but plays for another team, like the engine has remembered him, so when u look at the scoreboard the bot is in one team, but has the color of other team and is playing for the other team. After he dies it fixes itself and it seems always

does it happen to someone?

now it is worse because i have put there ATAC (punishment for teamkilling and they punish you when you teamkill but u see the skin he is opposing team so u attack and teamkill)

thanx for the help in advance

here u can test it
http://vBrute.co.nr/amxbans/gameserversdetails.php

RoboCop 25-08-2013 22:20

Re: JKBotti Bugs
 
Have you tried using Metamod v1.21 or v1.21-P37 yet cos Metamod v1.19 no longer supports SteamCMD servers.

joeysmile 26-08-2013 19:33

Re: JKBotti Bugs
 
Quote:

Originally Posted by RoboCop (Post 65396)
Have you tried using Metamod v1.21 or v1.21-P37 yet cos Metamod v1.19 no longer supports SteamCMD servers.

i tried the new steamCMD version, but there were more things bugged, so i returned to the previous version of the server, the last version before steamCMD update and i tried the new metamod too, but it bugged half-life servers, i left it only in sven coop server, because it is necessary there and it is working there

joeysmile 17-03-2014 12:57

Re: JKBotti Bugs
 
I have fixed the jk_botti bug with IP messing on half-life servers, just use the aghl updated hl.dll, and its allright and the teamplay bug seems to be fixed tooo with this dll, but I am unable to get it work on Opposing force, so the problem is opfor.dll, its a very poor port...
hpb bots dont do that bug at all, strange

RoboCop 17-03-2014 15:42

Re: JKBotti Bugs
 
I'm sure why but my Linux Server side seems okay to me.

joeysmile 07-05-2014 23:23

Re: JKBotti Bugs
 
.....


All times are GMT +2. The time now is 00:24.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.