.:: Bots United ::.

.:: Bots United ::. (http://forums.bots-united.com/index.php)
-   Sandbot (http://forums.bots-united.com/forumdisplay.php?f=85)
-   -   progress (http://forums.bots-united.com/showthread.php?t=10041)

tschumann 05-12-2017 12:14

Re: progress
 
Could you also post the output of ldd sandbot.so?

I've got v2.24 of libc6 and v6.3.0 of libstdc++6 installed.

Nubzior 06-12-2017 19:57

Re: progress
 
I tried only your binary, didn't compiled by myself.

output of dpkg-query -l libstdc++6

Code:

ii  libstdc++6:amd64    6.3.0-18                      amd64                        GNU Standard C++ Library v3
ii  libstdc++6:i386        6.3.0-18                        i386                            GNU Standard C++ Library v3

output of dpkg-query -l libc6

Code:

ii  libc6:amd64  2.24-11+deb9u1    amd64                        GNU C Library: Shared libraries
ii  libc6:i386      2.24-11+deb9u1    i386                            GNU C Library: Shared libraries

output of ldd sandbot.so

Code:

        ldd sandbot.so
        linux-gate.so.1 (0xdc4d0000)
        libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xdc414000)
        libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xdc3f6000)
        libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xdc23c000)
        /lib/ld-linux.so.2 (0xdc4d1000)


tschumann 07-12-2017 12:14

Re: progress
 
Okay so it looks like libstdc++6 isn't in the dependency list for you but it is for me (neither is libm, but libstdc++6 explains the missing operator delete).

My libstdc++ is at /usr/lib/i386-linux-gnu/libstdc++.so.6 - where is yours? Also, I thought ldd showed all dependencies even if they couldn't be located.

Nubzior 07-12-2017 16:15

Re: progress
 
My is at the same place

tschumann 09-12-2017 05:25

Re: progress
 
Alright I've recompiled with g++ and have explicitly linked with libstc++: https://github.com/tschumann/sandbot...f5f6e71ba3c087
Let me know if those binaries work. If not please let me know what ldd returns, and try recompiling yourself and let me know what ldd returns (and if your compiled binaries work).

tschumann 09-12-2017 06:53

Re: progress
 
Also, I've fixed the waypoints not loading issue (stupid struct size and padding differences between Visual Studio and gcc).
I also tested MetaMod for Opposing Force on Linux and at least on my VM it has a tendency to hang on start but it does load (not sure if that was only a problem for but it's not a problem now anyway).

Re the undefined symbol - doesn't seem like a problem with the code but hopefully it can be resolved soon.

tschumann 09-12-2017 12:01

Re: progress
 
And on the master branch I've got single player support working now.
Still a bit of work to get the auto-kicking etc working though.

RoboCop 09-12-2017 12:32

Re: progress
 
Are you able to release the latest compiled G++ version of Sandbot for us to try?

Nubzior 09-12-2017 16:40

Re: progress
 
@RoboCop
tschumann have compiled binaries by g++ in github branch 0.4.1.1-hotfix

A tryied compile it by g++ some times ago but have error.

Code:

Auto-restarting the server on crash
Could not locate steam binary:steamcmd/steamcmd.sh, ignoring.

Console initialized.
Protocol version 48
Exe version 1.1.2.6/Stdio (dod)
Exe build: 14:13:30 Jul  5 2017 (7559)
STEAM Auth Server
Server IP address 213.251.186.93:27015
LoadLibrary failed on /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so: ./libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so)
Host_Error: Couldn't get DLL API from /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so!
FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/nubzior/dod2017/dod/./dod/dlls/sandbot.so!

Maybe you know whats wrong? I searched about CXXABI_1.3.9 on web and dont find any answer... :/

RoboCop 09-12-2017 17:11

Re: progress
 
I've just tried the latest fix for Sandbot on Op4 server and that CXXABI 1.3.9 error occurs on my side too.


All times are GMT +2. The time now is 03:27.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.