.:: Bots United ::.

.:: Bots United ::. (http://forums.bots-united.com/index.php)
-   Common Questions (http://forums.bots-united.com/forumdisplay.php?f=51)
-   -   podbot_mm_src_v3B23 compatibility with hlsdk and metamod-hl1 from alliedmodders (http://forums.bots-united.com/showthread.php?t=10033)

YuGiOhJCJ 26-08-2016 04:22

podbot_mm_src_v3B23 compatibility with hlsdk and metamod-hl1 from alliedmodders
 
Hello,

On my Counter-Strike 1.6 Dedicated Server on Slackware 14.1, I am using:
  • ambuild-965f21beb316e9f693b5236a9b33903625d673f1 [1]
  • hlsdk-a0edb7792a96998d349325bebab8ea41ec5cb239 [2]
  • metamod-hl1-18a10db686702e8ae9e0fcb5b5febf8881dc9c2d [3]
  • amxmodx-e24b9548d43c2f0d09d394cc1884b6d171bd2790 [4]
The dependencies are:
  • metamod-hl1 depends on hlsdk
  • amxmodx depends on ambuild, hlsdk and metamod-hl1
Now, I am trying to build podbot_mm_src_v3B23 [5].
The dependencies are:
  • podbot_mm_src_v3B23 depends on hlsdk and metamod-hl1
The problem is that podbot_mm_src_v3B23 seems to depend on hlsdk and metamod-hl1, the official ones from metamod [6] instead of the ones from alliedmodders.

The result is that if I build with the ones from alliedmodders, I have this:
Code:

$ make
g++ -O2 -fomit-frame-pointer -march=i586 -mtune=i686 -fno-exceptions -fno-rtti -DNDEBUG -Dstricmp=strcasecmp -Dstrcmpi=strcasecmp -Wall -Wno-unknown-pragmas -DOPT_TYPE=\"optimized\" -fPIC -I. -I../metamod/metamod -I../hlsdk/multiplayer/engine -I../hlsdk/multiplayer/common -I../hlsdk/multiplayer/pm_shared -I../hlsdk/multiplayer/dlls -I../hlsdk/multiplayer  -DLINUX -o obj.linux/bot.o -c bot.cpp
In file included from bot.cpp:17:0:
bot_globals.h:25:20: fatal error: extdll.h: No such file or directory
 #include <extdll.h>
                    ^
compilation terminated.
make: *** [obj.linux/bot.o] Error 1

Indeed, in the alliedmodders version of hlsdk, the "extdll.h" header is here: hlsdk/dlls/extdll.h whereas it is elsewhere in the official metamod hlsdk.

I guess that if my amxmodx addon has been built with the alliedforum version of hlsdk but the podbot_mm addon is built with the official metamod hlsdk, then I will have problem of compatibility at runtime.

Is there a podbot_mm_src_v3B23 compatibility with hlsdk and metamod-hl1 from alliedmodders?

Thank you.
Best regards.

[1] https://github.com/alliedmodders/amb...33903625d673f1
[2] https://github.com/alliedmodders/hls...b8ea41ec5cb239
[3] https://github.com/alliedmodders/met...febf8881dc9c2d
[4] https://github.com/alliedmodders/amx...84b6d171bd2790
[5] http://filebase.bots-united.com/inde...ct=view&id=380
[6] http://metamod.org/


All times are GMT +2. The time now is 19:28.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.