.:: Bots United ::.

.:: Bots United ::. (http://forums.bots-united.com/index.php)
-   Sandbot (http://forums.bots-united.com/forumdisplay.php?f=85)
-   -   progress (http://forums.bots-united.com/showthread.php?t=10041)

RoboCop 21-08-2017 18:32

Re: progress
 
Nice work.

Lifeisverystrangeindeed! 29-08-2017 00:48

Re: progress
 
Could you look into making OP4's bots smarter? As of now they act like HPB non waypointed bots that walk slowly at you but always hit your head no matter how fast you move. Possibly as smart as jk_botti?

tschumann 29-08-2017 12:17

Re: progress
 
Quote:

Originally Posted by Lifeisverystrangeindeed! (Post 66849)
Could you look into making OP4's bots smarter? As of now they act like HPB non waypointed bots that walk slowly at you but always hit your head no matter how fast you move. Possibly as smart as jk_botti?

Eventually yes - at the moment I'm working on tidying up the code a lot and slowly adding new features but as the code gets easier to work with I'll be looking at improving how the bots play.

Persephone 30-08-2017 21:41

Re: progress
 
Haha, I like if the BOTS are act like an idiot when walk, but when aiming at you, they would become a killing machine (especially if carrying tau cannon, gluon gun, or sniper rifle) :D

Move zig zag or try to avoid their shot is useless, they have 100% accuracy, which sometimes make hard challenge even for professional players.

tschumann 31-08-2017 12:08

Re: progress
 
Yeah I haven't really touched the base AI - it's just stock HPB bot (which is fine for me).
Eventually I'll look at making them more player-like.

tschumann 07-10-2017 10:03

Re: progress
 
Small update - people or may not have noticed that if you kick a bot then other bots still try and attack the last location it was at. This has now been fixed.
From this I'll look at getting bots to be kicked better and deal with increasing/decreasing player count better.

RoboCop 23-10-2017 20:35

Re: progress
 
I cannot seem to start my OP4CTF server using SB v0.4.1 for some reason. I did allow liblist.gam to load gamelinux_dll "dlls/sandbot.so" but this error popped up from my GDB terminal:-

Code:

LoadLibrary failed on /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so: /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so: undefined symbol: _ZdlPvj
Host_Error: Couldn't get DLL API from /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so!
L 10/23/2017 - 14:32:16: FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so!

FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so!

[Inferior 1 (process 1211) exited with code 0377]
(gdb) bt
No stack.


tschumann 24-10-2017 12:39

Re: progress
 
Quote:

Originally Posted by RoboCop (Post 66891)
I cannot seem to start my OP4CTF server using SB v0.4.1 for some reason. I did allow liblist.gam to load gamelinux_dll "dlls/sandbot.so" but this error popped up from my GDB terminal:-

Code:

LoadLibrary failed on /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so: /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so: undefined symbol: _ZdlPvj
Host_Error: Couldn't get DLL API from /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so!
L 10/23/2017 - 14:32:16: FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so!

FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/desktop/steamcmd/hlds/./gearbox/dlls/sandbot.so!

[Inferior 1 (process 1211) exited with code 0377]
(gdb) bt
No stack.


What distro are you using? I compiled on Ubuntu (my last VM became unusable and I'm still setting up a new one).
Apparently it's expecting a function called operator delete(void*, unsigned int) though for what class I'm not sure. If you're feeling adventurous the debug symbols are at https://github.com/tschumann/sandbot...master/symbols and there instructions for their use at https://github.com/tschumann/sandbot...ster/notes.txt
I'll try and take a look this weekend anyway.

RoboCop 24-10-2017 18:56

Re: progress
 
Quote:

Originally Posted by tschumann (Post 66892)
What distro are you using? I compiled on Ubuntu (my last VM became unusable and I'm still setting up a new one).
Apparently it's expecting a function called operator delete(void*, unsigned int) though for what class I'm not sure. If you're feeling adventurous the debug symbols are at https://github.com/tschumann/sandbot...master/symbols and there instructions for their use at https://github.com/tschumann/sandbot...ster/notes.txt
I'll try and take a look this weekend anyway.

Xubuntu 14.04 LTS

tschumann 26-10-2017 12:30

Re: progress
 
Quote:

Originally Posted by RoboCop (Post 66893)
Xubuntu 14.04 LTS

Does Sandbot v0.4.0.1 work for you? In v0.4.1 I upgraded my VM from Ubuntu 14 or 15 to Ubuntu 17 (so much newer versions of gcc, libc, libstdc++ etc).


All times are GMT +2. The time now is 17:40.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.